11th Gen BIOS 3.09 Beta release

I’m not seeing a failure to charge during sleep or during fully powered up operation on 3.09 on my i5 11th gen. Very strange.

So I’ve rolled back all the way to 3.06, because that’s what LVFS offered me, and it seems to be behaving well again.

@Kieran_Levin I’m afraid there might be more going on with this bug than what you’ve documented, because the “wait 2 minutes” did nothing for me either.

Yes, this problem (not charging while powered on) only showed up today after using 3.09 for a week.

That’s good…at least you know it’s not the hardware.

Yes I have a related issue with new magnetic charging cables, I bought a batch and when used on the Framework they all fail. The manufacturers have said the only other complaint was also from a Framework owner, though support has told me the two issue are not ‘related’

BIOS 3.09 still requires 12+seconds to hard restart the machine? I thought @nrp talked about reducing that?

I timed it again, the 8 seconds is more correct. No idea if it changed or I just timed it badly before.

I recall that too. But I think it was “something to consider”…with no specific on commitment and timeline. Or maybe there’s commitment…but no timeline.

Found it, here:

True, I had not seen it stated like a promise that it would be changed. Just a good idea, but not a critical showstopper by any stretch of the imagination. Bringing it up was also my way of saying, don’t forget about this amongst the way more important things Framework has going on lol.

Hmm. Not according to the embedded controller: PWRBTN_DELAY_T4 controls how quickly the EC switches into PWRBTN_STATE_NEED_SHUTDOWN, which after a tick or two of the power button task forces a shutdown.

Thank you for that. Tested on the laptop just now. It’s at 8 seconds, in alignment with the code.

I’ve noticed that after updating to the 3.09 BIOS that my machine won’t power on now unless I plug it into the wall not matter the battery charge level. This has happened not only after about a week but approx. 24h

We’re now at the start of ‘next’ week. Looking forward to the new update. :slight_smile:

After the update to BIOS version 3.09 my thunderbolt docking station TB3TRIPLEDOCKPD from i-tec randomly loses connection. Usually it connects again after a few seconds without further intervention. Before the update I did not observe this behaviour and the connection used to work for several hours without any interruption.

I’ve tried different cables, different usb-c expansion cards in different ports, but every time the loss occurred again. So I don’t think the reason is hardware degradation coinciding with the update.

Does anybody have similar problems? Is there a workaround that I could try?

I’m using Debian sid with kernel 5.18.5-1 on i7-1165G7.

Hi Viandant, I moved your thread to here as it will be of better use here, but I will also make sure that Framework is aware. I would suggest contacting support directly to report this.


1 Like

Thank you, @2disbetter.
I’ve also reported to support to make sure Framework knows about the problem.

Just want to report another failure to charge while shut down.

Batch 1, i7- 1185. Recently updated to bios 3.09
I shutdown the device yesterday at 25% or so. It was plugged in for a few hours before unplugging.
Waking up this morning, the charge was 22%.

The weird thing is that I believe it charged normally in that situation, immediately after updating the BIOS.

Note: same 45 watt Samsung charger and cable.

Yep, that has been reported a lot, just downgrade if it really affects you.

I have noticed that my DP module is not picked up after a reboot. I have to go into Windows to add a device before the system DP modual. I’ve tried re plugging thr cable and re plugging thr DP module. This issues only started after 3.09 update.

Batch 4 i71165G7 DIY

You might want to skip the magnetic cables, they are not part of the usb spec. That thread has some very knowledgeable people including the famous Benson Leung talking about how magnetic usb type c charging cables are a bad idea. At least from personal experience a couple years ago, the magnetic charging cables I bought fried a couple of my power bricks.

1 Like

Hmm! but it was a kickstart type idea, using Fairtrade gold and better wages for the factory workers so I feel obliged to support the intiative.

Then there’s the notion that it is only the Framework that has shown a problem, so I will do some more tests and hope not to trash any more cables. Power and laptop seem fine.

Thanks for your concern :slight_smile:


The FairTrade certifications aren’t exactly good, as you are just looking at the people in the manufacturing house not only the material suppliers, and you cannot fix this.