11th Gen Intel Core BIOS 3.10 Release

Downloaded and installed, no issues thus far.

Had no issues with fedora 36

1 Like

Alright, I’m trying it. The update through LVFS went fine. I just had to do a “fwupdmgr refresh” before I could see 3.10 as being available.

2 Likes

I’m having a similar issue, but I also had the same issue when I tried updating from 3.07. I’m also on Fedora 36, and I’m truly at a loss here.

I’ve made sure of the following

  1. DisableCapsuleUpdateOnDisk=true in /etc/fwupd/uefi_capsule.conf persisted (no hashtag) after reopening and closing the file
  2. fwupdmgr enable-remote lvfs-testing completed without error.
  3. The battery was not fully changed, AND it was plugged in with a USB-PD adapter, and the Laptop was charging.
  4. I closed the terminal, reopened, and fwupdmgr update was executed without any error (so far as I can tell)

When the laptop restarted, it just sent to the Fedora log in screen.

I tried manually selecting the update manager from the F12 BIOS menu upon boot. The screen turned black and read “fwupd-efi version 1.3 WARNING: No updates to process, exiting in 10 seconds.” After waiting it out, the screen briefly flashed blue before booted back into Fedora.

Anyone have any suggestions?

Doesn’t the update image get stored in a EFI partition? …and if that partition is nearly full…it can’t store the image for update? (I could be really wrong here).

Maybe check how much diskspace you have left on your EFI partition?

Just to clarify, the latest beta BIOS is 3.10, but the latest stable release is 3.07. Is this correct?

Correct.

UEFI upgrade from 3.07 to 3.10 went without a hitch.

  • Intel i7-1165G7
  • 32GB RAM
  • 1TB WD BLACK SN850 NVMe
  • Intel® Wi-Fi 6E AX210 No vPro
  • Linux Mint 20.3

I did have to reset

  • Maximum battery charge limit (it had reset to 100%)
  • Power button brightness (it had reset to max brightness)
1 Like

Went from 3.09 to 3.10 smoothly

The only issue, is when I press f12 it freezes. Have been like this with 3.03, 3.09 too

@Denes_Adam_Dolhay black screen freezes? Do you have quiet boot disabled?

@Kieran_Levin

Depends on when I push it. If I push before anything appears on the screen, then it remains black. If I press it when the POST is already visible, then it freezes on that screen

Yes, quiet boot is disabled

The only thing that is not stock is a 2TB Toshiba SSD KXG50PNV2T04 NVMe TOSHIBA 2048GB I carried over from my last machine

I was very happy to see the 3.10 BIOS release to fix the charging bug in 3.09. I have a dual boot system but this time I chose to run the .exe rather than the EFI version.

All went quite smoothly including recovery of the grub menus. When the install completed and the laptop rebooted it went (again) to Windows. But this time I had a suspicion so I shut it down entirely and then rebooted. The grub menus were right where I expected. Yay.

Now I cannot say whether the EFI path would have had the same effect because I didn’t reboot manually after it first came back from an EFI install.

On the (unsupported) assumption that it does not matter which path I take, I now prefer the .exe path because no USB boot and generally easier. Obviously, if I had a no Windows system installed that would not be an option.

Thanks for pushing out this fix! I was just troubleshooting this last night and confirmed the behavior with a charging meter. Great job, team!

1 Like

All, I cannot prove that my current problem is BIOS 3.10 caused but I’m having trouble figuring out what else it might me.

No WiFi! My system appears to have rebooted at some point after the update. I am confident wifi was working after the update. However, now it is not. I reapplied the update, just to be sure, but that changed nothing.

Is there possibly driver update for wifi that is involved?

I know I’m not using actual data to say why I no longer have wifi, other than the fact of it. This is damned annoying and not a little inconvenient.

Thoughts (not prayers) or suggestions appreciated. Thanks

Um, followup: all fixed. No idea why the WiFi went out but a throwback memory led me to the Windows Device Manager which a) recognized the hardware but saw a problem and b) to my amazement seemed to successfully update the driver and that was that.

It is not every day that I can give MicroSquash a shoutout but today is one of those days.

1 Like

I have had a similar thing happen where, for totally unclear reasons, neither Linux nor Windows can see the Wifi module—and the problem resolves itself (again, for unclear reasons) after not too much time (maybe a couple restarts? I really have no idea…). This has only happened twice and I have no way of reproducing it so there hasn’t been much for me to report to anyone, but at least now I can at least add a “+1”.

Is there any indication that BIOS 3.10 addresses the slow battery discharge issue when the Framwork computer is powered down?

This is discussed in the release notes for 3.09, which this update supersedes: BIOS 3.09 Beta release

1 Like

Is anyone else having major issues getting fwupd to actually do anything?

I can’t seem to get mine to do anything useful. It’ll download an update, reboot into the fwupd splash, then reboot again to the OS, without actually having updated anything. No errors, but equally completely failing to be useful.

1 Like

@Crystalyne What fwupd command are you using? And what linux distro do you use?

Working command

sudo fwupdmgr update