1tb expansion card not being read

My 1tb expansion card is not being read. Any ideas???

Have you tried to reseat it? Tried it in a different expansion card slot? You could also try attaching it to your phone, if you have a compatible one. Is it visible in Disk Management, if you are using Windows?

Has the disk not been initialised?

Take a look at the device manager, and see if any of the USB drivers are not working.
I had a similar sounding problem, and had to delete and rescan hardware to resolve it.

I am using Pop OS

And my other flash drives are working fine, just not my 1tb.

Right now, I do not have a phone that can read usb-c and my computers are too old for usb-c

This is my first device with usb-c (without counting my phone which is having issues reading data)…

I will try to use my friend’s laptop and see if it works there.

For giggles if you have a USB-C module, plug the 1 TB module into that like the glorified flash drive it is to see whether it shows up properly then.

1 Like

Okay, good news. It suddenly started working. Don’t know why it didn’t before.

That said, does anyone have any ideas why it didn’t read the drive before now??? It just suddenly worked and that worries me.It just feels so random.

1 Like