Active Signal Resolution Wrong

Using Windows 10, I plugged in an external monitor via HDMI. Everything was working fine at first. But after a few times of removing and plugging in the monitor, the monitor started to only show up as 640X480 resolution when it’s supposed to be 1920X1080. After looking it up I discovered that it’s the active signal resolution that doesn’t match (Settings>Display>Advanced display settings). The found solution was the then go to “Display adapter properties for Display 2” and then “List all modes” to change it. However, the only option on the list is 640x480. I’ve made sure both windows and my drivers are up to date. I tried a different monitor (same make and model) and a different HDMI cable and have the same issues. Just like the first monitor, the second one worked at first, but stopped working after I removed the HDMI and then put it back. Any ideas?

For the drivers, could you check if the latest released directly by Intel change the behavior: Intel® Graphics – Windows* DCH Drivers

I have the Intel Graphics Command Center. That and the device manager both say drivers are up to date when I go to update. :confused:

Is it possible there’s an issue with the HDMI port itself?

So I just tried my partner’s ultrawide monitor and it works perfectly fine, although that monitor is DP over USB C so it could still be the HDMI that’s the issue. I unfortunately do not have any other monitors to try at the moment.

So I just bought 2 new monitors. New HDMI cable. Still the same issue. It’s got to be an issue with the HDMI port. Going to contact support and see if I can get a replacement.