AMD Gang, any of you are planning to swap out the Mediatek WiFi?

By “not the greatest” you mean it utterly stinks under linux. My mediatek card hasn’t worked properly since kernel 6.1, and I see this is pretty common across laptops and distributions.

I’ve had about enough, and am ordering an AX210 card.

I’m not sure. It annoyed me that the MT7922/RZ616 would struggle on resume but, for the most part, it seems like kernel 6.9 came with some improvements with regards to the MediaTek drivers. It seems to behave better so I am not too tempted to go for the AX210 yet. Especially that the AX210 can have some firmware issues of it’s own at times.

My MT still takes 1-2 minutes to appear after a fresh powerup. Works fine on 6.1, but fails on any newer kernel. (I’ve tested up to 6.9).

What distro do you use? The firmwares and microcode distributed by your distro could have an impact on this. Current linux-firmware and linux package on Arch give me a better behaviour than before.

I’m on Manjaro, so mostly Arch. But you’re giving me an idea. I have a spare partition, and think giving it a fresh install might be worth trying.

I had no issues with the RZ616, but I recently re-installed everything on a new drive, and now wifi will take around 30 seconds to start from poweroff/suspend. The logs say the authentication timed out… The weird thing is that I can still boot into my original arch install, and the wifi connects immediately. I’ve been trying to figure out what is different between the two, but so far I can’t find anything (all same packages, all same configs)

I’ve also found the fedora live usb environment connects perfectly fine, so you may want to try that to see if it works there.

Finally, I found that iwd works completely fine. If you are using NetworkManager you can change the backend from wpa_supplicant to iwd and that may fix it.

Although, I have other issues with the RZ616. For example, occasionally the wifi speed will just tank to around 2Mbit/s, and the thing is giving me trust issues by occasionally completely disconnecting.

I finally installed an AX210 on my FW 16, and I can attest to the following:

  • Bluetooth range is pretty much identical
  • Wifi at first refused to select 6Ghz, but was getting more consistent performance on 5Ghz than before. It would use 6Ghz when I setup a 6Ghz-only network, but after a few minutes would disconnect.
  • 2 days later I noticed it happily running at full speed at 6Ghz
  • Peak throughput is consistently a little less than the MT, but it’s consistently much more at peak throughput.
  • No real difference in power management/battery life

This is on Fedora 40 KDE edition on my FW 16.

The firmware updates definitely improved it over the past few months I had, but I had an AX210, and tried it, and I’d say its better, but not shockingly different.