Arch Linux on the Framework Laptop 13

Got everything working on Arch except Bluetooth here. I just upgraded to 5.13.9 so its a bit odd since others are saying it worked as of 5.13.8. Going to try and do a downgrade to 5.12 and upgrade and see how it goes, if a reboot does not clear it up first.

On another note, I tested some games for fun in steam and the 1185 is a powerhouse for an integrated chip! Everything else is super snappy so far and I got fingerprints working fine with fprintd too.

I got bluetooth working well under 5.12.5 now. One Question I have though, has anyone had success setting up fancontrol? I tried running pwmconfig but it couldn’t find anything. Was running a test and the cpu hit 100C and I realized it was not pushing the fan very hard.


@SparkX120 just a note that we would expect temperatures to hit 100C for a few seconds at the start of heavy load when the CPU is operating at PL2 limits (>30W). The fan should then start to ramp up as the load continues and then the CPU will drop to the PL1 limit of 28W and temperatures should drop.


Hello everyone,

On my side im using Manjaro with my Framework Laptop, so far so good except on one thing. At the beginning i installed Manjaro with Gnome 40, everything worked, yet i wanted to try Xfce to check how it has progressed since the last time i used it (and to check if it’ll have improved the autonomy).

Since the test has been inconclusive about the autonomy (i had worse result than Gnome 40, and also the fingerprint isn’t usable yet), i reinstalled Manjaro w/ Gnome 40. Yet i ran into an issue and i don’t find an answer which would explain why it happened.

On the first install with Gnome 40, i enrolled my right finger with the fingerprint sensor, no problem. But on the second install with Gnome 40 distribution, Manjaro doesn’t want to enroll the same finger and return me this error (in the journal of fprintd):

août 10 19:36:32 NuxWorld fprintd[3363]: Authorization denied to :1.108 to call method 'Claim' for device 'Goodix MOC Fingerprint Sensor': Device was already claimed
août 10 19:36:40 NuxWorld fprintd[3363]: Device reported an error during enroll: Finger is too similar to another, try use a different finger

And the thing is that it work without problem with another finger (and i tried multiple times, it doesn’t work only with the right finger that i enrolled on the previous install), it’s like the sensor kept my right finger in its memory. Do you know how can i fixed that ?

Thanks a lot!

It does actually, the sensor stores the fingerprint data and just gives a pass/fail to the OS. Try this:

I tried, i have disabled fingerprint login in gdm and disabled the fingerprint reader in the bios, re-enable it again after a reboot, but my right index fingerprint looks still in the memory of the fingerprint reader :confused:

Maybe try unplugging the battery from the mainboard once you disable it in bios again. let it sit for 15 mins or more before trying again.

The fingerprint reader is “match on chip”, meaning it actually is encrypted and stored in flash in the fingerprint module. As @jeshikat notes, there is some method to reset the state. I’m not entirely sure how it is supposed to work, but there is a note here about fprintd-delete fprint - ArchWiki

1 Like

If anyone has /sys/kernel/security/tpm0/binary_bios_measurements on their Framework it would be great with a copy. Either upload it publicy, privmessage me or email me on

Seems like it’s missing on the one I have which is the case on some fault drivers but I’m not sure why.

It doesn’t contain any sensitive information and the goal is to figure out if self-enrolling secure boot keys would brick the laptop because of Option ROM during boot.

@Foxboron I also do not have the file. I tried mucking with the TPM settings in the firmware interface and still nothing. I’m going to keep poking at it.

Of note, I have TPM-based disk decryption working using systemd-cryptenroll. So the TPM is there and talking, just apparently not to the OS?

tpm2_pcrread from tpm2-tools also works.

So the TPM2 eventlog is not fetched from the /dev/tpm0 device, it’s fetched from the ACPI table, the EFI configuration table or another subsystem I’m not familiar with. So the fact that tpm2_* tools work and the tpm eventlog isn’t exposed in sysfs is orthogonal i believe.

Kernel bug or a ACPI issue on the system?

Still no luck.

It works only before a reinstallation (because it checks the /var/lib/fprintd folder).

I have the impression there is no way to purge the memory of the sensor if we forget to remove the fingerprints before a reinstall :confused:

There is actually a way to do this on Windows, but I’m not sure what the equivalent would be for Goodix’s Linux driver:

  1. Click on the search button in the Taskbar and type “Services”
  2. Scroll down and right click on Windows Biometric Service, and click Stop
  3. Open File Explorer and navigate to “C:\Windows\System32\WinBioDatabase”
  4. Delete the .DAT file that starts with “74B”
  5. Go back to Services, right click on Windows Biometric Service, and click Start

@Foxboron I have secure boot working with systemd-boot, sbupdate-generated unified .efi image. Thanks to systemd-cryptenroll, my disk is only decrypted if the secure boot process executes successfully (LUKS2 key stashed in TPM).

In case any of you Arch wizards might be able to help, I posted a support thread over on the Manjaro forums related to the behavior of the lid switch and suspend. I don’t actually think this is so much a Framework issue as an Arch and/or Manjaro issue, but I figured this is a great community and maybe someone here can help solve it:

I don’t know if this is specific to arch, but I thought I’d leave a note here that yesterday after a pacman -Syu and a reboot I was getting some warnings in the system logs from the kernel, and trying to bring the wifi card up with ip link set <device> up failed with an error that I forgot to write down…

The solution for me was to sudo rfkill unblock all and everything is working great again.

I’m just posting this here in case it’s somehow unique to the wifi card in the framework (I have the non-vpro DIY edition) since that’s the first time I’ve ever had that happen in ~8 years of using arch!

1 Like

Just wanted to say that I was able to install Arch with minimal issues. The one thing that took some time to figure out was that I needed to add i915 to MODULES in /etc/mkinitcpio.conf to get X11 to work without xf86-video-intel, as was suggested by the Intel graphics page on the Arch wiki.

Touchpad worked fine after applying my preferred settings using a .conf file in /etc/X11/xorg.conf.d/. I also disabled PS2 Mouse Emulation in the BIOS.

Fingerprint sensor works fine with fprint.

Planning on testing dual monitor support with two HDMI expansion cards next week.

Battery life while suspended (lid down) is pretty bad, but that’s not a huge issue for me. Need to investigate this more. I am using tlp for power management.

The lowest brightness on the screen is still pretty bright (much higher than my T480), but this may be a hardware limitation (non-PWM backlight is very nice though).

The Framework is much snappier than my T480, quite happy with the performance.

EDIT: forgot to say that I’m a little disappointed that the touchpad (or at least the current driver?) doesn’t expose touchpad pressure values (e.g. sudo /usr/lib/libinput/libinput-measure touchpad-pressure reports “This device does not have the capabilities for pressure-based touch detection”). This would enable some more customization of the touchpad, which I like about the Synaptics touchpad in my T480. Hopefully it’s something that the touchpad manufacturer could enable in the future?

EDIT 2: Also forgot to mention I use rEFInd as my bootloader. No complaints here, but don’t miss the Warning under " Installation with refind-install script" like I did, or you’ll need to reboot into the installation media to fix it…


fellow arch frame.worker here, loving everything so far. I’ve got the fingerprint sensor working with Gnome login and terminal sudo via PAM, but there is the alternative password prompt that comes up occasionally which does not allow a fingerprint. I don’t know what to call this other than an “Admin” Authentication box, and am having trouble searching the web because I’m not sure what it’s actually called.

For example, when you try to install software from the graphical Gnome Software, this sucker pops up:

Anyone know how to get the fingerprint dialog on this prompt?

Edit: Looks like this bug may be related After login in with Fingerprint reader on Lenovo Thinkpad prompted to enter password for unlocking the Keyring (#613) · Issues · GNOME / gdm · GitLab

I was hoping that the 5.14 kernel would fix the bluetooth issues, but it’s still not connecting for me. Has anyone else had better luck?

I got Bluetooth working on kernel 5.13.3. It took a few extra packages to get my Bluetooth headset working but I got there at the end.

What kind of errors are you getting @Anil_Kulkarni on the Blueetooth service? You can check with “systemctl status bluetooth”.