Arch Linux on the Framework Laptop 13

Well that explains a lot. Still new to the Linux community, looks like I’ll be switching editions. Thanks!

Of course! If you want something similar in my opinion I would recommend either Budgie or MATE with the Brisk Menu extension! Both are quite fine and MATE is less resource heavy!

Be aware of the bug that prevents you enrolling the same finger again after reinstalling your operating system.

I think if you remove the fingerprints first then you can reenroll them after a reinstall.

I have fingerprints working fine in KDE Plasma on Arch. I installed fprint and libfprint and it’s working well for me.


I’m quite sure I didn’t support fingerprints. Where are you setting fingerprints up?

I’m using a distro based on arch and kde called Garuda, I have fingerprints working reasonably well, after enrolling fingers I just needed to go into /etc/pam.d and edit the appropriate files.

Oh mind telling me how to do this also then!

Go to the configuration section, you will have to see what parameters work best for your system, here is the line I added to kde:
auth sufficient try_first_pass likeauth nullok

1 Like

If your boot usb doesn’t work, make sure to disable secure boot in the bios (check the bios post for instructions on how to do this). When I tried using my arch linux usb, it kept going to a black screen and going back to the “No boot drive found”. Disabling secure boot fixed this!

sorry all, don’t know if this is the right place for this.

i am having some trouble with bluetooth, even after downgrading. i’m a complete noob and have been trying to follow the arch wiki. i was at some point on 5.14 able to use bluetooth and was setting up pulseaudio, and after a warm boot I believe it stopped working.

running uname -r returns 5.12.15-arch1-1

running systemctl status bluetooth shows that bluetooth is running.

running bluetoothctl list returns nothing

warm and cold boots don’t seem to fix the issue, i have not been able to access bluetooth since.

i tried enabling, starting, and stopping the bluetooth.service.

also i am running a kde plasma with grub

Has anyone had any experience fiddling with the Framework’s UEFI boot options from Arch with efibootmgr? When I configured a boot option from the install USB environment, it disappeared when I rebooted…

I’ve been able to add one since using UEFI Shell (as supplied on the Arch install ISO) and setting the boot arguments with bcfg boot -opt but am still getting a kernel panic on boot for some reason - it seems like the arguments aren’t actually getting applied or picked up. I can only actually boot if I run the linux kernel manually from the EFI shell.

1 Like

Not sure if this will help, but I had the same problem originally. I fixed it by adding --removable to the grub-install line.

1 Like

Technically it’s supported, but there are no GUI elements merged yet so it all has to be done pretty manually

Has anyone had any issue with getting pulse/alsa to see the microphone in Arch? I have not ever been able to get it to detect the internal one. It worked fine with a USB sound card. I have not seen it brought up anywhere that I looked so far, so I wonder if I just missed something somewhere perhaps?


First of all, sorry for the late reply.

I’m using SDDM, so if you are not, YMMV. I installed fprint and libfprint, and followed the instructions in the Arch wiki (Fprint and SDDM) to modify /etc/pam.d/system-local-login and /etc/pam.d/kde to set as sufficient and I also made sure try_first_pass likeauth nullok was sufficient (first) in /etc/pam.d/system-local-login, to give the ability to use my password if the fingerprint doesn’t work (damn shower-fingers!) and then the last thing I did was enroll my fingerprints. $ fprintd-enroll will do that, or you can specify which fingers you want individually (check the fprint docs for more info).

This works flawlessly for me (except for the aforementioned shower-fingers) and I’m happy to offer more info for those interested.


Having the same issue as @Arsal_Asif but I am on the newest kernel: 5.14.14-arch1-1. I have WiFi working, but bluetooth does not work. I am running GNOME on Grub.

I tried downgrading to 5.12.15 but that did not fix my bluetooth issue. I can confirm bluetooth is running via systemctl but GNOME bluetooth settings do not work.

Any help is appreciated.

1 Like

After an update, now bluetooth works after cold boots. Warm boots still cause bluetooth to not work properly in gnome.

I was having major power problems, the laptop was actually hot. I was getting 2 hours of battery life.

I’ve installed tlp and the laptop is now cool to the touch.

Do this:

pacman -S tlp
systemctl start tlp
systemctl enable tlp

Now your isn’t a toaster.


Running Manjaro KDE Plasma, kernel 5.14.10. Bluetooth is still crazy spotty for me. Works once every 10 startups, maybe, and when it’s not working no controllers are detected when I scan with bluetoothctl. Idk what to do, and still pretty new to Linux. Any pointers?


Is there any way to control or monitor charging wattage? For instance to charge slower overnight or while the laptop is sleeping?

1 Like