Battery slowly drains when completely shut down

OK. So, we can say that the hwclock is not the cause of draining in the completely shutdown state.

I don’t want to derail from your specific troubleshooting, but I just wanted to say I have an identical issue in the i5 DIY version running Windows 10. To be ultra-clear: my battery loses 1-2% charge per day when completely powered off. Not sleeping or hibernating: shut down.

I was about to open a support ticket and see if they could help me, but since you’re chasing this here, I wanted you to know it’s happening on a different OS as well.

@Stephen_Rodgers Thanks much for replying here. I’m sorry you’re encountering the same issue, but at least this may help get more attention on the problem. I’ve tried everything thing I can think of so far, including pull all the USB-4 modules and letting the laptop sit, but still the same battery drain. I’m hoping this issue can be cleared up with a firmware/bios update, but my battery drain problems didn’t start until after the 3.07 bios update (which was related to another problem I had where letting the laptop sit would drain the RTC battery, so you couldn’t boot from the mains battery, even if it was fully charged.)

Prior to the 3.07 bios, the main/power battery was holding a charge just fine when the system was shut down.

And if you read through this whole post, Framework’s official support response was basically, “All laptops drain their battery when they sit, sorry about your luck.”.

1 Like

This information is probably very useful for @Kieran_Levin to track down the root cause.

I’m on 3.07 as well; I’m afraid I couldn’t tell you if it was happening on 3.06 or not though. But I can at least confirm it’s happening on 3.07 with Windows 10 as the OS.

And while Framework support may be technically correct that batteries in general lose charge over time, I’ve currently got 4 laptops in my house and the only one that goes from 100% to low 90s / high 80s over the course of a long weekend while completely powered down is the Framework.

1 Like

I have two other laptops in-house of different brands, and neither of them drain the battery like this. Running on Fedora 35, Samsung 980 Pro 512GB NVMe drive, 32GB of G.Skill SO-DIMMs. Again, not suspended, not hibernated, unplugged from AC and powered off, the laptop’s battery drains 14% in 12 days of sitting in my laptop bag.

Just trying to keep this issue visible, where my other post was buried…

This is also some new metrics, where I recorded the battery state and put a sticky note on the laptop, then checked it 12 days later.

Anyone know if Framework engineers are looking into this?

I saw the same issue described on an HP laptop I was given by work so if it’s some comfort, it’s not an issue isolated to the Framework.

In the following example thread one user saying the behavior stopped when the laptop was hard powered off by holding the power button. Might be worth a shot to test to provide more data points: https://forums.tomshardware.com/threads/battery-drain-on-hp-elitebook-when-shut-down.3727248/

Other example: https://h30434.www3.hp.com/t5/Notebook-Hardware-and-Upgrade-Questions/Battery-drain-when-powered-off/td-p/7216587

And for what it’s worth, one of the Framework team did in fact say they were looking into it:

Here we are a week later and the battery is now down another 11%. Sure wish there was a blog post or something letting us know some sort of update on the situation…

All the laptop I have owned (HP, Asus, Lenovo) have had this behaviour. I may be wrong, but my educated guess is that it’s “normal” because they don’t have a dedicated battery to hold the BIOS settings (and the Framework does not have such battery either).

Of all the laptops I mentioned, only the Lenovo can be considered “ultra thin”, but I don’t think that this would make a difference. As I said, my guess is that the main laptop battery is used to hold the BIOS settings. Furthermore, the drainage ratio reported in the topic is more or less consistent with what I’ve observed for the HP 250 (the “Linux” edition from 2010), whereas for the Asus and the Lenovo (my current laptop) it’s a different story: both have the option to keep the USB turned on to allow charging another device when they are powered off; for the Asus (X555YA) I was able to turn it off, whereas for the Lenovo I can’t.
Maybe the Framework is doing just that, and that would explain the battery drainage.
My final thought: I’ve studied electronics, and if Ohm law is still valid I can’t see why USB should be draining battery if nothing it’s connected to it, unless the expansion cards have some resistance, i.e. they represent a “load” when attached to the laptop, draining battery; and that, in theory, would explain the behaviour. As for my BIOS conjecture, I may be wrong and there might be some alternative methods to hold the BIOS settings while the battery is disconnected; but I’ve never investigated very thoroughly, and I’ve also observed that every time I’ve kept the battery disconnected (from the laptops I owned) for more than half hour, the BIOS settings were restored to factory, including the date/time.
It would be interesting to do this experiment:

  • try to disconnect all expansion cards, keep the laptop off for a while (I’m not sure if the author has disconnected all the ports or just some of them)
  • Try to disconnect the battery for a while, then reconnect it and see if it holds the charge; if not, then the battery might be defective

P.S. : I don’t own the HP or the Asus anymore, but I can try to do this experiment on my current Lenovo, and when I will receive the Framework I will keep an eye on the battery drainage when turned off.

There is an RTC battery in the Framework laptop. How do I replace the RTC Battery in my Framework Laptop?

It’s rechargeable (ML1220 type) unlike the CR2032s you may have seen on desktop motherboards and laptop motherboards.

The knowledgebase article does imply that it holds the BIOS state.

On BIOS version 3.06, a bug would prevent USB-PD negotiation from occurring if this battery went flat, so the laptop would not charge. Removing and replacing the RTC battery allowed it to charge, USB-PD negotiation to occur, and the main battery to charge again.

Note: if you ever need to pull this battery, follow those guides. Be careful, the battery holder is fragile. It really does need to be pulled with a pin.

3 Likes

if the rtc battery is rechargeable, maybe that explains the main battery drain, the rtc battery is constantly charging itself from the main battery.

1 Like

Oh, of course! I forgot that… How careless of me.

1 Like

Heh heh these things happen. Traditionally batteries like this would retain BIOS settings and the real-time clock. The article implies this is the case, and what’s it for if not this?

The battery also has something to do with USB-PD negotiation, which hints that it may also power the EC. This means it does more than just retain BIOS settings and is involved with some very fundamental aspects of how the laptop operates (charging, for one).

@RandomUser I bought the non-VPro WiFi card.

@RandomUser I also unplugged all modules and let the laptop sit for a week. Same battery drain.

No, I’m fairly certain the reason that option is there is so that you can activate it when opening up the machine to minimise potential damage. The battery reconnects as soon as the power supply is plugged in again.

2 Likes

If I use the “Battery Disconnect” option and leave the laptop unplugged for a day, I get no battery drain.

1 Like