[Beta] DisplayPort Expansion Card firmware update to reduce system power consumption

Could you reach out to our Support team?


Unfortunately, this is one we don’t have visibility on ourselves. The world of PC peripheral ICs is filled with opaque firmware.


Ah, sorry, I should have tested this path before suggesting it. An LVFS update path is still on development roadmap.


As I alluded to previously, I don’t suppose it could work when ran from Hiren’s BootCD PE which is basically just Win10 PE with extra bundled software utilities (e.g. 7zip, Macrium Reflect Free, etc)?

Do note that you may or may not need to copy the EXE onto the desktop first in order to run it.

(protip; the ISO is also compatible with Ventoy)

1 Like

I looked at that, it appears to be 64bit as well. The issue is seems to be that WinPE for 64bit can’t run 32bit software. Which the bundled updater appears to be.

Should be noted that this will be a non-issue for a properly installed version of Windows or for a Windows-To-Go instance.

You sure about that? I’m able to run software that is definitely 32bit in Hiren’s BootCD PE; I quickly confirmed this with the simple stand-alone EXE program “Header Investigator” which itself predates 64bit Windows:

Heck, according to the task manager, even the included copy of GPU-Z is 32bit (in fact it doesn’t seem like a 64bit of GPU-Z even exists on the internet).

I don’t know what to tell you. The WinPE shipped in the Windows 11 64bit ISO refused to run the updater claiming it was incompatible, assumed it was because 32bit.

I will admit I didn’t test it with Hiren’s BootCD because I assumed it’d give me the same error since its still just WinPE at the end of the day

Any update regarding the beta release of the HDMI card’s firmware? ETA?


In progress. We have a version that puts the HDMI card into a suspend state, but doesn’t put it back into a state where HDMI works, which is not so useful. We’ll share the firmware as soon as it is ready.


This is really great to hear this is being actively worked on - would it be possible in the future to share what fixes/ improvements Framework are working on/planning to work on?

Perhaps I missed it but this topic and a mention in the linux battery life thread are the first I’m aware of this even being acknowledged or actively being and worked on. Having to hunt down comments in long topics doesn’t seem a very easy way to keep abreast of the work being done.


Linux support is definitely something I would like to see for this update. I’ve been doing extensive analysis of power usage of various parts of the Framework laptop and I’d be happy to rerun those tests with a beta version…


I know this FW update was not intended to correct my specific issue but I didn’t have anything to lose.

I have been having problems with the DP card and a 12th Gen board. I have tried two DP cards and the first one would freeze and then shutdown my laptop. The second one would connect unreliably. Both cards would randomly connect and disconnect themselves from my Windows 11 install. The second card was provided after contacting Framework support.

In a “why not try it” moment, I downloaded the FW updated and applied it to the first card which gave me the most and repeatable trouble. So far, so good. No freezes or shutdowns.

One thing I would like to note. Framework provided the “original” FW in case you need to revert back. I noticed that the version currently on one card appears to be, which is odd that the revert FW provided is version 6. Seems the FW on the card is older than what is considered the original FW. Perhaps I’m reading the information incorrectly.

Thank you.


UPDATE: Well, I was wrong about having nothing to lose. Initially the FW update seemed to correct my problem, even though my issue was not the one listed here, as the DP card did not cause my laptop to freeze or shutdown. However, the DP card also stopped responding correctly. I figured I’d rollback to the “original” FW but the software just bricked the card instead. Now the card is not visible to the OS and so I can’t apply either FW update. :face_exhaling: Oh well, HDMI it is then!!


:expressionless: Man, that sucks…

1 Like

Something random for those running Linux like me and doesn’t have an Windows installation, looks like this wiki from Arch Linux might be helpful:

Not sure if it works though.

This sounds like the card may have originally been malfunctioning. You should reach out to our Support team around it.


On the HDMI Expansion Card version of this, we are still working through it. One thing to note is that these Expansion Card firmwares are ultimately a bit of a hack to work around bad behavior on the retimers in the laptop. We have firmware work currently in progress to force the retimers to behave better, which reduces the need for changes on the Expansion Card end.


What’s the likelihood of this firmware being released this year? (For the 11th and 12th gen models)

1 Like

I’ve experienced the same issue as James_Adams with the DP expansion card myself. More often then not it would not be recognized and once it does it disappears as soon as a cable is being inserted.

I still don’t know what scenario will cause it to spuriously detect the card but sometimes it does. Once this was the case I checked the firmware using the above tools and it seems I was on a even older firmware: So first I tried the “stock” firmware which flashed fine but this did not seem to help the problem.

Currently awaiting the magic to happen for the DP adapter to be detected before I can try…

Apart from the power draw, searching the support pages indicated more people experience this issue. Is the plan for this to be resolved with the new firmware as well?
(for what it’s worth I’m on a 11th gen i5 mainboard on windows 10)

Managed to get it re-connected and showing as USB device in windows. Flashed with the twice and now at least windows seems to be recognizing the expansion card more frequently. Unfortunately I still get a disconnect in windows when connecting the displayport cable (DP1.4 ) for my monitor to the expansion card. Cable is brand new so I don’t expect that to be the problem.

Bad news for me… neither the “normal” firmware nor the “beta” one detect my DisplayPort LG 34UC99-W monitor:

I guess I’ll have to contact support :confused: