BIOS guide

Thanks, will give that a try. Ventoy + BootCD seems to be just the ticket.

Note, Windows boot CDs may not properly update ME (see the 11th Gen Intel Core BIOS 3.19 release - #49 by Jeremy_Fitzhardinge and the followon comments about CSME).

@Stebalien Oh, thank you. I didn’t catch that. We will have to wait for a Linux installer with only the other fw parts up to date.

I am hunting for a way to receive notifications of new BIOS updates. Perhaps there is a forum thread I could subscribe to for this purpose, but I can’t find it.

There is another post above on this subject. I thought I was replying to it, but apparently I may only reply to the whole topic.

I think that I received an email a long time ago regarding the importance of updating from 3.06 to 3.07. But I haven’t seen any notification since then, and there is now a 3.19.

A number of support documents warn that updating BIOS may destroy some boot methods, e.g.:

Updating the BIOS firmware will erase NVRAM boot variables, This can cause some alternate bootloaders or operating systems to fail to boot. This may impact users of rEFInd and some Linux distributions.

The instructions for repairing a GRUB installation appear to require some sort of rescue system on external storage, which one ought to prepare before the BIOS update.

A clearer collected bit of advice would help.

I am running Ubuntu Studio 23.10 Mantic Minotaur on an 11th Gen Intel Core from Framework Batch 5 received in December 2021. If someone knows the specific risk associated with that combination that would help me a lot.

I have some neurological problems limiting the span of my concentration. I got through a DIY build, install and many updates of Ubuntu Studio. But, the complexity of the BIOS update possibilities is going just beyond my threshhold, and I still have the Version 3.06 that I was encouraged to update, and which now could be 3.19.

There is a 3.19 BIOS update for the 11th gen. 11th Gen Intel Core BIOS 3.19 release

The 3.06 BIOS is for the 12th gen. 12th Gen Intel Core BIOS 3.06 Beta

There is a 3.19 BIOS update for the 11th gen. 11th Gen Intel Core BIOS 3.19 release

The 3.06 BIOS is for the 12th gen. 12th Gen Intel Core BIOS 3.06 Beta

To clarify: The 11th Gen shipped in 2021 with 3.06 BIOS. The latest BIOS for 11th Gen appears to be 3.19. So there are still some 3.06 versions on 11th Gen that ought to be updated.

You could use a monitoring service that notifies you of changes on a page to get an alert when the BIOS page changes.
I use, but there are others out there, often free for small number of watches.

1 Like

I got a 13th gen intel chip a month or two ago, and didn’t touch the bios.

sudo dmidecode -s bios-version is 03.03


There is! Now I need to go find the script that enables that feature…

Edit: Found it

I had the keylightd script installed when I got my 12th Gen Intel, just upgraded to Ryzen 7040 series, and it’s now broken. Tried uninstalling and reinstalling, no dice.

Any advice?

Check out the recent 7 or 8 posts in the topic about the EC, which talks about differences on talking to the EC on the new AMD systems. I suspect it is related and a solution has been provided.

1 Like

Funny enough, you don’t actually need to do this! The firmware disables the media functions when there is no OS running. :slight_smile:

1 Like


I’ve been trying to update my bios as there are a few dmesg things which don’t make sense and there was an intermittent freeze thing, and the internet suggested it might be bios.

That is, [RESOLVED] Suspend behavior on AMD running Fedora 39 is the only thing which has the same dmesg output on these fora and that problem was fixed with a bios update.

(my dmesg looks like this:

[12336.252647] [drm:amdgpu_dm_process_dmub_aux_transfer_sync [amdgpu]] *ERROR* wait_for_completion_timeout timeout!
[12346.493098] [drm:amdgpu_dm_process_dmub_aux_transfer_sync [amdgpu]] *ERROR* wait_for_completion_timeout timeout!
[12356.732667] [drm:amdgpu_dm_process_dmub_aux_transfer_sync [amdgpu]] *ERROR* wait_for_completion_timeout timeout!
[12366.972860] [drm:amdgpu_dm_process_dmub_aux_transfer_sync [amdgpu]] *ERROR* wait_for_completion_timeout timeout!

going back a very long way )

So I tried to update the bios and then hit another problem:

hannnah@butternut:~$ sudo fwupdmgr refresh
[sudo] password for hannnah: 
Failed to connect to daemon: Error calling StartServiceByName for org.freedesktop.fwupd: Failed to activate service 'org.freedesktop.fwupd': timed out (service_start_timeout=25000ms)

so now i have two problems. anyone know how to solve either?


My BIOS appears differently for the most recent Framework Ryzen 5. My Insyde version of the BIOS has a GUI. And most critically, below I/O Interface there is no menu for Secure Boot. I cannot install Linux or update my BIOs without this.
Is there a method to populate this setting from a combination of other options? (I’ve tried setting up a Supervisor pwd)

If you press F2 during boot (the key typically used to enter Setup), it will drop you on a page with a number of options. You can get to Secure Boot configuration from there.


Thanks for the quick reply. I assumed that entering the settings from Boot select (F12) would get me to BIOS. They are separate guis. That’s it!

1 Like

Yeah that bit is quite unexpected, I was digging for hidden menus in the bios for a while before I figured that out.

In this thread’s first comment, I updated Framework Intel 12th gen, the current beta version as 3.08.

I found that the power consumption is high while in BIOS. My Framework Laptop 13 has a power consumption about 3~5W when idling on desktop running Linux or Windows, however in BIOS, a whopping 18W


That’s normal, the system is in a very basic mode in BIOS/UEFI and there are for example no specific power saving features active.