Can you help me revisit TRACKPAD ISSUES, pls?

So this isn’t a complain; well… I just wanna know the best course of action or not;
First, I was trying to use the HDMI user port to grab video out in OBS - which is in itself an issue because if you’ve ever tried that in Linux with the… well, you prolly know that pain. (Any tips here? Wonky display settings and no HDMI out is as far as I got.)

But anyway, to my issue… I forgot I even had the HDMI user port installed, and just went on my day… I started noticing that the trackpad wasn’t working even like… 20% of the time. So I immediately thought ok… I’ve heard of this Frame issue before and prolly have to open her up and fiddle with the trackpad location. Well, I’m glad I searched the community first - I read about users w/ USB user port and trackpad issues… so, I remove the HDMI user port - viola, the trackpad starts acting normally again…

Mind you; ‘normally’ still has around 5% of the time click issues - so… what do ya’ll think? Have I diagnosed the HDMI user port as the ‘worst’ culprit? Anyone know anything about getting the HDMI out working under Linux? And, if it were you would you open the Frame and try to get the trackpad dialed in any better? Its good - but about 5% less as perfect as my Apple hardware.

What think the community?
Thanks, all.

1 Like

Forget the HDMI expansion card…use a USB-C to HDMI cable instead.

IMO, any non-USB-C expansion card is a bit of a headache at the moment.

Dongle life is here to stay for now.

1 Like

This statement makes a lot of sense in my experience - is this for all users, across Windows too - or just us Linux guys??

I’ll visit the USB-C to HDMI cable, I hadn’t thought about that. Appreciate the suggestion. I really wish the user port cards worked - as its… well, not a MAIN reason I bought - well, yea. It was a main reason. On Arch Linux Timeshift is failing to even write to the USB expansion port.

For me, waiting for FW to address any expansion card issue is a symptom / sign that we’re locked in. So, I opt for fixes that can be addressed by others…by having swappable / modular components by other manufacturers.

p.s. This, depends on the particular issue you run into, can be OS specific. But I opt to go down a path that has a wider user-base, that is handle this via dongles. And so, generally speaking (for myself), after seeing the types of issues people have been experiencing with expansion cards, I’m currently not sold on the engineering output (i.e. Concept, great. Execution, not so much).

I haven’t had any issues with the HDMI card that I have noticed using windows 10. I have had friends use the USB-C to HDMI Framework card on their ARM and Intel based Apple laptops (various OS versions) without issue as well.

1 Like

Thats a good idea - I’m going to test the user port on a different machine… however, using Linux I have seen several issues from the user ports - again, I’m a guy - but long story short, I can’t simply plug my HDMI user port into OBS on an iMac and have it work like a simple raspberry pi does.

I’ve never used OBS. On Fedora 36, when I plug the HDMI expansion card into my laptop it works with my Dell 4k display right away, no configuration required.

The trackpad on my Framework occasionally doesn’t register my clicks. It’s frustrating, but it doesn’t seem to be any more frequent with the HDMI expansion card plugged in then with a USB C expansion card instead.

1 Like