Charging using anker 737 powerbank doesnt work

When I try to charge my framework 16 laptop using the anker 737 power bank, it doesnt work. A message pops up on the power bank screen saying low voltage warning, and the charger seems to keep stopping and starting charging. The orange LED charging indicator turns on and off every few seconds and the wattage reading on the power bank goes from 3w to 0.1w and repeats. I have tried different usb c expansion cards in different slots on the chasis. Ive tried the official usb c to c cable and my own 240w usb c cable. Charging using the official power brick works fine, as well as an anker power brick.
Anker have offered me a 70% refund however i would like to try and get it working before looking into getting a different powerbank.
I have all the latest driver updates including the ones from the driver pack.
(the OS is windows 11 pro even though I doubt that matters)
Thanks in advance!

The power bank seems to support 140w over pd 3.1, and the framework laptop supports 240w over pd 3.1 so it should work right?

power bank description:

email from framework regarding their charger:

That’s my understanding.


I have the 140W variant and it works for me but you need to enable trickle mode but in this mode it will be limited to 100W (charge/discharge rate) and the “USB A” port will always consume 0.1W while in this mode.

To enable trickle mode, press the power button twice ( in less than a second ) and you’ll see a green dot appear on the top left corner of the display. Press it twice again and it will eventually ( after two minutes ) turn off. The green dot will be gone but you’ll still see the “USB A” consuming 0.1W

I’m on a FW16 and I’m not sure if this is a BIOS or Anker issue yet.