Completely dead

So I go to boot my laptop this morning, and it’s just dead. No boot light, no charging indicators, nothing. I use it maybe once a week, so I don’t know what exactly happened.

I did pop it open, but I didn’t see anything obvious.

Where do I even start with this?

1 Like

When this happened to me, I plugged in the charger and waited until the charging LED came on.

If it won’t start charging after 15 minutes of being plugged in, unplug the charger, carefully remove the RTC battery (the plastic clip is fragile), wait a few minutes, reinstall the battery and charge.

When you get it back up and running, update to BIOS 3.07.


Not an expert, but I think support may have a better answer then us forum members, as their dedicated to this kind of issue! Not to insult forum members or anything though!
Edit: For if @Fraoch’s solution doesn’t work, it’s probably best to contact support! Sorry if this seems rude, don’t mean it in the, you dumb idiot why did you post it here way!


By all means, if what’s outlined above doesn’t work, please contact support.

My guess is that’s what they’d advise you to try first before starting an RMA.

I’m not posting in an official capacity but please try that first, being careful with the battery clip because some people have broken it. Once it’s broken, you have no chance of ever running it again, so be careful.


I had the same issue - no LED on power cable connection. Contacted support and after a few steps I was adviced to remove the CMOS battery for a few minutes and that solved it. Also disconnected the battery at the same time but I think CMOS one did it. I feel silly now not trying it on my own…


My Batch 6 i7-1165G7 arrived a few days ago and would not power on. Removing the RTC battery and re-inserting it a few minutes later worked for me. Thanks @Fraoch!


Well that’s exciting. The RTC reseat got it booting and charging again, but the screen won’t turn on. (And no, I’ve never touched those connectors.)

I guess I’ll let it charge overnight, and if it’s not better in the morning, try some things. (Yes, I’ll try an external display.)

Ok, one last follow-up.

Screen didn’t work this morning. But when I plugged in the HDMI module this morning, both the internal and external screens started working. And now everything is fine even with the module unplugged.

So I just need to do the firmware update.

idk computers

1 Like

removing the CMOS battery for a few minutes did the job for me too. :blush:
Seems like the problem might accure when the laptop is completely empty (ex. by shipping it from Taiwan to Europe) - And the BIOS needs an Update. Checking on it right now.

German → Falls jemand ein Problem mit der Stromzuvor beim Laptop hat, kann er mich gerne hier anschreiben, dann kann ich meinen Lösungsweg aufzeigen.

1 Like

I just had what may be a similar problem. I was using the laptop, set it aside and presume it either went to sleep or hibernated. But it would not turn on with the power button and plugging in the AC did not get a charging light. Dead.

Reading forum posts I concluded I needed to either disconnect the battery or the CMOS battery. Alas, I did both so I can’t say which worked. But when I plugged the main battery back in I had lights (!) and it booted find with 61% battery left.

My only other note is that, when I had noticed it lost battery slowly when completely shut down for a month I modified the BIOS to disconnect the battery. This may or may not have been a factor in my recent event but I turned that setting to NO for now.

I think, but don’t know, that setting means the laptop won’t boot on battery because, duh, it’s disconnected. If that’s the case (I may try testing) then the setting is only for long term storage, imho.

Anyway, no biggie to reset the CMOS if that’s all it takes but I’m leaving disconnect set to NO for now. :wink: