Display black on first boot

I just got my Framework 13 with ryzen and was eager to turn it on. It is a diy kit so I assembled it according to instructions.
I bought 2x48 GB ram from Crucial and 2TB ssd from Samsung.

When I put it all together and went to turn on the laptop, the power button lights up, the backlight of the screen also lights up, but nothing shows up.
No logo, no bios.
I tried reseating the rams, removing the ssd, plugging in second monitor. Nothing helped.

When I turn it off by holding the power button for 15 seconds, this sequence of indicator light blinks:

Any idea what could be the problem or what to try?

Thanks a bunch!

Have you searched?

For example

Try [black] [screen] [boot] [power] [display] etc.

I did read that and tried the suggestions without success.
The final solution in the thread is replacing the screen.
So I am looking for other suggestions.

1 Like

There are lots of other posts. I know it can be a bit of an effort reading up, but . . . .

especially if you have tried many things nor explained them, those replying may well just feel they have to repeat what has been said, which then may turn people off from responding.

However I’m sure most users are US time based so may be getting to grips with the day and get back to you soon.

All the best

These two pages are a bit old but I think that they still apply to the newer models, for the most part:

From the first link it looks like thermal sensor and fan are throwing error codes. I would try making sure the fan is plugged in, as well as reaching out to Support. Best of luck.

Thanks! Based on the post code signals, it should be this error:
#define PEI_MEMORY_INSTALL 0x80 // Simple Memory test
That probably means something wrong with RAM.
I got these RAM modules inside:
Crucial SO-DIMM 96GB KIT DDR5 5600MHz CL46, 2x48GB
Those should be compatible, right?

AMD Ryzen™ 5 7640U (up to 4.9GHz, 6-core/12-thread)

If I am reading the pages correctly, I believe that the blue on the first light is for bit 0, making the code 0x01. That ram should be compatible. I would try checking all connections - fan, nvme, etc, and then trying to boot with one stick of ram in the right slot, then one in the left slot. If you get it to boot with either stick solo in one of the slots, then shut it down and try adding the other stick in the other slot. Make sure they are fully seated, and before putting them in, inspect the pins in the slots to make sure none of them is faulty.

Best of luck, I hope that you get things working. If not, then I would reach out to Support for further troubleshooting.

A few things to check:

  1. are you waiting long enough. Memory training of new ram can take 15mins. Memory has to work before the bios screen can appear.
  2. try single ram instead of 2. If you plug in a usb keyboard, you can test without putting it all back together.
  3. single ram in either slot.
  4. if one ram chip works and you get a bios screen, them try a single other ram chip, in case one of them is faulty.
1 Like

The blinking pattern after Orange (start of post code section) is
Blue and seven times green. That should be 1 and seven zeroes. 1 000 000 0
Converted to hex that is 0x80
Which should mean:
#define PEI_MEMORY_INSTALL 0x80 // Simple Memory test
This would probably mean something with RAM or Bios.
I tried reseating the ram a lot of times with no avail.
Actually right now the blinkng pattern is gone, but the laptop still does not boot.

Any other ideas?


  1. I tried waiting overnight. Didn’t help.
  2. I tried single ram, I tried both ram sticks separately in different slots. Did not help.
  3. I tried it.
  4. Does not work either way. I do not have other ram available, but it seems very unlikely that both ram sticks would be faulty. They are original from Crucial and they look just fine.
    The ports look fine too.

Does anyone have an idea how to reset the mainboard or bios in the latest gen laptop?
In older generations you could remove the CMOS battery, but the new ones don’t have CMOS battery. I tried unplugging the battery, but it didn’t help. Is there something else to try?

Thank you

Press the chassis open switch in the center of the Mainboard 10 times. 2 seconds on, 2 seconds off, repeat 10 times. This is done while the laptop is switched off, but with the power cable newly connected.

There is a picture of the “chassis open switch” in this thread:

I will admit that I have to think about this every time, and I am happy to be corrected, but from looking at the section around the blinks from here: My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on, I think that you have the bits backwards. The first blink is bit 0, the last blink is bit 7, so you would have 00000001, 0x01, not 10000000, 0x80. Please do reply when you hear from Support regarding what the value turns out to be. Best of luck getting things working.

Decoding the blinks.

The RR is:
8 Red - No Thermal sensor detected
9 Red - No Fan detected and spins up

The GGG is reporting that the CPU, RAM and Display are OK.

Yes, this seems to be the issue. That is what support has told me.
I tried unplugging and plugging back the fan cable, but it didn’t help.
I still get the same error.

I also reset the mainboard using the chassis open switch. Did not help either.
Probably some issue with heatsink/fan.