[Fedora 35] Sound device change on screen lock

Each time I lock my screen the default output sound device is reset.

If I play music on some jack headphones and lock my screen I will not get any sound and when I unlock the screen I will have to select my headset again as the default output device.

This issue seems to only occur when playing music via the jack port.

I was able to solve the issue by creating the following file:
/etc/wireplumber/main.lua.d/50-alsa-config.lua containing:

["session.suspend-timeout-seconds"] = 0
["node.pause-on-idle"] = false

Unfortunately, this seems to break the sound setting page on Gnome but it’s the only workaround I found for the moment.

A related issue I stumbled on:

Anyone is also experiencing this issue or maybe has a better workaround to suggest?