Fedora 39 on the Framework Laptop 13

If you are using flatpak version of firefox you need ffmpeg to support all the codecs. It is annoying that firefox dont prompt you about this.

flatpak install org.freedesktop.Platform.ffmpeg-full


1 Like

@Cheng thanks for that. i popped that into terminal and installed the latest version, but it still doesn’t work. i closed and reopened firefox and restarted the laptop but it still wont play the videos.
sorry to be a total noob, but am i missing something? is there something else you need to do?

@demounit Do you mind checking in app store (by right-click on the app and select “app detail”, or go directly to the app store and search Firefox), whether you installed the flathub version or fedora version of firefox.

If you use the fedora version, do you mind installing and trying the flathub version? You don’t need to remove the fedora version if you don’t want to, just select flathub from the drop-down and click install. If you don’t see flathub as an installation source, you will need to run

flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo

However, if you follow the default installation recommendation for F39, it should include flathub as a source.

Fedora is very cautious to let their software even connect to proprietary software/codecs. Fedora version of firefox won’t connect to ffmpeg, since it supports proprietary codecs IIRC, even when ffmpeg is open-source.

In the guide, it says that the preferred method of installation is backing up the home directory and doing a clean install of Fedora 39 - why is this? It seems like getting things set up again, installing my extensions, logging into my apps, getting hardware acceleration and HEVC working, etc. with a clean install will probably take me a while, so I’d just like to know why this is the recommended procedure.

I can answer this - because it just works.

Now, will it work if you make absolutely sure you’ve fully updated F38, following upgrade to new release procedures? Should, yes. But guess what happens if it doesn’t - you end up doing a clean install anyway.

On any OS, I’ve always advocated for clean installs as they remove any little surprises that come along. That said, I have never had a problem with upgrading Fedora to new releases in recent years, but I have with other distros multiple times.

Tltr: Upgrade however best suits you, but, do have a backup of your data ahead of time. That’s just a good practice. If the update fails for some reason, you will be glad you have this in place.

1 Like

Confirmed Fedora 39 Workstation, updated, no longer defaults to X11 - it defaults to Wayland.

I still have to do the X, logout, login to wayland dance with the latest updates.

I also still have the issue. Fully Stock Fedora 39 and fully updated. Are you on the newer BIOS 3.03 whereas all of us are still stuck on 3.02?

Mario from AMD commented on my bug saying the updated BIOS would potentially fix the issue:

Ah ha! Yes, Mario is indeed from AMD. I have another unit with the other BIOS on it. Will test it tomorrow and comment on the Bugzilla issue.

i had the fedora version installed, but installed the flatpak version and i get the same results. still the same videos are blocked.

I think this documentation may help you.

Just please be aware that RPMFusion has packages that are not endorsed by the Fedora Project and can be less secure.

1 Like

i followed those steps, installed the repositories, but on the final step i get this error

sudo dnf group upgrade --with-optional Multimedia
Last metadata expiration check: 0:49:11 ago on Tue 17 Oct 2023 05:31:59 PM AEDT.
No match for group package "gimp-heif-plugin"
 Problem: problem with installed package pipewire-0.3.80-1.fc39.i686
  - conflicting requests
  - nothing provides pipewire >= 0.3.81 needed by pipewire-codec-aptx-0.3.81-1.fc39.x86_64 from rpmfusion-free
(try to add '--skip-broken' to skip uninstallable packages)


The Fedora 39 pipewire RPM package’s latest stable version is still pipewire-0.3.80-1.fc39. If you install the pipewire-0.3.82-1.fc39, it may fix the error above. The new version will be maybe to the stable within a few days. Then you may run sudo dnf upgrade pipewire.

Or you can install it by your own risk now by following “How to install” on the page below.


i installed the latest pipewire and the final step now works, but even after a restart firefox will not play the youtube videos.

it’s so odd.


i got real frustrated and uninstalled firefox then redownloaded it and it works now!!! woooooooo that’s so good!

thanks for all the help everyone!


Fixed in upcoming BIOS release: 2244221 – Framework 13 AMD Defaults to X11 on boot

hey guys I’ve got another Linux noob question.

when I reboot my computer, for a few seconds, I’m given a couple of options to boot into.

are these completely separate installs of fedora? the non prerelease version has a newer kernel version, but it’s automatically booting into the prerelease.

They are most likely the same installs but with different kernels. The naming is a bit odd but ether way I would think you want kernel 6.5.7

1 Like

Those are separate kernels available to boot. The 6.5.2 kernel is the original version shipped with the liveiso. The 6.5.7 is the updated version. You will note that 6.5.2 is the default. I wanted to be on 6.5.7, so I set that as the default using the following.

sudo grubby --set-default-index=0

The index comes from the following.

sudo grubby --info=ALL

My AMD Framework (with fresh Fedora 39 beta install and latest updates) drained about 40% battery with closed lid during the past 24h. Isn’t it able to enter the proper low power states?
Never had such a problem on my i7-8550U with Fedora 37/38.

Wiki-ed :slight_smile: