Fedora Linux 35 (Fedora 35) on the Framework Laptop

@Alireza_Haghshenas could try this…

1 Like

Batch 5 Intel i7-1165G7 (12M Cache, up to 4.70 GHz)

Installed Fedora 34, needed drivers.
Installed Fedora 35 no drivers needed (WiFi), fingerprint working no issues. Straight out of the box.
Used Fedora Media Writer.

Looking for help. Just installed Fedora 35 of a new Framework Laptop, and while moving the mouse and tap-to-click works, hard clicking (not sure if that’s the right term) and click-and-drag don’t work. I’ve tried installing Fedora 35 respins (F35-CINN and F35-WORK) and neither fixed the problem. Is there a way to tell if this is a software or a hardware problem? I’m a beginner to Linux and hardware, so any help would be appreciated.

There was an issue where the trackpad wasn’t “seated” properly or something. For some people, pressing firmly in center near the bottom will allow physical clicks to start working. I would try that first.

If that doesn’t help, you could open up the laptop and check both ends of the ribbon cable for the keyboard/trackpad and ensure it is fully seated.

1 Like

Has anyone run into issues powering their laptop on after a long suspend? This thread documents pretty clearly what I’m experiencing-- after closing the lid and leaving it for awhile, returning the laptop doesn’t turn on and won’t charge. I think it may have something to do with Fedora by default not configuring enough swap to hibernate on lid close? But I’m not sure if it’s something else entirely… I’m wondering if any other Fedora users have run into these same symptoms, and if anyone has a system configuration that prevents the issue

@ascii-fish you might be experiencing a known bug in the 3.06 BIOS

While you can’t update directly with Linux yet since the 3.07 update isn’t in LVFS, they’re working on getting that update into the LVFS testing channel. Otherwise you’ll need to update it via Windows (if that’s an option).


Hi @gclimer thanks so much for the advice! I updated my BIOS and the issue now seems to be solved.

Right now I am dealing with another issue, which is that the laptop seems to run out of charge while the lid is closed for any nontrivial period of time. This isn’t a dealbreaker, but it is a bit inconvenient and I don’t want to waste too many charge cycles on my computer doing nothing.

I suspect that this might be because Fedora does not by default allow hibernation due to swap being configured to ZRAM instead of storage. Running $ systemctl hibernate gives:

Failed to hibernate system via logind: Not enough swap space for hibernation

What I want to enable is either hibernate or suspend-then-hibernate on lid close. I am considering using this guide for hibernation which seems to meet my use case almost exactly. But I wanted to ask you here in this thread, does anyone have any experience enabling hibernation for a Fedora default install?

That guide looks similar to the one I followed, and my hibernate is working just fine. Do you have secure boot disabled? Are you using LUKS encryption on any of your btrfs volumes (EFI, boot, root)?

I created my /swap subvolume during install, though the rest of the guide seems to check out.

Disabling secure boot, I believe, is a prerequisite to allowing hibernate to work.

I ended up tuning in hibernation on my default fedora install. I have secure boot disabled and I don’t use LUKS. I posted what I did here.

I hope it helps.


Thanks for sharing it! What’s the reason you created the /etc/tlp.conf file newly instead of installing the ltp RPM package?

I installed the TLP like this seeing the installation document on Fedora, and editted the file /etc/tlp.conf.

$ sudo dnf install tlp tlp-rdw
$ cd /etc

$ sudo cp -p tlp.conf tlp.conf.org

$ sudo vi tlp.conf

$ diff -u tlp.conf.org tlp.conf
--- tlp.conf.org	2021-10-05 17:51:20.000000000 +0200
+++ tlp.conf	2021-12-31 21:53:38.867100574 +0100
@@ -342,6 +342,7 @@


 # Runtime Power Management for PCIe bus devices: on=disable, auto=enable.
 # Default: on (AC), auto (BAT)

Do you mean tlp package? I didn’t have a conf file at all… It could be that I didn’t install the radio components (tlp-rdw) as I did tlp only.

Ah yes tlp package, not ltp package. OK you didn’t install the tlp-rdw. But you also didn’t install tlp package too? The tlp package includes /etc/tlp.conf. So, how does the PCIE_ASPM_ON_BAT=powersupersave in the /etc/tlp.conf work wihtout the tlp package?

$ rpm -q tlp

$ rpm -ql tlp | grep etc


Replied on my mobile on the previous post… So, on further review, I think I mixed up my notes, and I modified the lines in /etc/tlp.conf

So you are right, I modified the file that existed after installing the tlp package. My bad!

1 Like

@LegacyJames OK. No problem! I am curious to know how your Framework Laptop’s battery life looks like after you tuned the battery life including hibernation. What is the number “discharge rate” by powertop command or “energy rate” by upower command on your environment now? I am not sure the numbers are proper to measure the battery tuning.

Related topic: Linux battery life tuning - #119 by junaruga

@junaruga It varies, as I’m typing right now I see 5.68 W on powertop. I haven’t used upower before and it doesn’t seem to output anything.

I usually I see around 5.5 - 9.5 W depending what I’m doing. I have 3 USB-C and 1 USB-A module in. I keep bluetooth usually disabled, keyboard backlight off, and screen brightness fairly low.

Oh, and hibernate works much better than s2idle… I had closed my lid, unplugged the power cord for about 3 hours, and it booted up at 100%.

I’m also having this issue…I’ve downgraded the fprintd drivers hoping for a resolution but it still doesn’t work. It continues to say the device has already been claimed.

@pyguydev - try running the python script on these forums to delete all existing fingerprints.

Funny you mention this…just found and ran :slight_smile: What a blessing


Thanks for sharing it. It looks great result!

Today I experimented just keeping closing my Framework Laptop for 3 hours. The result was the battery was reduced from 100% to 90% during the 3 hours. The powertop and tlp daemons are enabled. But no hibernate. Just using s2idle maybe. My BIOS version is 3.02. Hmm huge difference from you.