Finger Print Scanner

Having some issues with the finger print scanner. I have the same issue on both Ubuntu 20.04, 21.10, Fedora 34 and Fedora 35 beta.

The issue:
When enrolling a fingerprint, at some point in the process when lifting/placing my finger over and over, I get the message “Fingerprint device disconnected”. In Ubuntu seems to happen in the later half of the process, in Fedora right at the first tap. If you click cancel, then attempt to go enroll again, I get the second error about the device already being in use.

I cant seem to get beyond this point. Any suggestions?

1 Like

Well…I’m running Fedora 35 beta without any problems whatsoever. With the others you need to make sure you are running the latest kernel. If still having issues…I’d look at the underside of your keyboard and see if you notice any defect and also ensure the cable is attached properly.

Yea after struggling to get it to work in Ubuntu i decided to try fedora and got same thing. Ill open it up and take a peak.

Nothing inside looks out of place. I unplugged and reattached everything.

@EvilbunnyELITE I get the exact same message and followup error on Fedora 35, but haven’t bothered trying to fix since I’m enjoying the Fedora experience so far and don’t want to break anything…

Having said that, I might try a kernel upgrade and see what happens. I’ll post back here.

Edit: I’m tri-booting with Windows (scanner works) and Ubuntu (scanner doesn’t work), but have had the scanner working with Ubuntu previously. So I know it’s just down to something piddly.

@Chris_Eden I dont have a windows install, so I cant try it there, but good to hear im not alone it seems. I look forward to hearing about the kernel upgrade. Maybe I’ll try that too

@pyguydev - which kernel are you running specifically? I should be on the latest stable kernel already.

Fedora 35 Beta runs 5.14…the latest…wasn’t sure which kernel you were running. It may be hardware issue as I said before. I’d just check your cable connections both on m-board and keyboard/trackpad.

Everything works fine in Windows, and previously did (briefly) with Ubuntu, so I assume a tweak I did reversed it somewhere along the line.

Otherwise, I’m on 5.14.9, but I know there’s at least one stable version later than that. Not sure it’ll make a difference.

I know Fedora 35 is about to be outta beta and fully released on the world soon. My kernel version is 5.14.12-300.fc35.x86_64…and as I said…worked flawlessly out the gate

I’m also seeing this on Fedora 35 (5.14.14-300) - works fine for me on other distros and windows though, not sure what the issues is with latest Fedora. I’ve tried a bunch of other versions of libfprint but no dice.

This might be related to an issue with the fingerprint sensor that @Adrian_Sanabria mentioned.

a solution from @Henry_Luengas worked for me, but I’m not sure if this is the same issue.


Sure enough @CSab6482, this got me fixed right up! I can use my right index finger again!!

Thanks @Henry_Luengas!


@CSab6482 This also worked for me! Thanks!


Further update -
The solution from @Henry_Luengas works wonders, but sometimes an OS reinstall or dual boot situation can make it even more difficult to solve.
Below is a solution from @Devyn_Cairns that has saved me and many others in getting back their fingerprint reader functionality.

thank you for posting that, i was able to use that and actually get me fingerprints working for the first time!!

This worked for me on the latest Fedora 35, with caveats. I had a bunch of fingerprints enrolled in the OS that I needed to remove that I couldn’t get-at using fprintd-delete. At first I would get cryptic error messages when running this python script when trying to list or delete enrolled prints. If you encounter this, you might try using fprint-delete initially (e.g.):

sudo fprintd-delete right-index-finger my_user_name

Once fprintd has accessed the sensor, the above python script can then be used to delete the remaining prints registered with the OS that fprintd cannot access (e.g.):

python3 -d

Hope this helps.

1 Like

I don’t know what it was that in the end helped, but thank you guys for all the input. After having to refresh the popOS installation I could not get the fingerprint reader to work. All the things listed here said that there were 0 fingerprints registered to the device, but still it seemed to have fixed it.