Fingerprint reader fails to recognize enrolled prints on F36

Hey all! I just got my Framework and I’m loving it so far, with the sole exception of weirdness from the fingerprint reader. No matter how many times I delete-and-enroll or which fingers I use, when I try to login or use fprintd-verify, it universally fails to recognize my prints.

It’s kinda driving me insane; you can see in the screencap below that I actually managed a “perfect” enrollment, yet fprintd-verify still insists I’m a stranger. As far as I can tell the reader is functioning fine, it’s just that some nebulous thing has gone wrong between there and Fedora.

Any help or pointers would be greatly appreciated!


I had a similar problem - did you enroll some prints in a different OS, or even a different install of Fedora, then reinstall without removing the enrolled prints in the previous OS install? If so, there’s a python script here that removes any & all prints that are stored in the hardware.

@gjason - Nope, I went straight for Fedora as soon I finished assembly. (I already use it on my desktop; the out-of-box compatibility with FW just sweetened the deal.) I’ll run the script regardless, just to see.

Edit: the script reports zero enrolled prints. I ran it with the -d argument anyways, but still no dice.

I encountered a similar issue just last week.
it worked out-of-box with a fresh Fedora 36 KDE. I enrolled of my fingerprint and it worked as expected.
After a few days I tried to add more print(mine and my wife’s). It just won’t recognize any finger after new enroll. I check systemctl status fprintd.service apparently the first verify reports mismatch but what’s weird is right after the failed attempt it decide it does not like my fingerprints and went ahead deleted all of them. I was able to replicate the issue a couple times with just my one fingerprint and a couple prints from me/me and my wife. everytime after fail attempt it deleted all prints.
I tried restart/reenable the service and the python script as well. after a couple times of poking around and rebooting it seems fixed itself and I was able to register my print. at this point I decided to leave it be and not adding more prints.

I had a similar event where I had to re-register my fingerprint after a failed login.
I wonder which part of the process caused that.
OS was Ubuntu 22.04.

Unfortunately, it seems I’m still SOL. However, I have noticed another oddity: the reader seems to spontaneously “forget” prints soon after enrolling them, at least some of the time:

You can see here that I enroll a print, then try to verify it unsuccessfully. However, when I try to run fprintd-verify once more, it insists that the reader holds no enrolled prints. This has happened a few times before in my testing; it doesn’t occur consistently, and if it does happen it only seems to rear its head immediately after the reader first tries to poll the newly enrolled print.

Looks like we have similar issue here. Here is my journalctl log. hope it inspires someone to come up with sth. right now I managed to have only my right index finger working.

Heads up: using the program provided in the above post resolved the issue. I still have no fucking clue what the problem was, especially seeing as I never used the reader in Windows, but it’s fixed.

@MDZZ @Edward_Gray