First impressions

Like the design, generally. Love the display aspect ratio and that was one reason I bought one. I have not had the greatest experience getting it to work. I started with centos 7 which I got running without too much drama. However it won’t support the wifi card. My bad there because centos wasn’t listed as a compatible OS. I have used both mint and manjaro and currently prefer manjaro. So I made a boot usb for manjaro but the manjaro download page gives you some weird flavor of iso that destroyed the mbr of the usb drive so that was no good. Then I got that fixed and burned mint, but when I installed mint half the time the trackpad wouldn’t work and it took a power cycle to fix it. I blew 3 to 4 hours on these machinations and in mint, which is supposed to be trouble free for this machine I still didn’t get a loaded driver for the wifi. I didn’t buy an ethernet port, thinking I didn’t need one, so I’m in a bit of a nether world at the moment. Clearly I shouldn’t have done the roll-your-own version of this, but I never expected these kinds of problems on install of a suggested OS.

I will be looking to see whether there is a HW compatible wifi card that has centos support because that is what I am gravitating towards, however it would be nice if somebody commented on the manjaro fiasco. I’m perfectly capable of working through these kinds of things on my own but I thought I was buying something with a little more maturity of integration than I have seen thus far.

There is only one thing stopping me from throwing in the towel with this and that is the fact that hosting a windows 10 VM on a 2022 mac is still a not-ready-for-prime-time proposition. That and the display aspect ratio. And the fact that I kind of hate Apple a little.

I recently set up manjaro using ventoy and a downloaded iso (gnome version). Everything went smoothly. I’d give that a shot.

The ventoy site is down but sourceforge had it. bitdefender thinks the binary is ok. i tend to feel ok about projects with source on github
then I saw this and wondered:

thanks btw …tftfctfctfctfctfctfc

Good luck, I hope that it works better for you this time. If you run into issues, post here and the community will step up.

No luck no matter what. Balena etcher with mint or centos works. Balena etcher with manjaro does not boot. Rufus, both versions of yumi and ventoy all make a usb that wont boot. Tried ventoy with MBR and GPT. I can’t run gparted on mint because the wifi doesnt work for update.

When failing to boot you choose it in the boot menu then the boot menu just comes back.

f10 on boot does nothing,tried enabling network stack in bios…no effect on wifi

Have you disabled Secure Boot, which Manjaro USB requires?

Also worth checking out the Arch wiki, since Manjaro is based on Arch:

If you like CentOS, just get Fedora. It’s essentially the same, Fedora just has newer software and better hardware support.

Fedora also works pretty much completely out of the box including WiFi, Fingerprint reader and so on. (Only the headset jacket needs a minor config tweak for mic input)

thanks will try all this :slight_smile: BTW secure boot is off.

I just got up and was next going to go back to centos 7 complete and then bring over all the ISOs and a zipped ventoy on the USB, use centos to partition and then install ventoy on the SSD and see if it worked better there. I used to enjoy this kind of stuff and would learn the internals but I am old AF and time is precious and to be honest there is nothing inherently interesting to me anymore about the 42 different ways to make a bootable USB. I just want to get to the endpoint so I can do my work.

I wanted to use scientific linux, but it seems that that community is saying they are doing centos now, and then centos stream shows up as another thing. Much appreciate the tip on Fedora because I hadn’t sorted what that was exactly.

My SW priorities are: smooth virtualization of windows 7 and 10 so I can run certain CAD packages that have to live there and an environment that is friendly to scientific computation which is more or less obviously linux based for the kind of stuff I care about.

So next I will try Fedora using Balena

I have to take the ego hit here and say that I was wrong about secure boot. It was on. I remembered seeing it being disabled in the boot menu of the bios but when I just looked it’s not there. Did it move or do I mis-remember? I’m sure you know the answer :slight_smile:

Balena plus fedora:
boots ok but in install trackpad does not work so I cannot tell it to install
fortunately I bought a wireless mouse the day before because of other trackpad problems

installed OK

the first time I set up wifi it saw a half-dozen local networks but couldn’t connect to mine
when I turned off wifi with slider and on again it only saw my network but it couldn’t connect reliably

when I sat next to the router it would connect and work

i went into the bios and turned OFF the network stack (whatever that actually is…maybe it’s boot related since I think it was in the boot menu)

under fedora the trackpad will move the mouse but will not click or tap regardless of timing of the length of tap

I do not think the problem is the antenna connection because the very first time it saw all the networks my other laptop sees in that location

That’s where I am right now. Much better thanks but not out of the woods.

After some time I found that other networks were seen. I’m not sure what transpired exactly. Also found out how to turn on tapping so no problem there. I would like to force 2.4 GHz on the wifi for greater overall distance reliability. Will be looking into that. I cannot get clicking to work on the trackpad. By clicking I mean pressing down till it clicks. I prefer that to tapping because with tapping unintentional stuff always happens.

How would I have avoided some of these problems as a new user? Nothing in the basic documentation suggests that I need to fiddle with the bios to install manjaro. What’s up with the trackpad randomly failing under mint? If you guys hadn’t bailed me out I would have moved on but now I am happy that I can at least try out this HW platform.

Oh yeah, I guess secure boot breaks ventoy as well because I had mint ISO on that but it wouldn’t boot either.

thanks :slight_smile: