FIXED: trackpad in linux

I’m facing the same problem as @Sebastian and @Evan_Hazlett (libinput recognizes the trackpad as a generic PS/2 mouse in Alpine 3.15 – thus I have no right click nor scroll). Did one of you find a solution ?

Have you tried single-finger clicking in the front right corner of the trackpad? That is the equivalent to two-finger tapping on this trackpad in Ubuntu 21.10 (if tapping is enabled).


I just wanted to let everyone know: I have installed Kubuntu 22.04 (beta) on my Framework Laptop. At the beginning, I could not activate “tap to click” in the touchpad system settings, the menu item was just grayed out. And now, while I was preparing to report this issue here and wanted to make a screenshot of the said settings, the item suddenly was selectable. And not only that - it even works as expected.

Apart from that, there were no other problems with the touchpad from the beginning. So it seems that the device will work flawlessly with Ubuntu 22.04 once it is released.

Regards, Dirk

I’m running Gentoo, and I manually compile my kernels. I’m running into the same issue above of the trackpad not being detected, but it seems to me that this is a kernel configuration issue. Can anyone running Linux with a fully-working trackpad post the output of lspci -k, lsmod, and lshw (possibly to a pastebin of some sort)? Note that lshw may need to be installed.

lspci -k



On Linux Mint 20.3 with kernel 5.14.0-1033-oem.

Trackpad working perfectly.

Thank you very much - I was missing the hid_multitouch module (CONFIG_HID_MULTITOUCH). The trackpad works now.

Also, for anyone else experiencing these sorts of issues, if you are comfortable with kernel configuration, please see the Gentoo Wiki page for the Framework laptop.

1 Like

@Fraoch: I hope that’s not your password, but if it is, then it’s an excellent one.

1 Like

Thank you - no, it’s the machine’s host name. I posted it on this forum a while ago.


I see your post is from a while ago but I have scroll/right-click/tap-to-click all working in Sway on Fedora 35.

In my Sway config I have the following for the touchpad input:

input 2362:628:PIXA3854:00_093A:0274_Touchpad {
    dwt enabled
    tap enabled
    middle_emulation enabled
    natural_scroll enabled

I don’t know if the input identifier value will change across different machines, so just use swaymsg -t get_inputs to find yours.

It should be noted that you need to follow the same touchpad placement as the screenshot in the post above yours. i.e. to achieve “right click” menus you need to use two fingers on the bottom right of the trackpad etc. Hope that helps!

@deadl0ck Awesome! I’ll give this a shot. Thanks for the update!

Does that mean you have to recompile the kernel to solve it? I’m not comfortable with kernel configuration.


If you’re still using Alpine, pinctrl for Tigerlake has just been enabled in the standard lts kernel by default (5.15.36-r1). And I can confirm that the touchpad now works properly:

Thank you @ssu, I’ll take a look at it.

I now run the version of the kernel but the touchpad still doesn’t work.
Do you think I missed doing something?

EDIT: with the 5.15.38-1-lts version of the kernel, it now works. :star_struck:

How can I find what version of libintput is installed on my Ububtu 20.0.4 system?

I was hoping that running salt regularly would ensure I have the lastest version of the needed drivers. Perhaps not. I am executing:

wget -O /tmp/ &&
bash /tmp/ --enable-hibernate

I have an issue where, intermittently, my trackpad stops responding. I can go to the login screen (by hitting the power button) and log back in and that usually fixes it. The fw support people said “update your drivers”, among other things.

Well, they also said to get the ‘Emulate PS/2 mouse’ to false. I did that, so it may fix my issues.

apt-cache show libinput10. Looks like it’s 1.15.5, though they may have backported some changes from later versions.

After a lot of head banging in the wall I found out why my touchpad was not working at all with emulation switched off. Turned out that kernel boot parameters

acpi_osi=! acpi_osi='Windows 2021'

break it. It fully works (gestures and all), if you change it to

acpi_osi=! acpi_osi='Windows 2020'

Why I had these parameters in the first place? I was following some reports from people that got their eGPU working with Framework and thought it didn’t break anything and didn’t revert it. Just one bit of info for other people with the same problem.


Oh, great! Upgraded to 1280P and touchpad doesn’t work again without emulation. Does 1280P use a different model touchpad controller?

Nah, had to remove the acpi_osi options completely and it is working again.

On Gentoo-musl, kernel 5.19, I also had to enable Tiger Lake GPIO / pin support in order for the touchpad to become visible. Before that, I could only see the PS/2 generic touchpad.