Framework and PopOS

So relating to my previous post, fractional scaling of 150% is the culprit of youtube (and basically all other videos) dropping frames and it being incapable of reaching 60 fps unless it is off. Any fixes for this issue? I refuse to believe intel 11gen igpu cant decode a 1080p youtube video even with the expected performance degradation from fractional scaling.

Sorry for spam, to conclude my day, i was able to fix this problem by moving to Wayland, i ran into the same problem @Johnny_B did.

@Johnny_B According to reddit wayland causes desktop icons plugin to show an extra window. And disabling it can remove that, wouldnt be an option if you use it tho.

1 Like

Hello everyone, I am a Linux newbie. My order is batch 5 so I have not received it yet. This question is below most of you. I am currently running Pop_os on my desk top and want to install in on my framework. Do you believe that is the correct choice, or would Mint be better in terms of just getting it all up and running? I am not a gamer and will mostly use for work (word processing, spreadsheets etc) and media consumption so wifi and vpn are important to me. While I am in the process of self education and learning the CLI, I get lost a lot…lol. Any guidance would be helpful.

Thank you. I had run Mint on my desktop and then switched because of something I cannot remember…lol. Both are fine, my concern is which will play nicer with the framework computer.

In theory, couldn’t I boot off an USB ISO and try it out on the new computer? I know you can generally do that, but I am not sure if that will fully interact with the hardware and let me know if the wifi etc works. I ASSUME that will work even with a blank hard drive. Am I correct to just wishful thinking?

Hope every one has a great weekend.

Yes, that’s correct - a live USB will work on a PC even with a blank SSD (or no drive installed at all). And all the hardware should work.

If you did want to try Mint, I found the “edge” ISO supported everything out of the box:

I’m thinking of adding to the post to make a better workflow for newbies installing and running the new 5.14 kernel.

I cannot speak for everyone, but I should would read it!

Curious if anyone else here is running Pop!_OS 21.10 beta? I testing it again today after they updated to kernel 5.15 and am running into an issue where the system can’t recover from sleep. Syslog shows it reached target Sleep and then immediately after log is filled with this line

Nov  5 01:34:43 framework-pop systemd[1]: Reached target Sleep.
Nov  5 01:34:43 framework-pop systemd[1]: Starting Suspend...
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@Nov  5 0

I don’t remember this being an issue with kernel 5.13

1 Like

just setup pop to use wayland and ahhhhh… it’s worth it just for the improved scrolling in firefox.

1 Like

Been using Pop on my framework since I got it last month. Hardly any complaints. However I have noticed a bug with closing the laptop and entering sleep/hibernate-- when I open the lid again and wake the computer the mouse moves extremely fast and there are other minor issues with scrolling and sometimes the trackpad will not work at all. Perhaps a bug with Wayland? I have experienced it with X, although to be fair I only used X for about a day before switching over to Wayland.

1 Like

I also experience this and I haven’t switched over to Wayland. I haven’t looked but there might be a bug reported in the GitHub

1 Like

Have you experienced any issues using Wayland vs X

So far the only big problem is crashing Firefox on waking, but I haven’t investigated or done any troubleshooting. And it’s worth it (for me) for the scrolling behavior… almost as good as on mbp except that scrolling doesn’t stop if you fling the page and then later rest two fingers on the trackpad… you have to move your fingers after resting. Not sure how common it is for people to scroll that way, but it’s really common for me personally and this is a slight annoyance. But still, the behavior is so much better than in X, where there seems to be a minimum scroll amount when using two fingers to scroll in Firefox.

1 Like

I just noticed that you can stop the “flung” scrolling with a one finger tap (but not two as that brings up a contextual menu)… will just require some time to retrain my muscle memory. nice.

Anyone else having issues with accidental touch pad hits registering? I have the touchpad disabled while typing set in the settings menu, it doesn’t seem to work in practice however.

I have that solved in mine with syndaemon which I’ve been using for some years now.

Just chiming in to say this is also my current setup. 21.10 beta on Wayland. I’m a relative Linux noob, and this just feels so good. I’m loving the snappiness of the framework and Pop combo. I came here looking for answers on the battery drain during sleep issue, so I’ve implemented the mentioned changes in the initial post and hope this resolves it.

Welcome in! I have been debating on implementing hibernation on my framework but just haven’t had time. I’d say the sleep issue is still there for me, be it not as bad, even with the changes in the initial post.

Implemented the fix from the original post and over ~13 hours, the battery drained from 80% to 0%. Not great.

If you figure it out, be sure to report back. I’ve been trying practically everything I can find in these forums on linux deep sleep and/or hibernation and am not having much luck. I did find this: How to disable sleep and configure lid power settings for Ubuntu or Red Hat Enterprise Linux 7 | Dell Canada, and tried out the steps near the bottom, and I think when I set it to hibernate, it actually just shuts off. I also end up in a login loop when I try to restart systemd-logind, requiring a hard reboot.