Framework Laptop 16 becomes unusable after activating Picture-in-picture mode of Samsung monitor

I have a Samsung 32" monitor that worked fine with my Framework 16 running Arch. However things fell apart when I tried the monitor’s PIP mode. PIP mode displays two outputs at the same time just like the PIP on your phone. This monitor comes with one DP port which the laptop is connected to, and two HDMI ports, which are occupied by a PS5 and Xbox Series X respectively.

While I was enjoying my PS5 I turned on PIP mode so that I could display my laptop screen on the top-left corner to look out for urgent GMail and Slack notifications. At first glance it was fine, but once I disabled PIP and the monitor was only displaying PS5 gameplay, the laptop was no longer outputting anything. The monitor’s menu indicated that only the PS5 was outputting video. When I unplugged the DP cable and opened my laptop, the screen was flashing and glitching. I had to forcibly shut it down as connecting and unplugging fixed nothing, and no text was on the screen, only colors.

I am unsure whether this is a defect of the Framework 16, Arch, GNOME, or something else. Once I rebooted the laptop was outputting as usual. When I tried PIP again it broke down miserably as it did the previous time. How can I fix this problem?

Laptop: Framework Laptop 16
OS: Arch Linux x86_64
Kernel: Linux 6.9.7-arch1-1
Desktop Environment: GNOME 46.3.1
Window Manager: Mutter(Wayland)
GPU 1: AMD Radeon RX 7700S @ 2.03 GHz [Discrete]
GPU 2: AMD Radeon 780M @ 0.80 GHz [Integrated]
Memory: 64GB, No Swap
Display: 32" Odyssey Neo G8 4K UHD 240Hz 1ms(GtG) Quantum HDR2000 Curved Gaming Monitor with Matte Display Monitor (LS32BG852NNXGO), AMD FreeSync Premium DisplayPort 1.4 3840x2160 240Hz