Framework NixOS (Linux) users self-help

Any KDE people? I’m finding plasma5 with default KWin is chopping up my firefox window, at both default compositor settings and `switching compositor off. I want to try KDE, it’s the only time I’ve seen screentearing outside of gaming though. Is there anything we know about intel? the framework is a 13 from batch 5 (2 years old), but mainboard updated to 13th gen a couple months ago.

┬─[qd@grindenstern:~/o/p/arct]─[10:21:57 AM]─[G:main>]
╰─>$ nix-shell -p neofetch --run neofetch
          ▗▄▄▄       ▗▄▄▄▄    ▄▄▄▖            qd@grindenstern 
          ▜███▙       ▜███▙  ▟███▛            --------------- 
           ▜███▙       ▜███▙▟███▛             OS: NixOS 23.11.20231116.7414e9e (Tapir) x86_64 
            ▜███▙       ▜██████▛              Host: Framework FRANMCCP07 
     ▟█████████████████▙ ▜████▛     ▟▙        Kernel: 6.1.62 
    ▟███████████████████▙ ▜███▙    ▟██▙       Uptime: 49 mins 
           ▄▄▄▄▖           ▜███▙  ▟███▛       Packages: 2247 (nix-system), 6708 (nix-user) 
          ▟███▛             ▜██▛ ▟███▛        Shell: bash 5.2.15 
         ▟███▛               ▜▛ ▟███▛         Resolution: 2256x1504, 1920x1080 
▟███████████▛                  ▟██████████▙   DE: Plasma 5.27.9 
▜██████████▛                  ▟███████████▛   WM: KWin 
      ▟███▛ ▟▙               ▟███▛            Theme: Adwaita-dark [GTK2/3] 
     ▟███▛ ▟██▙             ▟███▛             Icons: breeze-dark [GTK2/3] 
    ▟███▛  ▜███▙           ▝▀▀▀▀              Terminal: emacs 
    ▜██▛    ▜███▙ ▜██████████████████▛        CPU: 13th Gen Intel i7-1370P (20) @ 5.000GHz 
     ▜▛     ▟████▙ ▜████████████████▛         GPU: Intel Raptor Lake-P [Iris Xe Graphics] 
           ▟██████▙       ▜███▙               Memory: 4868MiB / 64027MiB 
          ▟███▛▜███▙       ▜███▙
         ▟███▛  ▜███▙       ▜███▙                                     
         ▝▀▀▀    ▀▀▀▀▘       ▀▀▀▘                                     

The basic on-rails plasma5

  # imports = [ ./../greeter.nix ];
  services.xserver = {
    enable = true;

    desktopManager.plasma5.enable = true;
    displayManager.sddm.enable = true;
  qt.platformTheme = "kde";

note: for World of Warcraft (through lutris) in particular, KDE is the least finicky desktop with respect to screentear in my experiments. I tried services.picom.enable = true; and it may haev made the WoW usecase slightly worse, but I didn’t check choppiness/tear in firefox (it could be a different question). I’m also uncertain how often I should be relogging / rebooting to test stuff like turning the compositor off and on.

The other thing about KDE is that my fan has literally not stopped running once, even when I’m on a light computational load.

also its odd that I run fwupdmgr update about once a month, it always tells me there’s nothing. Then today I do it and it offers a jump from 33 to 371 on UEFI dbx.

║ Upgrade UEFI dbx from 33 to 371?                                             ║
║ Insecure versions of the Microsoft Windows boot manager affected by Black    ║
║ Lotus were added to the list of forbidden signatures due to a discovered     ║
║ security problem.This updates the dbx to the latest release from Microsoft.  ║
║                                                                              ║
║ Before installing the update, fwupd will check for any affected executables  ║
║ in the ESP and will refuse to update if it finds any boot binaries signed    ║
║ with any of the forbidden signatures.Applying this update may also cause     ║
║ some Windows install media to not start correctly.                           ║
║                                                                              ║

Any downside to letting this run (it asked me yes or no)? I’ve never had fwupdmgr return any possible updates before.

Update: I ran it, rebooted, everything seems fine no noticeable difference. Still odd that it jumped from 33 to 371 so quickly, maybe the local index was wrong before.

Oh wow, what a small world. Have you tried it with wayland?

About fan — services.thermald.enable = true

@uwelaf I had to spin up a vm, install windows, run the official framework’s firmware update tool, stop it in the middle of execution and getting the extracted files from the temp dir.

The extracted files have the goodix update tool so then I mounted the fingerprint reader on the windows vm and updated it there.

Reboot and now linux sees the fingerprint reader.

1 Like

I’m searching nixos options for a way to activate wayland under plasma, closest I found is programs.xwayland.enable = true;. It seems to have worked quite well, though!

EDIT: Found this on nixos wiki services.xserver.displayManager.defaultSession = "plasmawayland";

Thanks for thermald! Hadn’t seen that around.

1 Like

I made my own notes on nix, after a few months in, because the documentation is chaotic.

Hope it’d be useful here :slight_smile:

Has anyone managed to get NixOS to work on the AMD 7040 series? I created a bootable USB for NixOS using BalenaEtcher and the KDE ISO from the downloads page. For whatever reason it shows up as

EFI USB Device (SMI USB DISK) boot failed.

When I use the same bootable USB on my 13th gen Intel it works fine (I get to the NixOS live USB menu), and also a Fedora bootable USB works fine on the 7840U (get to grub menu).

Any ideas? Perhaps there’s some BIOS thing I have to do that I may have already done on the 13th gen?

You need to disable Secure Boot in UEFI settings.

1 Like

That was it. I missed that setting since it’s in a different place than the rest of the BIOS Security setup (TPM etc). Thanks!

1 Like

@vitorio_cilia that didnt fix the issue…


I received my FW13 a few weeks ago, installed the latest BIOS (3.03 as of today) and NixOS on the machine. For the most part, it works without problem apart from issues with 3D graphics on Wayland (and X, actually, but I didn’t test it thoroughly yet) - but they might be the topic of another post.

From time to time, when I’m actively using it, the program I’m using crashes, and I can’t do anything on the machine: if I go to an already open shell (because sometimes I can’t open a new one), whatever I do triggers either an “I/O error” or a “read-only filesystem” error. I can’t find anything clearly related to these failures in last boot’s journald logs - if something would have been written, it couldn’t have because of the I/O failures.

So far, I ran SMART tests on my SSD (nothing remarkable), memtest86+ (a few complete cycles) didn’t show anything either. It might come from another piece of hardware failing, but I wouldn’t know how to test it. It looks like this issue.

I have no specific problem with suspend (it can happen either anytime before or after having suspended). The only thing I’m sure about is that this failure doesn’t trigger when I’m not actively using the computer. Sometimes it runs for hours (spread over days, using it actively), sometimes it fails 5 minutes after a reboot.

I use:

  • NixOS (nixos-unstable, nixpkgs-unstable)
  • Kernel 6.1.62, by means of nixos-hardware)
  • sway (Wayland)

Is it an already known issue? What can I do to troubleshoot further? I can provide more information if needed.

6.1 is old and has known issues with the newish hardware in the fw13 - I don’t know how nixos handles kernels but if you can ideally get onto a 6.7 branch or 6.5 distro kernel (the one in fc39 is mostly ok) you’ll be in a better place.

1 Like

Based on you saying that you installed bios 3.03, I assume you have the AMD one, but that topic is from Intel, so probably not something AMD-specific.

Also, I have SN770 1Tb and I’m not experiencing anything like this. I also highly doubt that it is related to NixOS in anyway, so I would probably ask in some other thread, where others, not only NixOS users, will see it. Given your symptoms, though, it does sound like hardware, so, like, I don’t know, have you tried removing the SSD and plugging it again? If you can, borrow another SSD from a different laptop or a friend and try with it. After this, probably, the only thing left is contacting the support.

1 Like

Thanks for the answers. I have the AMD board indeed - it was stated in the title of the post I created but disappeared on merging :smiley:

I used kernel 6.6 for a while, but it didn’t make the problem disappear (though it seems that it happened less frequently). I installed 6.5 as mentioned, we’ll see if it helps the problem go away - 6.7 is not easily available on NixOS yet. I also found some information mentioning bootargs for randomly disconnecting NVMe drives, like in this issue. That might be my problem though I can’t troubleshoot it as no logs are written anywhere (neither dmesg not journald work at this point, and after rebooting, journald -b -1 doesn’t have anything incriminating written in it). I’d like to try these bootargs out, do you have any more information about them and how they could be relevant?

If ever this is useful, my drive is a WD Blue SN550 1 TB. I just updated it to the last firmware, maybe the older firmware was part of the general problem.

FWIW, while 6.7 doesn’t even technically exist yet, on NixOS unstable you get 6.7-rc2 in linuxPackages_testing. Of course, then you’re running an RC kernel, which is most of the time okay, but can cause a lot of damage in the unlikely case something goes wrong.

1 Like