Getting started guide with a bare motherboard

As in, via a USB-C to HDMI expansion card?

I would try different ports first, but I believe DP via USB-C is more native


As @Xavier_Jiang says, I would try using an USB-C to DP cable. Also I would suggest recording the POST code and see if there is something abnormal there. But most possible, its just an issue with the adapter cable (which will not be shown by the post code).

1 Like

most of the USB-C to HDMI adapters I’ve seen, are basically “USB-C DP Alt-Mode trigger + DisplayPort to HDMI” in a single IC - which is to say, they shouldn’t behave differently from a USB-C to DisplayPort expansion card. I wonder if there’s something else wrong with the mobo, whether it’s the aforementioned BIOS update fox, or something like bad RAM.

I received my board through the developer program, and it’s worked wonders for me so far - didn’t require any kind of BIOS update, just worked, with two different USB-C to HDMI adapters.


For anyone who aslo has problems for me it was two! One bad ram stick and the hdmi for some reason didnt want to display. Fixed ram and got a direct to display port and bam!


Tip: Use a USB-C powerbank with sufficient output between the wall outlet and the motherboard USB-C connector. This at least minimizes the risk of the motherboard loosing power during flashing.

1 Like

Thank you @Geert_Schuring for the good idea! I would like to add this to the main post, however it seems to be too old to be edited anymore - I’ll see if I can still edit it and also point to the end of the thread for future updates :slight_smile:

1 Like

So thanks to @Fraoch I could add the info, however editing the main post is a bit problematic, so I hope users will visit the end of the thread often - however, as it stands, the main post should have most important infos available right now - and also be correct for the time being :slight_smile:

Thanks @nmaas87 for this excellent guide. Very helpful!

Agreed about taping the case intrusion switch. The flash red light is quite unnerving, and its really hard to tell if the board is powered on or not without a USB power meter plugged in.

Unfortunately one Framework laptop with a battery cannot power a bare mainboard, as only 5V is offered out by the Framework.

One other thing I have discovered about operating a bare mainboard, is that it will not hot-swap power supplies, even if two good 20V USB-PD supplies are present on the same side, or opposite sides. Might be an incremental improvement that Framework could make in the 13th gen boards.

1 Like

Anybody know if it is acceptable to hot glue the case intrusion switch into the latched position? The flashing red light is attention grabbing in the wrong way. If not I can CAD and 3d print a plastic clip to hold it down…

Don’t see how it wouldn’t be - you can put some tape over the switch first if you want to protect the internals, but it likely isn’t called for. Isopropyl will do quick work of the glue blob whenever it is that you might want to remove it.

So I’ve been using a mainboard as a replacement to a home server that died. Was working great until we had a power outage and the UPS died.

Now I can’t seem to get it post without doing a CMOS battery reset EVERYTIME I remove the power. Furthermore, it will boot but does not use the HDMI expansion card slot for video.

Does anyone have any suggestion for these two problems? Really appreciate anything you might have learned from similar situations. :+1:

@2disbetter I got the problem with the CMOS battery everytime I left the laptop unpowered for some weeks or so and the CMOS battery had run flat. In such a case I get it working again by doing the reset and let the battery charge for 24 hours. If you’re having this issue while running the laptop 24/7 attached to the wall, maybe the CMOS battery died and needs to be exchanged for a new one?

Thanks for your reply. I am using the Framework mainboard outside of the laptop enclosure. It is not connected to the laptop battery and is operating as a server of sorts.

The issue I am having which is the biggest to deal with is that I can boot into a graphical display I don’t see the Ubuntu greeter (gdm3) and it isn’t loading into Gnome.

Can someone maybe shin some light on getting the HDMI port to work when being used in a stand alone manner like this?

@2disbetter Yeah, I understand that issue.
I would recommend following:

a) Shutdown and pull the CMOS battery - measure how much voltage is on it. If it has been running and charging I should sit around 3V - just to be sure that this CMOS battery (which is in fact not a battery but rechargeable) is in an ok state.

b) I would update your BIOS if you have not done so already, as it does fix issues.

c) You use the official HDMI card for connecting your HDMI monitor? I do not have one, but tried lots of different dongles and always had issues with those. The best thing I found was to use an USB-C to Displayport cable and directly plug into an Displayport monitor, as HDMI converters were kind of unreliable for me. One issue I could see that this might be an OS issue, meaning that the system does output graphics on the internal eDP port (which is not attached) and you first have to boot to enable the external output - like with laptops on Windows where you have to switch to the external display with Windows Key + P and some stubborn systems. So I would say, try to add your HDMI card to an HDMI monitor and also try at the same time the Displayport solution I was mentioning (or alone, if it does not work with the HDMI). Chances are using both at the same time, the system will actually use the Displayport monitor and you can then switch one time to the HDMI output and make it work. But as said, thats just an idea, I have not tested this - only figured out the hard way myself that USB-C prefers Displayport (as it is part of the system here…).

Best of luck! :slight_smile:

I pulled the battery to force a reset, but left the battery out, just to make sure. It then booted just fine, and the screen was working. So the ‘server’ is happily running again doing server stuff.

Thanks for the suggestions!


@2disbetter Perfect! So it looks like the CMOS battery is making these issues :slight_smile:
All the best and happy hacking! :slight_smile:

I was having a hard time updating the bios on my board, and I think I found a new approach. I first tried the USB method with a platform.ini file disabling the battery check as well as lvfs with no luck. I ended up creating a modified EC image that reports a fake battery (using info and tools from the blog post by @DHowett ). I uploaded this EC image, plugged power into the left side of the board and ran the update with lvfs (I’m on Fedora 37). This reported that the bios failed to install due to no battery, but it did update the bios (and re-flashed the EC). I then put my version of the EC code back on, plugged power into the right side, and re-ran the bios update with LVFS. This time it updated the left PD controller and came back successful. Running sudo dmidecode -s bios-version now reports 03.17 (I believe I was on 03.03 before) and everything seems to be working. As a side note, I did run into an issue where after updating the wifi and bluetooth seemed to be missing. Turns out the new bios version included an option to disable wifi/bluetooth and it defaulted to disabled. If anyone is interested, I can clean up my modifications and post the code.


Hey @Darius_Lukas - awesome!
Yes, if you got the time, I would really like to see this information in this thread :slight_smile:

1 Like

I uploaded my changes here: GitHub - dariusjlukas/EmbeddedController-fakebattery: Modified Embedded Controller firmware for the Framework Laptop that reports the existence of a battery when there is none. Use at your own risk! My changes are not precise (I kept changing functions that looked related until the system thought it had a battery) so it is entirely possible that I introduced a bug that bricks/damages the board. So far this has only been used on my board so that is not particularly rigorous testing. Also, I have no idea what would happen if a real battery was plugged in. In the worst case, the charger would over-charge the battery and it could catch fire, explode, and do all the other lovely things lithium batteries like to do.

1 Like

Thank you for uploading.
I think we are getting close to the point were hacks like these will (hopefully) not be needed anymore some time soon. The latest beta BIOS ( 11th Gen Intel Core BIOS 3.17 Beta ) does already include an option to work a Framework Motherboard in “Standalone mode” which will skip the check for batteries etc on startup - however, I think this only works in regard to onboard diagnostic for the startup sequence - not gives a new route for the BIOS update yet. But maybe a step in the right direction so that we can get an easier update cycle soonish :slight_smile: . Thanks again!