[GUIDE] Debian unstable (sid) on the Framework Intel Laptop

this seem like a request that should be split apart in a different topic, IMHO. :slight_smile:

I agree, this post wasnt very thought through and more out of desperation. I went ahead and created a question with more details on stackexchange.

If anyone installed debian recently successfully, I would be happy to know what build they used anyhow.

do you mind linking to it from here? :slight_smile:

On 2022-10-18 18:42:45, Pratched via Framework Community wrote:

I agree, this post wasnt very thought through and more out of desperation. I went ahead and created a question with more details on stackexchange.

Care to link there? :slight_smile:

If anyone installed debian recently successfully, I would be happy to know what build they used anyhow.

I used the Debian alpha installer from Debian -- Debian-Installer

you’ll probably need one of the builds with non-free firmware: https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-builds/

Did you mean linking to stackexchange? That might be helpful yes, done.

Yeah I used that one as well (and the non-free-version, more context on stackexchange), but they didnt go through either…

Hey @Pratched, I was facing similar issues with the debian installation.

What worked for me was to use the bookworm alpha installer w/ non-free firmware.

To be 100% precise, I the used the iso-dvd image image, written to a USB stick via dd.

The crucial part was to NOT install any desktop environment. So at “Software selection step” you have to uncheck everything besides “standard system utilities”.

This of course means that you are left only with the command line. The only way you can start an internet connection is via WiFi with ip and wpa_supplicant.

You can follow the instruction on how to do that here. You have to replace wlan0 with the correct name of the interface (use ip link show)

I use sway so I can say anything about installing a DE.


1 Like

Ah yes, I think currently this is the best build at hand. However, apparently I had a very faulty RAM, so when I used I new one, even the bookworm alpha netinst WITH desktop env (I use kde) worked without any issues.
Cheers anyway.

1 Like

Using Debian Bookworm on a 12th generation i5, I started to get random freezes when using Firefox or VSCode, anyone in the same situation?

Try disabling hardware acceleration for Firefox and Visual Studio Code

1 Like

Thank you, I think it solved it

1 Like

Marking this as as guide as this will likely address community related challenges Debian Sid users will see.

1 Like

Not sure if anyone has hit this and found a work-around, after installing Sid on my new 1360p 13" and rebooting the laptop hangs after attempting to bring up the Intel WLAN nic. On the installation I enabled non-free and told it to build all modules.

I installed Fedora 38 and it worked fine, would prefer to be on Debian though.

1 Like

@MarcusW just a stab in the dark here, but did you enable non-free-firmware as well as non-free?

@ayhcheung yes, I enabled both.

The URL to download the installer is out of date - it 404s, and according to a message higher up the directory chain, " As of Debian 12 (Bookworm), firmware is included in the normal Debian installer images. USERS NO LONGER NEED TO LOOK FOR SPECIAL VERSIONS HERE." A replacement could be the regular trixie netinst.

Once I did this, everything worked fine (so far!). Caveat: I did this plugged into ethernet; don’t know if the wireless would have had issues.

To do this:

  1. run wget https://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/debian-testing-amd64-netinst.iso
  2. copy to a thumb drive: sudo cp debian-testing-amd64-netinst.iso /dev/sdX where /dev/sdX is the drive
  3. install, deselecting “graphical environment” and “gnome” from the checkboxes of what to install
  4. finish; reboot
  5. edit /etc/apt/sources.list changing trixie to sid and removing the “security” lines (there’s no security releases for sid)
  6. sudo apt-get update && sudo apt-get dist-upgrade
  7. reboot, login
  8. install more things (e.g., sudo tasksel install genome-desktop)
  9. reboot; login; enjoy!

Note: this was my second try. My first try was the same procedure but with a “mini” installer ISO; that failed miserably (failed to boot into the new kernel; had a glitching screen in gnome with the old kernel).

edit: looks like as I’m a new user I can’t edit the original post; perhaps someone else can update it?


Thanks for the details, I tried using the netinst.iso instead of the mini.iso and installed stable and then just updated my apt sources. That worked great and the laptop actually booted into Debian this time for me. Unfortunately after I ran the apt update & upgrade it installed the 6.4.4 kernel and THIS hung on boot! It would still boot with 6.3.11, after looking at where it seemed to be hanging in 6.4.4 I found it was complaining about the TPM module - once I disabled this in the bios it booted just fine with the new kernel…whew.

Sorry, fixed! It now directs to the official testing netinst ISO.


For anyone interested, I’m running Debian sid (unstable) on my 7840u Framework.

GPU acceleration doesn’t work on the 3.02 BIOS (and indeed locks up the system, waiting paitiently for the 3.03 BETA), to get around this I’ve blacklisted the ‘amdgpu’ module, after that, everything seems to work perfectly (without gpu acceleration).

The wifi module wasn’t detected during install, however simply hitting esc and re-running the detect network hardware step again causes it to appear.

Regarding the fingerprint reader, I followed the framework guide to update the firmware and installed fprintd and libpam-fprintd, after that it works perfectly. I did however install windows before installing debian, which aparently works around some issues (I never encountered any).


Solid work, thanks for sharing this.


Everything here works for the AMD Framework 13 laptop (ignoring UEFI Updates). No, you don’t need to use the Wikimedia mirror, any work. Using v3.03 of the BIOS I’ve had only one issue.

Fingerprint didn’t work with stock firmware, had to update via fwupdmgr using fwupdmgr enable-remote lvfs-testing (after a bit of fuss and a number of tries it updated). Then enrolled my fingerprint and continued as above.

Not using deep sleep or hibernate as I don’t need these features and hibernation requires removing secure boot.

I installed the regular stable Debian image, then upgraded to Sid after a quick update / upgrade. I also added the multimedia repo once Sid was up-to-date.

As a side note for Intel and AMD, if you use LightDM and want to log in using your fingerprint, you can uninstall lightdm-gtk-greeter and instead install slick-greeter which is a front end to LightDM, same as lightdm-gtk-greeter is. If you can use your fingerprint for sudo, then you’ll also be able to log in with your fingerprint.

Apparently fwupd has pushed an update that fixes updating the firmware on the fingerprint reader.

1 Like