Has anyone tried Zorin 0S 16.1 yet?

Zorin released a new version a week ago and one of the features mentioned was better support for the Framework laptop.

Has anyone tried this out yet? How compatible is it?

I initially tried Zorin OS 16.0 on my Framework, the only thing that didn’t work out of the box was the wifi card, so I expect the kernel has been updated to include the driver for the AX210.

1 Like

I’m on Zorin 16.1 right now.

The only thing that didn’t work for me out of the box was the fingerprint reader, but after updating libfprint and clearing the fingerprint database using the Devin Cairns tool, I got it to work. I also updated the BIOS to version 3.07.

I found that there was some screen tearing using fractional scaling, so I followed the ElementaryOS instructions to create a 3000*2000 resolution and ran that at 200% scaling.

Issues so far:

  • Screen occasionally flickers / minor graphical glitches
  • Battery drain on standby is much worse than on Windows (~10%/hr)

I tried setting to deep sleep instead of s2idle, but that made startup times extremely slow.

1 Like

For me, initially wifi didn’t work, so I used my phone to tether through USB and did a package update and then everything worked including fingerprint sensor after a reboot.

1 Like

Update: Using suspend-then-hibernate, with the laptop set to hibernate after 3 hours, I got the battery drain down to 5% overnight! Note that the default swap size needs to be changed to the size of the installed RAM for suspend-then-hibernate to work.

1 Like