[IN TICKET] Piece of mainboard partially melted

Opened up mine today and I saw the same melted plastic. I pulled up the plastic and off came an IC. The laptop still runs. I was having charging problems on that port so maybe that had something to do it with? I plugged the USB 3a expansion into it and that still works. So yeah… I guess it’s time to contact support.


Framework has reached out to me and is currently working on getting me a replacement. They are going to take the board and analyzed by there manufacturing partner. So woot progress!


I was curious after reviewing this topic and tried inspecting my own sticker and the circuitsboard underneath. Mine looks to be fine, but appreciated you all sharing this potential issue.

I accidentally took off my sticker completely and had to eyeball putting it back on, hopefully I didn’t cause any problems in that process but it looks reasonably similiar to before my intervention

1 Like

Woop - forgot to mention that Framework replaced my laptop case+mainboard.

Outta curiosity: what kinds of workloads were you running? Were you pinning the CPU to max freq often for extended periods of time or was it light use? Were you charging on the upper left primarily or did you happen to notice charging difficulty on that port when rotating through them?

Does anyone know what sort of function do these specific MOSFETs serve? Is this an area where heat sinks of some sort would be a better solution than some sort of rf shield or rubber piece?

1 Like

I got my replacement last Monday and finished getting it installed that day. I took a few of photos of the boards before I installed/sent the old board back. Here is a comparison between the new and old on the left side of the board.


@Samuel_Chaboya, I’m glad you got a new board that doesn’t have the same issue. Hey @anotheruser, What ever happened with you? Did you get another mainboard from framework? That makes 2 people with the same issue with the same mosfet chip in the same spot on the MB!

For the most part I used the top left port for charging, till it stopped working. While at the office I plug into a thunderbolt 3 eGPU dock. I would not say I run it maxed out all the time. During the first few weeks of having it, I did run a ton of test with benchmarks / stress test during that time. Afterwards I have played a ton of games on it and while using the eGPU it plays most more demanding games quite well. Heck I’m kinda amazed at what intel has done with the iris GPUs. I have not tired running a twitch stream on it yet, nor have I done any video editing on it. Once this all started I think I was having my usb SSD module on the top left port just drop out randomly while I was in windows. Shortly there after, I was not able to get thunderbolt devices to work then charging died. I honestly should be a bloody beta tester, cause I will break what ever I get my hands on, by just being me. I’m like that fringe user that will come up with problems out of nowhere.

For what it’s worth both motherboards we’re the same revision. After swapping the boards I went back to using the top left port again. But I did get a new TB4 cable for my eGPU. Who knows maybe that has something to do with it? My old cable would stop working if you even looked at it funny. When I first got my eGPU I had no idea the TB cables were so sensitive.

Mine was DIY Batch 6. I don’t think I found any differences between the two of them when I had them side by side. Odd… apparently I only took pics of the back and the front left of the boards.

I’m almost certain these are of the “old” one.

And these are from the replacement.

NOOOOO! IT’S BACK! So, update. I have been using the same port I did before. I did get a new thunderbolt cable (TB4) This time. Oddness happened since forever when rebooting with the eGPU dock attached. No biggie, I think it’s a windows thing. I think I have seen a notification that this device cannot be used till a user logs in. Makes sense since it literally attaches PCIe to the CPU. (I was using a 2019 MBP before) Beyond that I unplugged the Thunderbolt cable after I rebooted to update the Radeon Drivers and noticed, damn that a bit toasty… Soooo, I was like… i may as well check and yup. Melty plastic.

So here is a pic of the setup. I would close the laptop lid but I get the oddness where everything is slow and skippy when it’s closed (sometimes), but I have the laptop on its front so that It gets good airflow. The cable is new, it is attached now to a 90 degree adapter since the cable did not fit into the port on the eGPU because of the plug having sharp edges and the connecter is resisted and oblong. I have not done any streaming yet from this setup, work has been too crazy for me to do my normal streaming, but I have played some wireless VR with the 5700xt that I have in Mantiz MZ-03 Saturn Pro II EGPU enclosure just fine. I moved my cable to the bottom left port to see what happens there. As for now the chip that fell off last time is still where it should be.

IMO this illustrates the folly of this Apple-promoted ‘thin and light’ craze. If this was a reasonable laptop form factor (i.e boxy like an old thinkpad) this would be an easy fix; a thermal pad and a small heatsink on each of those chips. But in the ‘thin and light’ universe, there’s no space to do that. Apple don’t care about this sort of thing because they just sell the customer a new laptop.

Laptop thermals are bad enough without making things 100x worse in the pursuit of a ‘paper thin’ laptop. Jobs cared more about appearance than he did functionality.

1 Like

To me it looks more like this part is just being severely overloaded and / or running out of spec. A heatsink won’t solve it. What it needs is a different spec’d part or a redesign with more overloading protection


Good point on that, after moving to the bottom port I have been able to close the laptop, though I started to use the F8 key and set it to external only seams to leave the display “attached” but disabled.

No glitchy ness over the last 3 days. I have a thermal camera on its way so I can take a look at how hot it’s getting. I leave the laptop in this orientation for about 8-9 hours a day 5 days a week. On the weekends I use the laptop with the framework charger. I also have the charging limited to 90% so that it has a decent charge in case I need to go out somewhere I have a decent charge. I’ll open it later today to see how it has handled using the bottom port over the top port over the week.


I do wonder if it’s something to do with using it vertically. Perhaps there’s some clever airflow in the machine that keeps those chips cool that somehow isn’t working because it’s vertical :thinking:

I think someone just watched the Gamers Nexus Video on the Steam Deck. It could be. The fans don’t sound as loud when propped up, and since the CPU is “cooler” the fans are not running as hard. But not like it’s silent or anything like that. I wonder, is there a way to get fan speed out of the laptop? Like it should be monitored…

Just got done opening it up. Nothing melted, and I put the back of my finger on that area and it does not feel any warmer than the surrounding areas. So maybe it’s just that back left port?

1 Like

Ok so I got my FLIR one in about two days ago, and I did some looking at the board while plugging and unplugging the eGPU. At one point the temp got up to ~150c it started to come down to the mid-80s and never went back up again. I tried multiple reboots/plug-in/unplugs and could not get it to happen again. Later in the footage, I captured it ends up going down to the mid-50s low 60s. Here is a link to the part where the chip got spicy. Sorry for the fan noise.


After using my framework for around 24 hours, I opened it up and noticed a small round spot right over the same spot from this thread. To (hopefully) prevent mine from outright melting like what happened here, I fashioned a small heatsink just to add some extra thermal mass to this area to absorb and spread out some of the heat.

Note that I don’t believe I’ve done anything special with it. It’s been connected to an Anker 575 USB-C Docking Station since I received it.

Note that the thermal pads added to the top aren’t really meant to transfer any heat; I just wanted something to add a bit of pressure to that area to keep the heat sink in place if the adhesive that is on it wasn’t enough.

1 Like

Welp, now mine has done the same thing. Mine just turned off while sitting there doing nothing but charging and viewing a remote desktop session. Then it wouldn’t turn back on, instead blinking red LED codes 4, 9, 10. I’m already in contact with Framework about a replacement motherboard but found this thread afterwards and wanted to share since this seems to be some kind of design flaw and I’m worried my replacement board will eventually do the same thing.

When I get the replacement board I will do a FLIR comparison test of charging a low battery to see which MOSFETs get how hot – maybe the top left port’s MOSFET isn’t being driven fully saturated for whatever reason. Can each person with this melted plastic report what port they were primarily charging with? (Assuming top left)


@RandomUser I think early in the conversation @nrp did say that they were looking to get an affected board back to send to the manufacturer for fault analysis. I can only assume this is still ongoing, or they are still working out what can be done about it.