[Manjaro xfce] Freezes after startup with different display scaling than 1.0

Hello framework community,

I have already more than one year a Framework Laptop DIY Edition (12th Gen Intel Core i5-1240P). SSD, memory and power supply were purchased from a different dealer.

OS: Manjaro Linux 23.1.0
xfce: 4.18.1
Kernel: 6.3.13-2-MANJARO

From first day I installed manjaro linux with xfce desktop environment on it. (I was looking for a simple and minimalistic design.
I had some problems in the beginning, since I grew up with MS Windows, but I could fix most of my issues and I am pretty happy with the hardware and manjaro linux.
In the beginning the FN Keys did not work. But with some help from the community here I found a solution.

There is now only one thing left, which annoys me. I can life with it, but I donโ€™t want:

After the boot and login into linux the sceen gets black for about one second, and a couple of seconds later the same again. After that, everything runs fine.

I realized that that only happens if the display scale is set to a different value than 1.0. The display has such a huge resolution, that 1.0 is not practicable. so I use 0.7.
I tried the same with a higher scale than 1.0: Same problem.
I searched on the internet and could not find much about such a problem.
The only here:

So, what I tried a couple of days ago. I installed a different DE: KDE Plasma 5. It is nice, but I like xfce more. With KDE there are no issues with the display with a custom scale.

Anyone any idea?!

Hey guys,

today I found a possible solution for my scaling problem:

Adding a custom resolution works fine. Screen is clear and fills the full display. Scaling can remain 1.0x1.0. BUT: The settings to not survive a reboot :frowning:

How can I add this permanently?

I found a solution for ME:

created a script which defines for me two additional custom resolutions:


Both have the aspec ratio of 3:2 and work well with my Framework 13 laptop.