Mic not working in Zoom

Hello, I am running Fedora 35 and my mic is not working on Zoom calls. It shows as working in sound settings and can be used in other apps such as Discord. Has anyone else had a similar issue?

Did you set the mic setting written in Fedora 35 Installation on the Framework Laptop - Framework Guides or Fedora Linux 35 (Fedora 35) on the Framework Laptop , right?

Do you use headset with a microphone? Even if you prefer to use mic integrated to the laptop, it still can be recognized. But if you haven’t configured Linux properly headset’s mic would not work.

Try routing Zoom’s input to an integrated microphone.

Similar problem here on Ubuntu 21.10 - muting a headset on zoom didn’t mute the mic, meaning everyone got to hear my throat-clearing… Would love some info on how to fix this.

Following up on this, it appears to be fixed. Somehow “Zoom VoiceEngine” was muted in PulseAudio. Once I unmuted it my mic was picked up in the Zoom audio settings although it doesn’t show in meeting over the mic icon.

BTW Jitsi/8x8 meet was a good alternative while it wasn’t working.