No Intel VT-x, Virtualization Technology? (Resolved)

Running Windows 10 - 20H2

WSL2 working perfectly. VirtualBox is running with no issues.
Everything is working BUT Kubernetes! This is a such a blow to me.
Can’t even start minikube…

Was hoping this would be a development laptop for me, but today I have officially came across a roadblock.

Running VirtualBox from inside WSL2 would require nested virtualization, which is not typically supported in cross-hypervisor configurations (like, running VBox inside Hyper-V!). You’re seeing the features from the virtual processor, not the physical one, suggesting that nested virtualization is not enabled.

This is from the ark page at Intel

You can find it here:

Not sure what you are talking about as it seems it absolutely has what you are looking for. Have you tried checking in the bios if virtualization is enabled? If you are tried virtualize inside of a virtualized environment you will be talking about the limitations of the hypervisor you are using.

1 Like

If you have WSL2 enabled, then you’d have Hyper-V enabled and by default you can’t launch Virtualbox when Windows is running under the hypervisor.

You could try starting minikube using the hyperv driver: hyperv | minikube

You can, but you need to enable Windows Hypervisor Platform and Virtual Machine Platform. This will enable VirtualBox to run in conjunction with Hyper-V (I. E. Any hypervisor that speaks with the VM platform API’s.

I run them together all the time :slight_smile:


I’ve had a moment to get more information, so I thought I’d post it here:


I’ve slightly edited this for brevity; these are the Windows features I’ve enabled to allow me to run Hyper-V, Virtualbox, and WSL on my Framework. Make sure you’re running a recent version of Virtualbox (If you’re running Windows 11, you need the latest version of virtual box!).