PCI error message during boot (mostly harmless)

I’ve seen this a few times during what should be a ‘quiet’ boot (meaning I shouldn’t be seeing info messages between boot and graphical UI):

PCI 0000:00:07.0 RP PIO log size 0 is invalid
PCI 0000:00:07.1 RP PIO log size 0 is invalid
PCI 0000:00:07.2 RP PIO log size 0 is invalid
PCI 0000:00:07.3 RP PIO log size 0 is invalid

PCI 07 corresponds to the following (via lspci):

00:07.0 PCI bridge: Intel Corporation Tiger Lake-LP Thunderbolt 4 PCI Express Root Port #0 (rev 01)
00:07.1 PCI bridge: Intel Corporation Tiger Lake-LP Thunderbolt 4 PCI Express Root Port #1 (rev 01)
00:07.2 PCI bridge: Intel Corporation Tiger Lake-LP Thunderbolt 4 PCI Express Root Port #2 (rev 01)
00:07.3 PCI bridge: Intel Corporation Tiger Lake-LP Thunderbolt 4 PCI Express Root Port #3 (rev 01)

Googling around, it appears this message is due to a hardware misconfiguration:

It sure looks like the device is out of spec because PCIe r5.0, sec, says: “RP PIO Log Size - This field indicates how many DWORDs are allocated for the RP PIO log registers, comprised by the RP PIO Header Log, the RP PIO ImpSpec Log, and RP PIO TLP Prefix Log. If the Root Port supports RP Extensions for DPC, the value of this field must be 4 or greater; otherwise, the value of this field must be 0.” (source)

As far as I can tell, there is no negative side effect (unless this has something to do with laptop not being able to wake from sleep… just speculating). I thought I’d write it down though since it’s a hard message to “catch”.


Had the same error message. I initially try to boot an iso by usb-a but coulnd not get this to work because of usb device descriptor read error that would pop up right after those errors. I then tried to boot an iso using usb-c and for reasons that elude me booting only had the first set of error and now everything work ok.

1 Like

I have this too; it seems like that thread has been updated to say that there are laptops from Lenovo and Dell, and that people are trying to contact manufacturers for it.

Not entirely certain how that’d work if the (presumably) out-of-spec hardware is there in the wild, but maybe the folks at Framework are more happy to look than those at Dell/Lenovo.


Hi! I upgraded to Ubuntu 21.10 last night and I am also getting this error. Anyway to fix it at this point ?
I also have this additional message:

/dev/nvme0n1p5: clean, 452219/19808256 f1les, 7086882/79221760 blocks


I’m getting this too, on Debian 11 stable (BIOS 03.07).

1 Like

Huh, I just realized I’m seeing about 4 of these messages on boot. Linux Mint 20.3.

No adverse effects though.


Messages also present during boot on Ubuntu 22.04.

Does anybody know a workaround to at least suppress those messages during boot? No real bad side effect that I noticed but they are tainting my beautiful boot experience by showing log output even though I’m booting with “splash quiet”.


I recently upgraded to 22.04 from 21.10 and have been getting the same message during boot ever since. Like others, I haven’t yet identified any adverse effects.

1 Like

Research several possible solutions and made some improvements but decided to roll back and just accept the message for now.

What it boiled down to was that forcing kernel log level 2 or 3 via grub param eliminates most of the output.

Only one message I was not able to figure out how to suppress: one single line of the fsck output at boot. Tried looking through scripts in /etc to find the line and possibly reroute the output to /dev/null, but sadly no luck in finding the call.

Since there is not much difference for me personally if there is one or 5 lines of output I decided to revert back. If all output was gone that would be neat but also was not sure if setting a higher kernel log threshold might make it more difficult to debug other issues in general, so I reverted back in the end.

1 Like

Also getting four of these messages on boot. I have Ubuntu Budgie 22.04 installed on a 1TB expansion card, dual booting with Windows 10 (on the NVME). Unsure if it is related, but I’ve also been getting consistent “System program problem detected” error messages, each time with the option to report it or cancel, but no additional information on it. None of this appears to have any adverse effects on the system though.

Same issue here - started after I upgraded to Ubuntu 22.04.1 -

4 posts were split to a new topic: Nouveau error message on boot, Dell

Also expereicing the PCI error during boot, on 22.04.1 LTS, kernel 5.15.0-48-generic.

Read today that this cosmetic issue is planned to be fixed with 6.1 release of the kernel.

1 Like

@Matt_Laurenceau - in the thread you referenced, Mika mentioned BIOS bug. Do the Framework firmware have this bug?

38Mika Westerberg 2022-08-12 10:26:36 UTC
Created attachment 301556 [details] Quirk the RP PIO Log size of certain ports Can someone try the attached patch? There is a BIOS bug that causes the log size to be set to 0 instead of 4 so this patch should quirk the affected ports (Tiger Lake, Alder Lake). This will be fixed in the BIOS too at least for the upcoming platforms.

1 Like

@Justin_Vander_Ziel I don’t know the answer. I’m running 11th Gen Intel(R) Core™ i5-1135G7 @ 2.40GHz, BIOS 3.10 (with issues like battery quickly getting down when in suspend mode)