Periodic ~1sec mouse pointer freeze events

I am experiencing periodic, short (~1 or 2 sec.) periods where my mouse pointer will not move. Then, after the short pause, the mouse pointer will jump to wherever I moved it during the pause. After the short pause, my laptop resumes working properly. These events happen during periods where I am doing several mouse moves every minute. This behavior is most obvious during gaming.

My Framework laptop came from batch 6. It has a Core i7-1165G7 CPU and 32 GB of RAM. It is running the Ver. 3.06 BIOS and Linux Mint 20.2 with the version 5.13.0-22 kernel. I use a Logitech M310 wireless mouse.

I’m curious as to whether anyone else is experiencing this sort of behavior, what might be causing it, and how I might fix it. Thank you for your help.

sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash i915.enable_psr=0 mem_sleep_default=deep”

sudo update-grub

sudo reboot


Just posted about this. Same CPU, ram, bios version (happened on both 3.06 and 3.07), and batch, but I’m running Ubuntu. I’ll try the suggestion posted above.

To help future knowledge seekers, @Trex182’s fix is related to the discussion here:

The issue is fixed by Linux kernel version >=5.14. I had the same issue with Manjaro, but unfortunately Debian/Ubuntu-based distros are a little slower to get these kernel fixes.


I tried the fix recommended by Trex182 and it seems to have totally fixed my problem. Thank you very much Trex182!

By the way, for others attempting to determine whether this issue is pertinent to them, I was not encountering anything I would describe as “stuttering”. I don’t understand why this other issue has been introduced here.

1 Like

Having same issue on Windows 11

1 Like

Solved my problem using the fix above. Thanks all!



I just got my framework laptop yesterday, and I love it. It’s my first experience with Linux outside of a raspberry pi, and the specs are great. The only issue I have is that sometimes my cursor gets stuck and then updates its position later (between a tiny fraction of a second to over 1/2 a second), so my mouse jumps all over the place as opposed to smooth movement. If someone else has this issue and found a solution, please let me know.

(I’m not sure what system info is needed, but I’ll list some stuff and let me know if I’m missing something)

Ubuntu 21.10
GNOME version 40.4.0

Are you using the trackpad or an external mouse?

Built-in trackpad

------------- characters ---------

I have a similar system as you

  • Ubuntu 21.10 (as well as using POP!_OS 21.10 on the 1TB Expansion card)
  • i7-1185G7
  • WiFi: Intel® Wi-Fi 6E AX210 vPro®
  • 64 GB RAM
  • GNOME 40.4.0
  • Wayland
  • Balanced Power when connected to a power adapter
  • Power Saver when using the laptop battery

I monitored the system using top via terminal. I have not used any application(s) that consumed more than 10 GB of RAM.

I don’t this issue at all when I use the Framework trackpad/touchpad.

I do see the issue when the USB Type A has a keyboard plugged in which has a USB hub within it. The mouse is plugged into the hub with an Ethernet USB3 dongle.

I do see the problem but it seems to happen when I have a lot of tabs open in my Firefox web browser with the above configuration.

When I use a docking station having an Ethernet port connected to the laptop via a USB-C, this issue occurs less frequently.

In both configurations and regardless of the operating systems, I have never seen the cursor hitching when I use application that can connect to other computers/system via SPICE or Remmina; I have number of environments running on Proxmox servers.

I did experience a number of applications slow down when the Firefox has a a couple tabs containing ads using video and/or sound.

Hope this is helpful to you.

I got it to work, I used the fix highlighted here:

Echoing this, as it’s important if one cares about battery life.

Disabling Panel Self Refresh (PSR) will prevent the CPU from reaching C10 resulting in increased battery usage.

So after updating to a kernel >=5.14, remember to re-enable it (or just delete the kernel parameter that disables it, since it’s enabled by default).


^Been waiting for this to happen. Good stuff.

Facing a similar issue on Windows 10, when using a Bluetooth mouse. A dongle mouse works perfect. I’ve used a Microsoft mouse, as well as an Apple mouse, and both seem to have a slight glitch where the cursor seems to freeze if not moved for a few seconds. On resuming movement, the cursor will jump a bit before moving normally.

Might have something to do with the power saving settings/low power mode of the Bluetooth card? Since this seems to be an issue that persists over different OSes.

I have also tried the same mice on my desktop and other laptop running Windows 10, and have not seen the issue.

Feedback will be appreciated!


This is a different issue related to Bluetooth power settings (as you suggested). Maybe try the solution linked here:

I have similar issue, and similar system - just lower i7 without vPro and… Windows. But my problem exists only if I have mouse connected to usb hub. I also have very annoying keyboard problem which seems to be from the same culprit - stops working, or sometimes repeats key hit few times (annoying if I do backspace…). I checked mouse (for now, because its easier to move RF receiver) and it works just fine if connected directly to laptop. Laptops touchpad and keyboard does not seems to be affected at all. And the hub I am using is also fine, as 2 different PCs does not show that issue at all.
It happened maybe once after long day of working before I switched to new driver package and BIOS (3.06 → 3.07) but now, its almost immediate after power up. Super annoying and makes the laptop nearly unusable - I have USB C “hub” to connect my KB/Mouse, monitor and tools… I plan to check if keyboard works connected directly after I get my extension cable :slight_smile:

Update: It appears that the problem resides in the newest driver bundle - 2021_12_16. I installed the previous one I had - 2021_10_29. And so far no problems. I will update if it comes back…

Update2: And it came back after 1.5 hours. No gradual change, just from perfect to horrible… So the only change is now BIOS. Do we have plans for a new release soon?