Pop_OS! - Script to enable fingerprint

I’m sorry, I don’t have encryption here so I haven’t had to deal with this. What you’re doing is what I would have reached for first as well (cryptsetup luksOpen ...).

Thank you @RandomUser I managed to figure it out with your help! Among other things, I had forgotten to use the sudo elevation when using cryptsetup.

So here’s what worked for me in case anyone else finds themselves needing it (for encrypted drives):

lsblk
sudo cryptsetup luksOpen /dev/nvme0n1p3 cryptdata
sudo lvscan
sudo vgchange -ay
sudo mount /dev/mapper/data-root /mnt
sudo mount /dev/nvme0n1p1 /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo cp -n /etc/resolv.conf /mnt/etc/
sudo chroot /mnt

cd /home/[user]/fprintd
ninja -C builddir uninstall

cd /home/[user]/libfprint
ninja -C builddir uninstall

pam-auth-update # <-- then uncheck "fingerprintd"
exit
reboot

You’ll want to note where the fprintd and libfprint folders are, mine were not located in a tmp folder, but just in my user folder. Thanks again y’all!

Edit: I figured out what went wrong for me in @rumlyne’s code and fixed it (they put pam instead of libpam for the first line):

sudo apt install libpam-fprintd
sudo pam-auth-update

This worked for me and hopefully for anyone else on Pop_OS! 21.10.

4 Likes

This is the correct way to do with the 12th gen laptops and PopOS 22.04 LTS.

3 Likes

This worked perfectly. Thank you kind sir.

1 Like