PSA: don't upgrade to linux kernel 5.19.12

You can try adding init=/bin/bash to the end of the same kernel line. That should skip the runlevels.

1 Like

Thank you, maybe next time. I have downgraded the kernel and everything is working well for me.

1 Like

Just for easy reference for Arch, you can add linux linux-headers to the IgnorePkg line in /etc/pacman.conf to do something similar.

Personally, as recommended above, I have linux-lts (and also linux-mainline, which is still at 6.0rc7 atm in Arch AUR (6.0 just released about 12h ago).

(FYI, 6.0rc7 does not have any flickering for me on my 1260P, so I’d guess 6.0 will be fine.)

ive done a terrible writeup on my pain with this update Broken i915 - Keloran blog and random stuff

1 Like

That’s interesting to me. I’m also on Fedora 37 Beta with an 11th gen i5 and I am getting the issues. I had to exclude 5.19.12-300.

Kernel 6.0.0 confirmed working (dist and custom)


If you’ve made the mistake of installing Linux 5.19, you can get it to boot with nomodeset on the kernel command line. If you are booting with systemd-boot, just press e on the bootloader screen and add nomodeset to the line before pressing enter. If you’re on 11th gen, and don’t need kernel features from the last few months right now, I recommend you stick to linux-lts. Right now, linux-lts on arch is linux 5.15 and works great. (just remember to update your bootloader entry to point to the linux-lts kernel and initrd)


I am somehow booting with 5.19.12…? The startup message still says I’m booting 5.19.12. Which I think this attempt is causing the emergency mode to happen since I tried to remove it.

And I can’t get grub to show up or I don’t know how to. I’ve only been able to shutdown by holding the power button when it does its flicker stuff, and the grub menu hasn’t made an appearance. I’ve also tried spamming ESC, SHIFT, F8, and SPACE.

1 Like

Additionally, I have no root account for it to log into during emergency mode.

I get a “Press Enter to Continue Prompt” after it says: I’m in emergency mode and the root account is locked. Pressing enter starts the “default target” which results in the same messages.

EDIT: there’s also a 50/50 chance that I get a chain of about 30 “[FAILED] Failed to mount” messages before the aforementioned emergency mode messages. It starts with

[FAILED] Failed to mount boot -efi .mount - /boot/efi.

sounds like Fedora patches kernel? what is 300 and what is fc37

1 Like

just waiting someone to ship it Arch Linux - linux 6.8.2.arch1-1 (x86_64)

1 Like

I’m in! So I noticed the /root/boot was empty on my partition 3. Went and mounted partition 2 instead. It had /boot with a few kernels in it. I sudo rm -rf’ed everything I could that said 5.19.12 :laughing:

I rebooted, got a menu with only a selection for UEFI Firmware settings. Rebooted again, spammed ESC, hit a grub prompt, followed some advice Here:

# found grub2 via ls
ls (hd0, gpt2)
# then did these commands
set prefix=(hd0,gpt2)/grub2
set root=(hd0,gpt2)
insmod linux
insmod normal

After “normal”, it put me at the grub kernel selection screen where this time I had a choice of 5.19.12, 11, 10 and UEFI Firmware. I selected my 5.19.11.

In an attempt to ensure this won’t happen if I reboot I have double checked the dnf remove on 5.19.12, I have excluded it, and I ran a dnf upgrade which said it was excluded. I also checked my grub.cfg settings were set to show the grub menu and ran:

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Now I just hope I don’t have it break on next reboot

This is great to know. I thought display was broken in general, but after blindly entering the password, I went ahead and updated the systemd-cryptenroll TPM bindings. Now it boots to the login screen without issue (other than the lack of boot splash due to the display going bonkers).

1 Like

Has anyone reported this to Framework or seen that they are aware of the issue?

1 Like

Wrong tree.

1 Like

The fc37 just denotes that it was build for Fedora 37. The 300 is the package version which is the version of the actual packaged RPM. Usually if there is the change to the packaging done by the packager and not the sources the package version is incremented so that the updated package will propagate. Apparently for the kernel, things are slightly different. See this reddit post for an explanation.

What does “Wrong tree.” mean? Framework has a good working relationship with Fedora. I’m asking if there is any chance of continued collaboration on this issue.

1 Like

The bug’s reportedly already fixed in 6.0, so it’s really just a waiting game. FWIW people on laptops that aren’t from Framework are also having this problem, so this isn’t something special to Framework, but a bug introduced in the Intel graphics drivers.


Can confirm, just compiled 6.0 of the Clear Linux kernel and it’s working fine on my Arch install.


DO NOT USE 5.19.12.

Intel devs are saying it can potentially damage lcd panels:

After looking at some logs we do end up with potentially bogus
panel power sequencing delays, which may harm the LCD panel.

The patches are being reverted and a new stable release will be out soon.