Public Beta Test: 11th Gen BIOS v3.06 + Driver Bundle 2021_10_29

Just updated the BIOS and power button dimming works like a charm!

Can confirm that power on without battery works as well.

@Foxboron looks like that TPM2 eventlog issue is fixed?


Clear evidence that public shaming works after all. /s

1 Like

Thank you Framework for delivering. I hope we all can take a moment to appreciate their efforts to make this right.


Would it be possible for Framework to provide ISO’s for us to manually copy to USB drives until official LVFS updates are set up?

Here’s an example of Lenovo provides ISOs for Thinkpad X1 Carbon bios updates: BIOS Update (Utility & Bootable CD) for Windows 10, 8.1 (64-bit), 7 (32-bit, 64-bit), Linux - ThinkPad X1 Carbon (Type 20HQ, 20HR, 20K3, 20K4) - Lenovo Support US


^^^ This please!

I already missed out on 3.03, couldn’t install it on my Linux-only Framework even with a Windows To Go drive.

1 Like

Can confirm the mainboard works without the battery, outside the case, and on an external display. Let the tinkering begin!


Framework laptop built for linux but still a minority. :pensive: I wonder what percentage windows and linux Framework users.


This sounds related to the workaround I did on Ubuntu 20.04 where I rmmod i2c_hid on suspend and modprobe i2c_hid on resume to avoid the touchpad turning into a potato. Maybe that workaround won’t be needed with this BIOS. Will test.


I’m so excited to see what you do with this! I saw your video on the battery issue when it went live, and your ideas are undoubtedly going to be fruitful with potential.

A question for all is, could this be a good opportunity to buy just a mainboard to use as an independent computer in a 3D-printed case? I have worries that this won’t be sustainable due to the way that a laptop is designed to be used and using it like a PC or Latte would damage it in the long run. Thoughts?


I will be using 3D printing for prototyping but it’s not a long term solution due to the heat the mainboard generates. Prototypes that are promising will be sent off and machined from aluminum. This isn’t really a cost effective solution for most unless your a builder/Modder and have a passion for it. I will be buying mainboards when available but I don’t see it as hugely cost effective for most unless again my previous justification applies.


Oh? Please share your experience. I was planning to do exactly that.

1 Like

Normally I’d be hesitant to do that, as the way framework has those modules implemented on the mainboard is going to vary from application to application. Hence the drivers they provide could be specific to that implementation. Otherwise, wouldn’t they tell us to just use the ones straight from Intel?

Still have you seen improvements? About the only thing I want is standby improvements.

1 Like

Framework bundles the drivers they’ve extensively tested and confirmed to work, so you can get every part of their eponymous laptop up and running on a clean install, but ‘not the recommended version’ is far from ‘incompatible’. Framework’s laptop is a modder’s dream, and it can be your dream too if you dare to dream it. And troubleshoot it.


So far so good on Windows 11 (22000.282). Both BIOS and driver bundle installed. A cool feature in the future would be the ability to create a custom fan curve in the bios for the cooler. Maybe with safeguards in place so someone can’t purposely cook their CPU. Thanks for the hard work Framework!


Just an FYI for others who might have any issues:

I installed the BIOS update using a Windows To Go drive, which worked fine for BIOS 3.03. It rebooted fine, and it went through the install like normal. After doing the EC update, it hung on “Update status: Complete”. I left it like that for about 30 minutes, and no change. I just tapped the power button (tapped, not held), and it turned off. I turned it back on, and was greeted with a black screen for about 25 seconds. After that, the normal Framework post screen came up, and it tried to start.

However, it just threw me into a Windows blue error screen (A required device is not connected). I rebooted to try and change my boot settings, only to notice that my Linux boot entry was gone (Arch on my NVMe drive), and it was listing Windows Boot Manager on the NVMe drive, while in actuality there’s no Windows EFI data on my internal drive, it’s all on the expansion card. I removed the expansion card, had no effect.

I tried an Arch USB, to reinstall my boot entry, but I then discovered that no new boot devices showed up whatsoever. Also, while I was in there I tried the power button dimming option in the bios when I first rebooted (it’s why I updated), and it didn’t have any effect. Still the same brightness.

At this time, I started to panic a little. I opened up the laptop, and I wasn’t greeted by the normal flashing LEDs when I first opened the chassis. Completely dark. I disconnected the battery, then (very carefully) removed the CMOS battery, waited a few seconds, and put it back in. I then reconnected the battery, and upon turning the machine on (and going through another memory training), everything is normal again. I was able to boot into an Arch USB and reinstall the boot entry, and the new power button dimming feature works perfectly now.

Hope this helps if anyone else has the same issue. It might be my fault for pressing power (given that it tells you explicitly not to do that in the initial program), but I didn’t know what else to do after it hung for a long time with seemingly no change.


Awesome :slight_smile: Thanks for the highlight.

Waiting for the drivers on LVFS though som might take a while before I get the update :smiley:


I got an error “The BIOS image to be updated is invalid for Secure Flash or onboard BIOS does not support Secure Flash.”

I have no idea what caused it and no idea how to resolve it. I seem to be the only one to have encountered it since no one else reported this.

Secure Boot setting? Something else?

My Framework has been running pretty much perfectly so I didn’t work at it much, but I would like to try out these beta BIOSes.

If it does work for you please let me know.

1 Like

I’m actually planning to install Windows on USB using DISM. Basically circumvent the installer’s refusal to install on removable storage. I’ve tried this approach once and it worked. I have not tried flashing BIOS from it.

1 Like

Ooh that does sound scary. I think I’ll wait until the BIOS update is finally on LVFS and play it safe.

Actually your experience with Windows To Go is similar to mine on my desktop. WTG turned on Secure Boot somehow, put itself and only itself on the approved drive list and on reboot I could no longer boot from my Linux Mint drive. I couldn’t boot from an LM install drive either so there was about 10 attempts turning on and off Secure Boot, wiping EFI keys, trying to find the install drive, etc. Finally I was able to reinstall but I lost all my data. Thank goodness for backups!

I vowed “never again” but I need it for SSD firmware updates on my desktop and my Framework so I have to risk it again. It did not destroy my install on my Framework but would not update the BIOS.

1 Like

Nice. I used Rufus which worked well but it needs to be done from a fairly powerful Windows computer and since I’ll be selling it, I have to come up with something else. I created it “UEFI + CSM” this second time which did not destroy my Framework install, so maybe it’s safe now. But I have to keep it permanently because I’ll never be able to write it again, I’m having problems using USB devices from a Windows VM.

So as not to drag this important thread off-topic, maybe I should explore this further in the Off-Topic section.