Random boot trouble

Hello everyone,
I recently received my laptop DIY framwork. After plug the components inside, I install the last version of Lubuntu 21.
Everything seems to work quite well, except for some trouble of display, but this is not problematic at usage. The more problematic situation is that some time (once every 4 or 5 boot), the BIOS display a message saying that the boot wasn’t found during the process and the laptop shutdown. For the moment, it’s not that problematic but it can become and I want to know if some have the same troubles.
I used the boot-repair software, you can find here the boot-repair file : Ubuntu Pastebin
Thank you in advance if you read and for your help,

What SSD are you using? Have you updated its firmware?

In some SSDs (Crucial P5, WD SN850), the drive doesn’t resume from sleep fast enough and the BIOS thinks it’s not there.

This was fixed in newer versions of the SN850 firmware and I haven’t seen reports of the Crucial doing this anymore either.

Hello, i use the SSD : 500GB - WD_BLACK™ SN850 NVMe™
And because I don’t know how to update its firmware, I assume that I didn’t make this. And because you cited the SSD I use, I imagine that this is important, I will check how to do this.
Thank you for your answer

1 Like

You’ll have to do this from Windows using the “Western Digital Dashboard” application.

Thank you, but as I run the computer on Ubuntu, I don’t have Windows

Here’s one way to do it…kind of…(you still need windows…doesn’t need to be activated):
Updating firmware of WD SN850 SSD on linux / Kernel & Hardware / Arch Linux Forums

1 Like

Thank you, I will have a look… And maybe try… I’m a bit affraid of making some try like this when the computer don’t want to power on sometime because it can bring more troubles…
For the moment I have to understand why I have an error message with “h0 not find” during the boot because the quick boot seems to permit to space a lot the power on when the boot isn’t find.

For a reason i don’t understand, yersteday, the fast boot permited to fix the issue of boot. But today, 5 time in a row, the boot is impossible to find by the bios. I’m not able to power on the computer until I’ll find my usb key back.
I don’t found any suggestions for easily fixing the firmware of the ssd on linux. Do someone have an idea on what to do ?

Update : I tried with the Window computer of a friend to create the USB to update the firmeware, the ssd have to be plug on the computer to create the bootable usb. Is was on a laptop.

You have to install Windows to a USB, then install WD Dashboard to that once you have it up and running.

There are several threads in this forum about how to do this. Here’s one: