Realtek Windows 10 tips

The Intel Smart Audio services and the Realtek drivers are responsible for most of the insane power drain during Suspend on Windows. The problem? Opening any kind of audio program causes the service to start running. Merely closing the program before suspending does not guarantee that the service will not drain your battery. While disabling the service, disables audio in Windows as well.

Has anyone whose laptop has the Realtek audio chips in it found a way to make this whole thing a bit more predictable? When the service is not started I can suspend for about 2 and a half hours using only 5% of the battery. When the smart audio service is enabled this drops drastically to about 20 minutes.

I know that I don’t see this kind of thing on Linux. On Linux I see a consistent 5% for 2 hours of standby.

1 Like

It’s been a while since I’ve used Windows, but do you know if reverting back to the default Windows driver helps? I.e. deleting the Framework audio drivers for whatever Windows ships with?

You might be able to do a scheduled task magic to stop the service (if that’s a thing), could help albeit in a hacky manner.

So far, I’ve forced S3 to be available by using a registry entry. I would prefer it if s0 could be used, but I don’t think the problem can currently be avoiding due to the Intel Smart Audio issue.

I was reading on Dell and Lenovo forums that their machines were having the exact same issues, so at least it isn’t central to just Framework. Ultimately a driver update from each was able to correct the issue.

However, I mean it is pretty telling when Dell tells their customers that if they use s0 suspend and put their laptop in a bag, that they have voided their warranty.

1 Like

Oh thanks! But have you confirmed that this prevents smart audio from plaguing suspend?