Reliable laptop wakeup/sleep mechanisms

Is there a list of what mechanisms wake the laptop from sleep, and enter sleep?

1- Power button
2- Keyboard
3- (Magnetic) lid sensor
4- Type-c power attach

1- Power button (can be disabled in Windows)
2- Windows shutdown
3- Closing the lid (can be disabled in Windows)

I find it waking unintentionally in my backpack more than I’d like… to get a more reliable mechanism, I would be open to disabling several of these and relying on the power button… is there some possibility in the bios or via other mechanisms?

Hi and welcome to the forum.

  • You can have a look at the BIOS settings :slight_smile: BIOS 3.07 ?

You haven’t stated what OS you are using. If Win is that Win 11 with the updates.

When you say it is waking up, waking from what? Sleep?

Have you disabled [Fast startup] if you are using Windows as else powering off doesn’t allow a full fresh start.

Check out the [powercfg] options, you may find what you want there.

1 Like

Hi, yes I was using 3.06 BIOS, just upgraded to 3.07

Windows 10 Version 10.0.19044 Build 19044

I guess my question is can I disable the PC waking during sleep mode from its lid sensor / keyboard / inserting USB power, and only wake via the power button?

Control panel > Power options > Choose what closing the lid does.

Hey thanks for the reply, I have these set to ‘Do Nothing’, this is the current behavior:

  1. Start Menu → Sleep, PC enters sleep (power button light doing fade animation)
  2. Close lid
  3. Open lid
  4. PC auto-wakes up from sleep

preferred change

  1. Start Menu → Sleep, PC enters sleep (power button light doing fade animation)
  2. Close lid
  3. Open lid
  4. PC remains sleeping until power button press

I would disable [Turn on fast startup] as unless you do a ‘Restart’ every time you shut down many options don’t actually change.

Fast Startup is a setting that helps your device to start faster after shutdown. Windows does this by saving the kernel session and device drivers (system information) to the hibernate file on disk instead of closing it when you shut down the computer.


Perhaps you have some metallic/magnetic objects near the lid sensor?
I have noticed (at least on one laptop) that if I position my iPad (with the magnets on the sides) around a certain point the laptop will think I have the closed (even though I didn’t).

If the screen flex is so significant that it touches keyboard keys and/or press trackpad buttons, there’s a problem. Try not to put pressure on the lid.

And yes, I will turn off fast startup if I am you. It only save a few seconds, but it can add a lot of potential problems to the loop.

If you run powercfg -devicequery wake_armed in a command prompt, it shows you every device that is able to wake up your laptop from sleep. You can definetely stop e.g. external keyboard and mouse from waking up the laptop by disabling that through the device manager. I currently have no keyboard attached so the screenshot shows the Wifi module. But a keyboard should have the same “Power Management” tab.

I don’t know if its possible to disable the lid sensor and usb inputs to wake up the laptop, but it is probably a good idea to check the devices in the list from powercfg. I would check it myself, but i already deactivated wake up from sleep for all devices so the above command shows nothing :sweat_smile:

1 Like

Thanks for the replies, seems like the Keyboard & Mice don’t have a Power Management tab (Win 10 Home), the only devices listed from powercfg are the Thunderbolt Controllers. Disabling these and fast startup seems to have the same behavior.


1 Like

Power options → Change Power Plan Settings → Change advanced power settings.

Power buttons and lid
→ Lid open action
→ On battery: Do nothing
→ Plugged in: Do nothing.

You’ll need to enable this from the registry first, for it to graphically show up to be configurable.

1 Like

Just to elaborate on the registry edit part:
You’ll need to CsEnable the hell out of the power settings.

Give them a 2.

Oh, and this goes with the “Do it at your own risk” thingy.

If you just want this particular setting, this is the direct way:

1 Like

Thanks!!! It looks like somehow only had the ‘Balanced’ power plan, adding the other plans & the registry file from the second link finally enabled the ‘Lid open action’ in this power options dialog (control.exe powercfg.cpl,3), works as detailed.

Any ideas if wake from keyboard/mouse can also be disabled?

Actially I was reminded of a similar setting.
“Allow wake up from Thunderbolt Dock”
This is a BIOS setting (from Dell bios). Whether Framework made it available, I don’t know.
A similar setting might be “allow USB device to wake (computer) from sleep”. This may or may not be in BIOS or Windows.