Repair of Ubuntu (was: difficulties with install disk)

When I first installed Ubuntu 20.04.3 on my laptop, I had burned an ISO onto a thumb drive. This was my install media. It is a USB-A stick. I have a (6") USB-A → USB-C cable and it worked, but it took repeated tries to get the system to boot into disk-select mode.

In the past, I had to re-install something. This was the not-working-with-wifi-pnm thing. I could not get the disk to mount. I had to re-burn the image onto the thumb drive, try a bunch more times. I am not sure if it was the newly-burned dis, or if it just worked because it was the 50th time and it decided to work.

Now I have to fix something again. Once again, I cannot get the %&$%%-ing thing to mount. It mounts after it finishes booting into the old system. It just will not go to disk-select mode first.

Is there a reason this is so challenging? Will it be easier when I get my (recently ordered) USB-A extension thing?

Is there anything I can do so it … just … mounts? Erg.

FYI, I horked my python environment and now cannot launch gnome-terminal. If there are other workarounds, I would be glad to hear.

Do you mean it is not booting to the install media?

There are two settings in the BIOS menu related to boot order. One is to prefer USB boot media when deciding boot order, and the other is to choose boot preference between all recognized options. If you have the “prefer USB” option selected and it is still not booting to your install media, try opening up the boot preference menu and un-check all the boxes except for the thumb drive.

Yes. Or rather, I got to a screen where I could choose the available boot disks. And I just saw that screen again. And the connected thumb drive was not on the list. Only the on-board disk appeared.

Apparently, I am not the only one. Cannot boot off USB after installing an OS

I’ve installed four distros so far and I’ve never had an issue. I use Ventoy, it works great–give it a shot.

Make sure “USB Boot” is enabled.

Also make sure secure boot is disabled in the BIOS. Even if it is something you want to enable later, for installation you will run into problems if it isn’t off.

Yikes. I have, I think, painted myself into a corner. I went into the BIOS, un-checked the on-board boot disk to see if that would make the system recognize the USB drive as a boot disk. It sounds stupid now that I say it like that.

So, now my laptop does not recognize any disk as a boot disk and therefore cannot boot. I can get into the BIOS and, when I look at the list of devices available, I can see the on-board disk and I cannot get the X mark back on it. Arrows, fn-F5 or 6, nothing does anything.

So, get a new laptop? :–)

I know it is not veyr clear, but see the “[ ]”? I just need an X there…


On the menu before that one, make sure “New Boot Device Priority” is not set to “auto” and then you should be able to make changes to the boot list.

“First” would be the most common choice for this setting.


Got it. Much thanx.

Still cannot launch gnome-terminal or find an install disk that mounts. But I am dug out of one hole. Onward and upwards!

I think you should go for a re-do on that flash drive.

Try Ventoy, it’s easy and works great–you’ll love it!

1 Like

Ok, so now I have a bootable drive with 20.04.4 on it.

How can I install onto my current system? I do not want to add a separate system on it. I want to fix the existing system. Is this possible?

What do you need to fix?

Sorry. Tried to upgrade/change python version. Yes, I know not to do that now.

I cannot launch gnome-terminal to save my life. Have tried installing, “–fix-whatever”, “–please-please-fix-something” and, after much reading and trying things out, I still have no gnome-terminal.

To switch to a full screen terminal on tty2:


To switch back to your desktop on tty1:


From the terminal on tty2, try:

sudo apt update
sudo apt install gnome-terminal

Though you may prefer to install ‘synaptic’ from the Software Center, in order to install ‘gnome-terminal’ that way.

1 Like

I do not get the ‘Ctl-Alt-F2’ key thing. If I am in my Ubuntu desktop and hit ctl-alt-F2, I get the sound-volume-down effect. If I hit Ctl-Alt-Fn-F2, I get nothing. Whatever. I can ssh in to the laptop.

And I can do an update and install gnome-terminal (as I have seen suggested many time and tried nay times) and, when I launch terminal, I see this in var/log/syslog:

Apr  3 13:49:35 ray0 systemd[1128]: Started Application launched by gnome-shell.
Apr  3 13:49:35 ray0 gnome-shell[8246]: Traceback (most recent call last):
Apr  3 13:49:35 ray0 gnome-shell[8246]:   File "/usr/bin/gnome-terminal", line 9, in <module>
Apr  3 13:49:35 ray0 gnome-shell[8246]:     from gi.repository import GLib, Gio
Apr  3 13:49:35 ray0 gnome-shell[8246]: ModuleNotFoundError: No module named 'gi'
Apr  3 13:49:35 ray0 systemd[1128]: gnome-launched-org.gnome.Terminal.desktop-8246.scope: Succeeded.

and then terminal silently goes away.

FYI, this is what I get from “apt update”, when I execute it. I have been told that these errors are innocuous.

# apt update
Ign:1 cdrom://Ubuntu 20.04.3 LTS _Focal Fossa_ - Release amd64 (20210819) focal InRelease
Err:2 cdrom://Ubuntu 20.04.3 LTS _Focal Fossa_ - Release amd64 (20210819) focal Release
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Hit:3 stable InRelease
Hit:5 stable InRelease                                                                               
Hit:6 stable InRelease                                                                          
Hit:7 focal InRelease                                                                                   
Hit:8 stable InRelease                                                                        
Hit:10 focal InRelease                                                            
Hit:11 stable InRelease                                                                                 
Get:12 focal-updates InRelease [114 kB]                                                                 
Hit:14 focal-security InRelease                                                                           
Ign:15 xenial InRelease                                                                    
Hit:16 focal InRelease                                                                     
Hit:4 focal InRelease                                                                    
Err:17 xenial Release                                                                      
  404  Not Found [IP: 443]
Hit:13 jessie InRelease                                                              
Get:18 focal-backports InRelease [108 kB]                                                               
Hit:9 deb InRelease                                                                 
Hit:19 focal InRelease                       
Hit:20 stable InRelease
Traceback (most recent call last):                   
  File "/usr/lib/cnf-update-db", line 8, in <module>
    from CommandNotFound.db.creator import DbCreator
ModuleNotFoundError: No module named 'CommandNotFound'
Reading package lists... Done
E: The repository 'cdrom://Ubuntu 20.04.3 LTS _Focal Fossa_ - Release amd64 (20210819) focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ' xenial Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository ' focal InRelease' doesn't support architecture 'i386'
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code

I switched over to Wayland, and noticed that it started a Wayland session on tty2, so it would need to be the next one over at tty3. I’ll have to remember that, still used to the desktop being on tty7.

Yeah, they appear to be innocuous. Amazon’s repository using Xenial threw me for a loop for a second.

Just realized you also have a thread on Stack Exchange: Ask Ubuntu.

command line - mucking around with python and gnome-terminal will not launch - Ask Ubuntu

Have you reinstalled python from the article linked to you?:

13.04 - Removed Python 3 and now Ubuntu Software Center, terminal and other applications don't work - Ask Ubuntu

Karel has a decent list of suggestions, which seems to boil down to the following two commands:


sudo apt install python3-all
sudo apt-get install ubuntu-desktop


Reboot if necessary. Installing ‘ubuntu-desktop’ should not break anything, and should reload anything that went missing when python went sideways.

Is there something special about the Ctrl+Alt+Fn+F3? Because I cannot do this but I can ssh in and get to a command-line.

And then:

# apt install -y python3-all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python3-all is already the newest version (3.8.2-0ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.
# apt install -y ubuntu-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ubuntu-desktop is already the newest version (1.450.2).
0 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.

And, what?

Maybe this is giving up, but is there anything preventing you from just reinstalling?

Some critical data in your /home directory?

1 Like

Last thing I have to suggest is “which”, to see if there are multiple instances of python installed.

which python

If it only lists a singular entity, then retry the install commands with “–reinstall”, which might trigger something.

apt install --reinstall python3-all

apt install --reinstall ubuntu-desktop

Finally, give --fix-missing a shot if the above does not work.

sudo apt --fix-missing update

The hard part is determining where it broke.

I am hesitant to recommend “purging” the related packages using apt, as that is generally a more convoluted version of reinstalling. It is generally considered to be an advanced level procedure.

Booting from a live distribution you should be able to locate your hard drive and backup the data in “/home”. Do you have a USB hub to connect more than one USB device simultaneously?

It is possible to use the mount command on an external device from a command line via ssh in order to copy files over to a thumb drive, but that is probably going around your elbow by that point.

1 Like