Repeated Message - Driver exit RTD3. All the connected devices will now cause DeviceConnected events

In my event viewer, I keep getting the message "Driver exit RTD3. All the connected devices will now cause DeviceConnected events. " It repeats about every 5-10 seconds. I’m on the latest BIOS and drivers as of today.
I don’t have anything plugged into the USB ports except power.

Does anyone have any ideas?

1 Like

I am sorry to hear that you are having trouble! What BIOS are you using?

1 Like


I installed it yesterday and it did not resolve the issue.


Disable USB selective suspend?


That’s exactly what I did. I disabled selective suspend. That being said, it did not show up directly in my advanced power options, so I had to unhide it in the registry so that it would show up in my advanced power options. I can’t remember where I found the administrative command line script I used to enable where I could see the option, but I think it was a Microsoft support forum.


Ok. I did see your post, but I do not have that option. I didn’t think of trying to find a registry option to unhide it. Let me know if you remember how to unhide it.


PhilipG - I had to do some pretty intense googling to figure it out. There were a couple scripts that didn’t work, but I ultimately did find one. I totally forgot where it went! If you have a full retail license, you should have MS windows support that you can reach out to.

1 Like

I found this:

It worked for unhiding the USB option. Then I disabled the USB Selective Suspend Setting for both power and battery.

The message has stopped.

Thanks everyone for the help.


Glad to hear! If you look closely in your event manager, you’ll still see some disconnects and reconnects, but they usually only happen when connecting and disconnecting from power or switching out expansion modules. I was initially concerned (overanalysis by me), but it looks pretty normal. I’m running a TB4 dock right now from home, and everything seems to work perfectly with my connected accessories. Looking forward to exploring EGPU and TB3/TB4 storage drive options as budget allows, and how everything plays together on the Windows side going forward.

1 Like

Yes, I saw the same behavior when plugging in/unplugging power.

I still don’t understand why it was oscillating every 5-15 seconds. But I’m fine with disabling the suspend feature.

Thanks for the help.


Yep. I’m keeping a pretty close eye on it. And I didn’t necessarily plan on buying thunderbolt devices as soon as I did but I wanted to rule out any hardware issues right away. Right now everything seems to work just fine with no issues, connecting to a thunderbolt dock which is connected via USB-C to my HDMI monitor.

1 Like

Sigh. I am getting a similar issue. I only see it when I launch an old game which tries to go fullscreen. I am connecting via USB-C + PD to a monitor w/ a USB hub built in.

I tried to disable suspend all all the usb and thunderbolt hubs in device manager, but still experienced the issue.

Yesterday, it went away after a reboot… so definitely smells like a bug somewhere.

1 Like

Did you do the steps to disable the USB Selective Suspend?

1 Like

Yes, I resolved this error, with these commands as admin:

#Display USB Selective Suspend when on battery

powercfg.exe /SETDCVALUEINDEX SCHEME_CURRENT 2a737441-1930-4402-8d77-b2bebba308a3 48e6b7a6-50f5-4782-a5d4-53bb8f07e226 1

#Display USB Selective Suspend when plugged

powercfg.exe /SETACVALUEINDEX SCHEME_CURRENT 2a737441-1930-4402-8d77-b2bebba308a3 48e6b7a6-50f5-4782-a5d4-53bb8f07e226 1

Hey I just wanted to chime in and say that I’ve been getting the same messages when using an Anker 65W PD charger with an appropriate Anker cable. I switched to a Framework charger and cable and the problem went away. Since I don’t have the equipment to properly test the Anker charger, I have no way of knowing whether the Anker charger is failing or if there’s some kind of Framework firmware incompatibility going on. If anyone has any suggestions on how to further narrow down the issue, I’m happy to help. For now, though, I’m sticking to the first party charger.