[RESOLVED] Disable touchpad while typing (Fedora)

Fedora 38
11th gen

I saw there was an old post regarding the same issue but on ubuntu. I’m looking to disable the touchpad in fedora.

I know there’s a setting in Gnome Tweaks that has this exact setting but in the past when I installed it messed with the screen resolution. Is there any other way?

Maybe the touchpad uses the libinput that has the feature of the disable-while-typing.

The ArchWiki page says libinput-config is an alternative on Wayland.

Here is a Fedora document for using libinput for X window-based window managers.
https://fedoraproject.org/wiki/Input_device_configuration

1 Like

junaruga provided one general direction you could go. There is no reason why it should have messed with resolution…unless you were using Xorg, then I could see something getting messed up. Was this with Wayland (default)?

2 Likes

I installed Gnome tweaks again and it seems to be working ok so far. Thanks for the tips!

1 Like

Yay! Delighted Gnome Tweaks came to the rescue here!