[RESOLVED] FW13 AMD 7840U Arch Graphics Output Corruption

Hi all, this problem only seemed to crop up somewhat recently (within the past ~2 weeks?) where graphics output to a single monitor at a time becomes corrupted, and it honestly looks like its drawing RAM with how uniform some of these structures are and there are specific parts that flicker almost like they’re being written to, but I assume its something to do with the AMD GPU Linux driver. I have the amdgpu.sg_display=0 in my kernel parameters which resolved the issue where parts of the screen would go white, but doesn’t seem to prevent this from happening. It also seems to mostly manifest when I’m interacting with window decorations or mouse movement causes something to change in the window, etc. I’m unable to take a screenshot of it, those all come out clean, which makes sense if its a GPU driver bug. Its happened to both external and the built in display, though as I said, seemingly only one at a time. Rebooting sometimes helps, but rarely gets rid of it entirely.

If I can provide any additional details to help troubleshoot, do let me know. I’ve put the output of neofetch down below which should cover most of the bases, along with some pictures I was able to capture of it happening. Thanks!

~> neofetch
                  .o+`                   ------------
                 `ooo/                   OS: Arch Linux x86_64
                `+oooo:                  Host: Laptop 13 (AMD Ryzen 7040Series) A7
               `+oooooo:                 Kernel: 6.7.0-arch3-1
               -+oooooo+:                Uptime: 4 hours, 58 mins
             `/:-:++oooo+:               Packages: 1349 (pacman)
            `/++++/+++++++:              Shell: fish 3.7.0
           `/++++++++++++++:             Resolution: 1920x1080, 1920x1080, 1503x1002
          `/+++ooooooooooooo/`           DE: GNOME 45.3
         ./ooosssso++osssssso+`          WM: Mutter
        .oossssso-````/ossssss+`         WM Theme: Adwaita
       -osssssso.      :ssssssso.        Theme: Adwaita-dark [GTK2/3]
      :osssssss/        osssso+++.       Icons: Adwaita [GTK2/3]
     /ossssssss/        +ssssooo/-       Terminal: zellij
   `/ossssso+/:-        -:/+osssso+-     CPU: AMD Ryzen 7 7840U w/ Radeon 780M Graphics (16) @ 5.1
  `+sso+:-`                 `.-/+oso:    GPU: AMD ATI c1:00.0 Phoenix1
 `++:.                           `-/+/   Memory: 14564MiB / 31279MiB
 .`                                 `/

I faced picture corruptions a few times similar to yours AND the well known white screen problem frequently on linux kernel v6.7.0 on Arch. Note that I got my laptop just last week recently and this was the latest kernel when I installed Arch.

I immediately downgraded to linux-lts which is v6.6.x and this solved the corruption problem. Then I added amdgpu.sg_display=0 to fix the white screen problem after searching the forum.

1 Like

Welcome to the community!

Let’s start with trying this. Reboot. Did this fix the issue? If not, I’d try linux-lts as suggested by bullza. You may need to append amdgpu.sg_display=0 as boot parameter.

Thanks Matt, I’ll give that a try and report back either if it continues to happen or if it seems to not, and I’ll see about trying to daily-drive the LTS kernel once the iGPU memory results are in.

1 Like

Been running with the increased GPU memory for a while now and it seems like that’s fixed things from what I can tell, haven’t experienced any issues since! I’ve added a section in the Arch Wiki documenting this workaround so its more easily discoverable for other users, hopefully. Thanks for the help Matt! (this was with amdgpu.sg_display=0 already in my boot parameters from fixing the white screen issue previously, for reference)

Fantastic on both the wiki front and the results! Marking solved.

Oh dear! I’m using increased GPU memory and am still plagued by graphics issues. I’m also tried setting the amd_sg=0 flag to no avail. Can this issue please be reopened?

This is an upstream amdgpu linux kernel bug: issue.

A patch for this has already landed in drm-misc-fixes, but isn’t yet in any kernel release. The initial patch had an issue that was fixed up right away, you can find both commits in one single patch file in this gist.

I’ve been running the patch on top of kernel 6.7.5.arch1-1 (Arch Linux package linux) for a few days now and the issue has disappeared.

1 Like

Update: It looks like this bug will be resolved in kernel 6.8 since the patch for this was merged in kernel 6.8-rc6.


Awesome, thank you for the update :slight_smile:

On kernel 6.8 I still have corruption issues. They only occur on the left quarter of the screen. On opening the laptop from sleep it often produces horizontal shaking for a minute for the whole screen and then stops leaving just the left hand artifacts.