[RESOLVED] Systemd suspend-then-hibernate wakes up after 5 minutes

This working really well on Fedora. Patched. All we need now is Ubuntu 22.04 OEM C and we’re on the right path.

Any luck on an Ubuntu patch or instructions on how to set the kernel flag on a 22.04 system? I’m seeing the same behavior with a sleep-then-shutdown script using rtcwake.

edit: just used the basic instructions from ubuntu here – Kernel/KernelBootParameters - Ubuntu Wiki and can confirm that on my 22.04 system running 6.2.0 AMD Framework 13 the rtc_cmos.use_acpi_alarm=1 kernel parmeter does seem to fix the interrupted suspend issue!

Also, for the benefit of anyone who finds this thread in the future, it seems this is a quick/easy way to test if the parameter is set correctly, it should return “Y”

$ cat /sys/module/rtc_cmos/parameters/use_acpi_alarm
Y
1 Like