[RESPONDED] 11th Gen Intel Core BIOS 3.17 Release

Another report:
3.10 (3.16) → 3.17 from Fedora 36 LVFS. Update went smoothly (updating from 100% plugged in worked. NVRAM boot variables were reset, so I had to re-setup those.)
Shortly after, I updated to Fedora 37. All seems fine so far.


I tried to enable testing but it is failing to refresh:

(fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.217: downloading https://cdn.fwupd.org/downloads/firmware-testing.xml.@compression@.jcat
(fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.218: Emitting ::status-changed() [downloading]
Downloading…             [    \                                  ](fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.359: download progress: 88%
(fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.359: download progress: 88%
Downloading…             [**********************************     ](fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.359: download progress: 100%
(fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.359: download progress: 100%
(fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.359: download progress: 100%
(fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.359: download progress: 100%
(fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.359: Emitting ::status-changed() [idle]
(fwupdmgr:4789): Fwupd-DEBUG: 13:18:22.359: status-code was 404
Downloading…             [***************************************]
Failed to download, server response was 404

running on openSuse Tumbleweed

sudo fwupdmgr --version
runtime   org.freedesktop.fwupd         1.8.7
runtime   org.freedesktop.fwupd-efi     1.0
runtime   com.hughsie.libjcat           0.1.12
runtime   com.dell.libsmbios            2.4
compile   com.hughsie.libjcat           0.1.12
runtime   org.kernel                    6.0.10-1-default
compile   org.freedesktop.gusb          0.3.10
compile   org.freedesktop.fwupd         1.8.7
runtime   org.freedesktop.gusb          0.3.10

With the “testing” remote enabled in my fwupd configuration I got the 3.17 BIOS installed last night. The Gnome “Software” app saw it and did the install for me(Fedora 37). So far so good. Per the usual I went into the bios afterward to reconfigure the charging limit.

Successful update from 3.10 to 3.17 in EndeavourOS (arch linux) via fwupdmgr. As usual, NVRAM got erased, but having rEFInd in my EFI fallback boot location ( esp/EFI/BOOT/BOOTX64.EFI ) meant that I did not even have to do the F3 trick to chainload my original rEFInd installation.

Since I upgraded the BIOS to 3.10 I also upgraded Fedora to 37. I just booted up with the latest kernel from updates-testing, 6.0.11-300.fc37 Starting this morning after the F37 upgrade I noticed this new error (first time in journalctl during the past year):

[  +0.052642] ACPI BIOS Error (bug): Could not resolve symbol [\_TZ.ETMD], AE_NOT_FOUND (20220331/psargs-330)
[  +0.000006] ACPI Error: Aborting method \_SB.IETM._OSC due to previous error (AE_NOT_FOUND) (20220331/psparse-529)

Nothing seems obviously broken, but I don’t know how to interpret these ACPI errors.



@feesh have you tried doing a full bios reset after the update? I don’t fully remember the process, it’s on here somewhere, you do a battery disconnect in the bios and then physically unplug the battery and plug the charger in and then the lights blink red you can plug things back in and boot… anyways when I updated from 3.07 to 3.10 the battery drained like crazy still, but after the reset I mentioned above things where fixed. This may help with the update to 3.17 as well, just a thought.

1 Like

Potential issue with this update. This morning, plugging a flash drive into a USB-A port on my laptop was not detected. Did it a few times and eventually it came up. The flash drive worked first go on my work laptop. Never had this problem before. Only difference was the recent BIOS update.

Hopefully just a fluke, but putting it out there for awareness.

1 Like

How do you downgrade in Windows? I’d like to know before I try the upgrade.

1 Like

How about just executing an older version ?

why would you do that?

I’m uing Win 11 and Ubuntu 22.04 and have installed each update as they are available and there hasn’t been any problems.

Is there anyone using NixOS that has found a way to do this?

Hmm, I reproduced what looks like the same thing here.

I only have one USB-A adapter, normally I use that to connect an older USB hub which then “carries” an external USB keyboard and a scanner.

I unplugged that:

[39123.036330] usb 3-3: USB disconnect, device number 2
[39123.036339] usb 3-3.3: USB disconnect, device number 4
[39123.126675] usb 3-3.4: USB disconnect, device number 6

and plugged in a flash drive. I got this on several attempts:

[39135.649747] usb usb3-port3: Cannot enable. Maybe the USB cable is bad?
[39137.225844] usb usb3-port3: Cannot enable. Maybe the USB cable is bad?
[39137.225995] usb usb3-port3: attempt power cycle
[39138.865786] usb usb3-port3: Cannot enable. Maybe the USB cable is bad?
[39140.649889] usb usb3-port3: Cannot enable. Maybe the USB cable is bad?
[39140.650068] usb usb3-port3: unable to enumerate USB device

Then I unplugged the USB A adapter and plugged it back in (same port). Then the flash drive started being recognized. Note the difference in USB identifier/enumeration(?):

[39230.276500] usb 2-2: new SuperSpeed USB device number 3 using xhci_hcd
[39230.288957] usb 2-2: New USB device found, idVendor=1f75, idProduct=0917, bcdDevice= 0.01
[39230.288966] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[39230.288969] usb 2-2: Product: USB DISK
[39230.288971] usb 2-2: Manufacturer:  
[39230.288973] usb 2-2: SerialNumber: xxxxxxxxxxxxxx
[39230.290940] usb-storage 2-2:1.0: USB Mass Storage device detected
[39230.291228] scsi host1: usb-storage 2-2:1.0
[39231.300389] scsi 1:0:0:0: Direct-Access                               1.00 PQ: 0 ANSI: 6
[39231.300950] sd 1:0:0:0: Attached scsi generic sg1 type 0
[39231.301170] sd 1:0:0:0: [sdb] 30310400 512-byte logical blocks: (15.5 GB/14.5 GiB)
[39231.301396] sd 1:0:0:0: [sdb] Write Protect is off
[39231.301404] sd 1:0:0:0: [sdb] Mode Sense: 23 00 00 00
[39231.301650] sd 1:0:0:0: [sdb] Write cache: disabled, read cache: disabled, doesn't support DPO or FUA
[39231.303903]  sdb: sdb1 sdb2 sdb3
[39231.304332] sd 1:0:0:0: [sdb] Attached SCSI removable disk

@Kieran_Levin I can not seem to update via LVFS or EFI/USB due to the fact that no battery is connected to the mainboard. How to update standalone boards?

1 Like

Just run the previous BIOS installer executable.

1 Like

I’m having the same trouble, mostly with the front left expansion slot as you look at the opened laptop. USB-A expansion on the right hand side works fine, although sometimes is intermittent in Windows - i.e I’ll hear the USB disconnect noise, then the USB connect noise as it drops in and out. Definitely seems, at least in my view, linked to the firmware update.

I’ll just add that I experienced a smooth update through fwupdmgr on Fedora 37, and several days later I’ve detected no regressions. None of the fixes, changes, or known issues are of particular importance to my usage, but I appreciate the security fixes and continued support from Framework for this machine. As I’ve said before, I was never aware of BIOS updates for any previous laptops (from Toshiba or HP) that I’ve owned, so it really says a lot that Framework is doing this.


I don’t think it is related to the update, I’m still on an older version and recently experienced the same thing. In fact if you search the forum there are a number of posts that seem to be related to the same or similar problems with USB-A devices.


Is there anyone using NixOS that has found a way to do this?

Here is one way:

  # bios/firmware update
  # https://knowledgebase.frame.work/en_us/framework-laptop-bios-releases-S1dMQt6F

  services.fwupd = {
    enable = true;

  environment.etc = {
    # enable lvfs-testing remote to get the newest firmware from framework
    "fwupd/remotes.d/lvfs-testing.conf" = lib.mkForce {
      source = pkgs.runCommand "fwupd-lvfs-testing-enabled.conf" { } ''
        sed "s,^Enabled=false,Enabled=true," \
        "${pkgs.fwupd}/etc/fwupd/remotes.d/lvfs-testing.conf" > "$out"

    # recommended by framework for firmware 3.10
    "fwupd/uefi_capsule.conf" = lib.mkForce {
      source = pkgs.runCommand "fwupd-uefi-capsule-update-on-disk-disable.conf" { } ''
        sed "s,^#DisableCapsuleUpdateOnDisk=true,DisableCapsuleUpdateOnDisk=true," \
        "${pkgs.fwupd}/etc/fwupd/uefi_capsule.conf" > "$out"

To make things slightly simpler, to enable lvfs-testing on NixOS all you should need to do is

services.fwupd = {
  enable = true;
  extraRemotes = [ "lvfs-testing" ];

You’d still need the second part to define DisableCapsuleUpdateOnDisk=true though.


Just tried this, same results :frowning: