[RESPONDED] 1TB expansion card disconnects randomly

There’s a Bios 3.08?

Bios 3.08 will be released soon.

Kieran said that they were having some issues upstream of framework that they couldn’t solve, once that gets solved it’s ready to release.

I typod. 3.07

I’ll go edit my post. Sorry I didn’t catch it. Thanks for catching it! :sweat_smile:

  1. 3.07
  2. Debian GNU Linux 11.3, Kernel 5.16.12-1~bpo11+1
  3. Last time it happened: 2 USB C cards left and right nearest to the screen, 1 USB A card left, 1 1TB card right.


The disconnect happened to me again after two months without a problem. This is with the “Better Performance” USB Disk Option enabled. That option worked so well for me for so long! I’ll report back if this becomes a regular disconnect.

As always, I was running my python program which parses a bunch of json data and puts it into a sqlite database (both the data and db are on the 1 TB expansion card) when Windows popped up a message saying that the disk disconnected.

The system event log has these 3 warnings:

Source: disk
Date: 4/5/2022 8:50:04 AM
Event ID: 153
Description: The IO operation at logical block address 0x219ae50 for Disk 1 (PDO name: \Device\00000056) was retried.

Source: disk
Date: 4/5/2022 8:50:04 AM
Event ID: 157
Description: Disk 1 has been surprise removed.

Source: exfat
Date: 4/5/2022 8:50:56 AM
Event ID: 141
Description: {Delayed Write Failed} Windows was unable to save all the data for the file \Device\HarddiskVolume5; the data has been lost. This error may be caused if the device has been removed or the media is write-protected.

System Information:

  1. Bios 3.07
  2. Windows 10 Pro 21H1 19043.1586
  3. Left-Back: USB-C with power plugged in, Left-Front: USB-A with a Samsung Galaxy S7 plugged in, Right-Back 1TB expansion card, Right-Front USB-A with nothing plugged in.

Edit: I just had another similar disconnect after 10 days of smooth sailing. Oh actually, I only had the power plugged in. The other slots were unplugged but the same.

Same issue happening with me.

  1. Bios 3.02
  2. Windows 11 Home 10.0.22000 Build 22000
  3. 1TB expansion card, bottom right slot. Other slots are power/USB-C on top right, HDMI top left, USB-A top right.

Any updates on this problem?

Would like an update as well. Windows has begun disconnecting it every half-hour of use or so, Linux has been mostly okay.

I’ve been seeing this too, first on a 256MB card, then on the 1TB card I ordered to replace it.

  1. 3.07
  2. Ubuntu 21.10 5.14.21-051421-generic
  3. Currently, just the 1TB card and three USB-C cards, with power plugged into the northeast port. The 1TB card is in the southwest bay, but I’ve tried other bays too and hit the same problem.

I am having the same connect/disconnect issue when using USB thumb drives. I’ve tried switching the expansion cards to different slots with no luck.

BIOS - 3.07
Windows 11 Pro - build 22000.613 (21H2)
I used both a USB-C and USB-A expansion cards and have trouble with thumb drives on both. I’m not 100% certain if the problem extends to USB HDD and SSD but I believe it does happen using those devices as well.

Thank you.

I seem to be having this problem when running Fedora Linux off of the 1TB expansion card. My laptop is from Batch 1, and I have tried the EMI sticker fix, although I have not noticed a problem using any other expansion cards on any expansion bay. The expansion card is the newer version with the thermal pad.

  1. Bios 3.07
  2. Fedora 35 (Workstation), kernel 5.16.20-200.fc35.x86_64
  3. Occurs in all four expansion slots, with USB-C expansion cards in every other slot.

I think I’m having the same problem. My computer is about two months old. In the expansion slots I have USB-C (back) and USB-A (front) on the left, USB-C (back) and a 1TB drive (front) on the right. I usually plug it in from the left USB-C with a 96W Apple charger and have nothing in the other slots. Though I’m pretty sure it’s crashed with and without being plugged in.

Recently installed Parrot Linux on the 1TB drive with BTRFS. After 1 - 6 hours of operation, the OS will crash and the screen will fill with journald errors complaining that it can’t write to the disk. This happens both when I’m in the middle of doing stuff and when it’s idle (I don’t have any automated power management/sleep/hibernate stuff in place).

btrfsck and hardware checks say everything is good.

Same here. Problem occurs on any card bay, btrfs and ext4 filesystems.
Bios: 3.07
OS: Fedora 35 on card, Win11 on 1Tb NVME
250Gb expansion card, 1 type c, 1 HDMI and 1 type A.

Recently installed Fedora 36, 5.17.2 kernel. No problems for ~20h uptime (non continuous).

I suppose I can’t keep editing my old post with disconnect updates. I have one more to report, the first in 1.5 months. This time I wasn’t doing anything with the drive. I was just working on my computer and using the good old C:\ drive, when I saw the popup that the D:\ drive had disconnected. The event log simply says:

Log Name: System
Source: disk
Date: 5/19/2022 1:51:26 PM
Event ID: 157
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: WorkBrian
Disk 1 has been surprise removed.

1 Like

Is there any update from Framework on this issue? It was first raised in Dec ‘21 and you jumped into the chat around Feb ‘22.
I recently cancelled my order on the basis of this problem. It would be good to know it’s in hand.


Has anyone tried the expansion card with another thunderbolt equipped machine? I don’t have another to test myself. I wonder if the disconnects happen on another machine, if so, the issue is probably with the card itself.

I have a MacBook that I could test on, but since the problem only happens sporadically, I’m not sure what the best way to test would be in order to maximize the chance of reproducing the disconnect.

My own theory of the problem is that it’s related to a different issue: [RESPONDED] Quirky USB Port

1 Like

The storage card is USB4, not Thunderbolt. I do agree that we need to look for someone with a USB4 port that can see if it’s a framework-specific issue. I’ll ask around, thanks for the idea!


Hi everyone, just following up on this. We provided our Storage Expansion Card supplier with a setup to try reproducing this, and they weren’t able to on their end. Internally, we have been able to trigger the behavior rarely with one setup, but we also haven’t been able to create a reliably reproducing scenario for it. We’re collating the responses in this thread to create a more reproducible setup so that both we and our supplier can replicate and then root cause the issue.