[RESPONDED] 1TB expansion card disconnects randomly

Thank you for reporting this, I’ll keep an eye out on mine this week.


Will install that later today. If this works I’ll be very happy!


With the reports of 3.09 “fixing” this, I tried with the install that was doing this regularly. Logged in, updated the OS, and started updating some games for the screen to go blank and start throwing the disconnect, and read only errors.

I’ve re-installed the OS, and have started to perform the use case described in my previous reply to see if it was a situation of once borked, always borked. Hoping that the BIOS update ‘did’ fix this, but not holding my breath considering the inability to reproduce for the manufacturing partners.

As an update, this BIOS update has not solved the issue for me. Error happened quicker than I am used to it doing so. Same as previous, Lockup of GUI, Dump to Terminal, spam errors onto the screen.

Edit: For context sda3 is my root partition.

Same issue here…it’s almost gotten worse with the 3.09 BIOS update.

Framework - batch 5, I think ?
CPU: i7-1185G7
HDD: 2TB WD 850 (with latest firmware)
OS: Windows 10 Pro, 21H2, build: 19044.1826
1TB add-on, have tried ALL 4 ports with similar random disconnects (even when it’s not even being utilized, i.e. I heard & get a notification on USB), get that diskpart.inf “warning” in the Windows Logs but don’t point to anything other than the device

This has gone on long enough…I think. How come there’s no fix for this yet?

This 1TB expansion card’s only positive thing is the form factor…that it fits into a Framework expansion slot. But it’s less reliable, slower (due to the interface speed), lower TBW and more expansive than a 1TB SN850 or a 1TB 980 Pro. Like, on a ‘value’ side of things…this card has extremely poor value as it stands at the moment.


I’d be curious to hear if people have similar problems with other USB drives. I think I’ve had a USB backup drive disconnect once or twice, but I don’t use them often enough to notice (and I wasn’t analyzing this problem back then.)

The 1 TB expansion card is only disconnecting every month or two for me even with it plugged in constantly and used every day to store and process ~1GB of data.

The reason I bring this up is that I keep wondering if the problem isn’t in the drive itself, but rather in the Framework’s USB connections.

BIOS 3.09 did not fix my issue. I’ve had my 250GB connected through a USB-C card for about two days, and it just dropped and reattached.

My overall experience has been that this is independent of charger connectivity, storage card location, and other attached peripherals. Sustained reads seem to trigger it more often than when it is left idle, but it will still trigger at idle (such as this most recent one).

Batch: 6
CPU: i5-1135g7
RAM: 1x16GB
HDD: 2TB SN750
BIOS: 3.09
OS: Win10 Pro
Expansion Cards+connections (clockwise from back left):
Full Power Magnetic Charging Card → charger
USB-C → storage
USB-C → Ethernet hub → peripherals
USB-C → TB3 cable → ADT-Link R43SG-TB3 → GTX1650S

Now that the 12th gen boards are in the wild, does anyone have a 1TB expansion card to use / test with?

Wonder if the 12th gen boards also have disconnection issues…or not.


Definitely wanting to know that same!

Curious as well! This would narrow the problem down to being the 11th gen framework itself or the drive.

I’m getting to a point where I would like to jump onto the 12th gen bandwagon…but need to know what I’m really getting myself into ahead of time.

Anyone else have a problem with the 256 and 1tb expansion cards just randomly disconnecting? I’m running windows 11 and it happens every once in a while when idle or when accessing files on the drive. It’s kinda annoying because it crashes all the programs and games that I have on them. Any help is greatly appreciated.

Is this with the 11 gen or 12 gen ?

It’s with the 11th gen, running the 3.10 bios update.

1 Like

No problem with the 256GB on 11th gen

1 Like

Ah, might just be a problem with my 256gb module then, Though the random disconnects happen more often with the 1tb module, so it’s less of an issue.

@Ironsidemaster I mentioned this earlier in the thread, but I had a lot of “Delayed Write Failed” errors until I disabled the Windows “Quick Removal” option for my 1 TB expansion card.

Since that change, I’ve only had 3 disconnects. And none since May 19th. I know other people have said this option hasn’t helped them. But it’s worth a try!


That’s just delays the flush to storage, doesn’t it?

i.e. The card still disconnects, but it’s able to auto connect back online (?). Thereby minimizes your chance of attempt to write to storage while it’s disconnected.

There’s no official word on what IS happening or why it IS happening…does that mean Framework doesn’t know the actual cause yet…and so there’s no fix (yet)?

Known issue with unknown root cause, and unknown fix isn’t really comforting.

1 Like

@brianshmrian I’ll give it a try, thanks for the suggestion!

1 Like