[RESPONDED]🎅 3.19 BIOS Upgrade for Linux?

Dear Santa:

I’ve been doing my best to be good this year. When the 61 Wh battery was released, I quickly ordered it. Unfortunately, it requires the 3.19 BIOS release on my 11th gen laptop to enjoy its increased capacity, and this version is not yet available for installation on Linux or LVFS. Santa, please bring me a Linux-compatible 3.19 BIOS release this Christmas.

Hugs and cookies,



Just unzip the efi firmware into the vfat EFI partition (normally mounted at) /boot/efi/ and then launch efi shell from the FW bios pointed at the unziped from the firmware setup utility at the shim efi file.

Where can I locate the EFI firmware?

:christmas_tree: Hello little boy :christmas_tree:

you’ve been nice, no need to wait for Dec 25th.

The thread about the 3.19 update is 11th Gen Intel Core BIOS 3.19 release

The BIOS can be downloaded from Framework Laptop BIOS and Driver Releases (11th Gen Intel® Core™)

The instructions to update are on the page Updating BIOS on Linux (section “Linux/Other/UEFI Shell update”)



Thanks. I can’t seem to find the actual EFI zip file to download. None of the listed pages appear to contain any such link.

You can follow the steps in the last post here to install the update without needing to have windows installed: [RESOLVED] How do I install BIOS updates with Linux - #7 by ChrisGC

Yes as Matt stated in that thread, you have to option to use windwos2go to update to 3.19 bios.

Will these instructions work to upgrade an 11th gen laptop to 3.19? I’ve been really frustrated with my battery life and was really excited to get my new 61Wh battery, only to find out that it won’t work without an updated BIOS. I’m on Pop_OS 22.04 if that matters.

Hi @baptistemm and @pbryan,

Recently purchased a FW13 laptop and while I did not NEED to update the bios because of a hardware limitation; I wanted to because of all the improvements/security updates. The version mine came with was I think 3.06?

I read a post that complained about there only being a Windows BIOS updater; and the reason if memory serves me is they provide a Windows updater to their board partners first since that is what the vast majority of them use.

Another post I read (again just going from memory here) stated someone in the same situation did the following:

  1. Download and unpack the Windows v3.19 BIOS to a clean USB.
  2. Download and create a Windows 10 USB from the Microsoft Media Creation Tool (clearly they had access to a Windows machine at some point)
  3. Open up the FW13, remove the NVME drive and install another “spare” temporary in the NVME slot.
  4. Leaving everything apart, booted the machine from the Windows 10 USB and installed it on the “spare” NVME drive. Don’t give it a license number it is just a means to an end.
  5. After installing Windows 10 and booting to the real operating system; letting it settle down (5 minutes or so); THEN insert the 3.19 BIOS usb created above.
  6. Run the BIOS update and be patient because it has to update the Intel ME along with both halves of the system board.
  7. When the machine says it needs to reboot; LET IT and wait patiently, this is where the two halves get updated. A different boot screen will appear and it will check the firmware and update the components it needs to. [Mine finished right as I was coming back and I could not see if BOTH sides of the board had been update before it rebooted itself back into Windows because it was complete; not trusting both sides were done, I elected to restart the 3.19 BIOS update again (See #6 above); it did, correctly; twice; thanks to my OCD if it was done right]
  8. Shutdown the machine and swap the NVME “spare” with the one taken out from #3 above.
  9. Reassemble and power on your FW13 with 3.19! Your BIOS settings might need to be tweaked as the firmware update can reset some things if you did not have everything left at the factory defaults.

Your bootloader also may have been compromised (GRUB, reEFI, etc.) I am not familiar with restoring or reinitializing the bootloader; there are some help articles in the forum that should address the issue of the bootloader being overwritten or reconfigured unexpectedly (almost always because Windows likes to stick its fingers everywhere).

Again I can not take credit for this; it was someone else who had posted what they did to get the 3.19 BIOS and was Linux ONLY; though I did think of the same thing after realizing it was A workaround; albeit a slightly unorthodox one.

I believe one of the Linux guys who works for FW posted a guide to rework the UEFI Bios updater from v3.17 BIOS to work for v3.19 BIOS; but a significant number of specific steps needed to be taken due to some hardcoding in the BIOS updater from before. They prefaced it with it being experimental and not an officially documented means to update to v3.19 for Linux users.

It all boils down to multiple embedded systems from different vendors all on the same board; there is a one or two right orders they need to be updated in and several hundred incorrect orders that will possibly brick your board.

Alas, do not follow the instructions from: Updating BIOS on Linux
and apply this to the v3.19 BIOS or you might end up with an expensive and poorly performing rectangular frisbee/coaster.


For reasonable values for recent, you would not have purchased an 11th gen Intel. The 3.19 bios is specific for 11th gen. That upgrade does not apply to your laptop.

That should really not be the case, right? LVFM will simply say that no update is available (or at least not find 3.19, because it’s not there) and there’s no UEFI shell to be downloaded for 3.19 either. And if you try it with a different UEFI shell, I would expect it would check if the payload applies to the hardware and fail based on the mismatch.

With the 12th gen update finally out, hopefully 11th UEFI shell packaging is the next one.

(another correction: the solution to “build your own” UEFI shell was not posted by a FW employee. That looked to me like a solution without guardrails and hence one where you could actually brick your device. The solution with replacing NVMe drives was posted by an employee, but I read that one as a “YMMV” solution myself)

Just to be clear.

(You will need to use Windows until we’re ready to EFI Shell Update beta test - not there yet. We’re doing Beta testing on the update for 12th gen ATM.)

  • This guide: Updating BIOS on Linux is only used where there is in fact a LVFS update or EFI Shell Update available. At this time, this is not the case for 3.19.

This is also correct.

1 Like

Is there any info in regards to the progress on the BIOS 3.19 EFI Shell Update for 11th Gen Linux users?

Also, I have been using 61Wh battery on my 11th Gen Ubuntu 23.10 device with BIOS v3.10… where can I find the most updated BIOS version available for my setup? Because the only site I can find is for the 3.19 that’s not currently available yet.

1 Like

It seems that there are two threads (maybe more) about this issue, here is also some information:
but the TLDR is coming “soon” … or install windows in the interim to perform the update …
and seeing this was ~7months ago… i still don’t think we will see movement anytime soon.

1 Like

I eventually broke down and installed Windows on an NVME drive I had, to upgrade the BIOS. Now I get the full 61 Wh capacity.

1 Like

Like others, I’m running Linux (Ubuntu) and wishing to update my 11th gen bios. I tried to create a bootable usb dos drive using rufus (in hopes that I could then run the bios upgrade exe from Framework), but all reasonable combinations I’ve tried from rufus don’t result in anything my Framework seems to consider bootable.

@pbryan is there a reason you went with an NVME to boot to in order to run the bios upgrade?

I probably could have figured how to install Windows on an external drive, but Windows on the primary drive was just a known working config for me.

I did make a working win11 to go install that worked on my framework 13 using rufus recently so it is possible.

1 Like