[RESPONDED] dGPU not running at full speed on Fedora?

Odd issue I’ve started having, seemingly out of nowhere. Everything was fine for a while, but now suddenly the dGPU has been underperforming. I checked nvtop, and for some reason, the dGPU is only running at around 1GHz, instead of the normal 2.2. This isn’t happening in Windows. The laptop is plugged in with the 180W adapter and the power profile is set to performance. The issue has also been off and on - yesterday, I was having the issue trying to play Helldivers, so I swapped to windows for a while. Then I switched back to Fedora to try and solve the issue and it was back to running at full speed. Now again I’m trying to game and it’s not running at full speed. The dGPU temperature is only 60C and the fans are pretty quiet so it’s definitely not thermal throttling. The games have the DRI_PRIME=1 environment variable and are using the dGPU. But it’s just refusing to clock high enough. I can’t think of any system changes that could have caused this, obviously there are frequent updates in fedora but I can’t think of any that would change this. Anyone got any ideas?

Some more info

  • The battery is no longer draining while gaming. It used to do that.
  • The fans used to get pretty loud while gaming. They no longer do.
  • Nothing seems to change when I set the power profile to balanced instead of performance, or vice versa.
  • Uninstalling power-profile-daemon entirely does not fix the issue, so the problem doesn’t seem to be it limiting things.
  • sensors reports the maximum power allowed for the GPU to be 100W, but it’s only drawing 48 at most.

This is really bothering me since it started happening out of the blue with no rhyme or reason as to why. Worked fine a week ago.

Knowing what distro you are using and whether you updated recently would be good starters in possibly helping.

Fedora 39, KDE plasma spin. But I figured out the issue just now.

Issue appears to be with the kernel. Bad performance with low clock speed on version 6.8.4, but booting into 6.7.11 fixes the issue entirely. Again, it’s inconsistent on 6.8.4, works fine sometimes (probably why I didn’t realize it was the kernel at first, cause it was working fine on 6.8.4 when I first updated). For the time being I’ll just use 6.7.11, but I suspect more people would have noticed by now if it was an issue for everyone so I’m wondering if there’s still something wrong with my machine specifically somehow.

1 Like

That is awesome to hear! I know how frustrating it can be when things just stop working properly and there doesn’t seem to be a reason on Linux.

Linux is awesome, but learning how to catch all that can possibly go wrong is why I stick with LTS.

Glad to hear you’ve got your 16 back to full power and thanks for sharing the solution!

it appears that something was in fact wrong with my system – not sure what, but reinstalling kernel 6.8.4 seems to have fixed the issue. Although, as I mentioned it was inconsistently happening before, so hopefully the fix persists.

If I were to guess, probably just a driver issue? On windows this is the kind of issue reinstalling drivers often fixes. With the Radeon drivers being included in the linux kernel, I guess reinstalling the whole kernel does the same thing.

Try downgrading to Fedora’s 6.7 kernel, if that helps it’s probably a duplicate of


1 Like

I might be running into that issue. 6.8.4 as well.
I also have the issue where the CPU is stuck on 20W max, so fans never ramp up, and everything is slow.

$ modinfo amd-pmf
modinfo: ERROR: Module amd-pmf not found.

Yup, seems to be it.

makes sense. Stopped working again today, so reinstalling the kernel didn’t actually fix it, and the modinfo amd-pmf also results in the module not being found. Gonna downgrade to 6.7.11 for now then.

This the next thing to try for sure, downgrade to 6.7.

yeah, everything is working great in 6.7. Tried 6.9 from rawhide but my screen started flickering when I got the the login screen so gonna just stick to 6.7 for the time being. Hopefully this is fixed soon!


Do you think you can pin my post regrading this bug? This might help prevent duplicate posts.

I also plan to update that post when the Fedora team releases the fixed/updated kernel and I have tested to ensure that the bug is resolved.

Looks like a fix is coming with 6.8.5, so we should all be good once that’s released.

Can confirm, I just installed 6.8.5 and tested. amd-pmf module loaded as expected.

Additionally, tested in game and was able to hit 97 watts in Cyberpunk 2077.

Where’d you find the 6.8.5 release? I was looking for it earlier but I couldn’t find it, granted I didn’t have time to look for long.

Edit: nvm, just saw your post in the other thread.

1 Like

@Owen I just downloaded:


Put them into a folder, then:

# cd /folder/path
# sudo dnf install *

Then, reboot, and profit.

1 Like

Any idea when the fix will be available in the standard dnf update?

Likely within the week, 6.8.4 was pushed to stable two days after being submitted to testing, 6.7.11 in 4.

1 Like

If you enable the “updates-testing” repo - it is now available for download

Instructions are here for F40: FEDORA-2024-6d35739db7 — security update for kernel — Fedora Updates System
and F39: FEDORA-2024-33a9ea72d1 — security update for kernel — Fedora Updates System

1 Like