[RESPONDED] Fedora 39 Kinoite Fingerprint Reader Not Working

I’m on the AMD 7840U and everything is running great so far except I cannot get the fingerprint reader to work. I’ve tried following the guide to update the firmware, but I’m running into errors.

greg@icarus:/var/home/greg$ fwupdmgr refresh --force
Updating lvfs
Downloading… [ - ]
Successfully downloaded new metadata: 2 local devices supported
greg@icarus:/var/home/greg$ fwupdmgr update
Devices with no available firmware updates:
• WD BLACK SN850X 1000GB
• Fingerprint Sensor
Devices with the latest available firmware version:
• System Firmware
• UEFI dbx
greg@icarus:/var/home/greg$ sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab
[sudo] password for greg:
Loading… [******** ]07:02:29.441 FuEngine failed to add device /sys/devices/pci0000:00/0000:00:08.1/0000:c1:00.0: ioctl error: Bad address [14]
Decompressing… [ - ]
generic GUID requires a CHID, child, parent or sibling requirement

If anyone has suggestions or a fix please let me know.

1 Like

I had a similar issue when I was on Kinoite Beta some time ago.

I’ve solved it running fwupdtool using a live Manjaro XFCE as it runs on X11.
After upgrading the firmware the fingerprint reader started working as it should.

I read in other threads that some people managed to run fwupdtool in Fedora without issues, so YMMV.

1 Like

I believe this is because the firmware cab is not expressing what systems it applies to properly.

When it’s posted to LVFS, LVFS will force a CHID requirement.


I was one, likely because I was still using fwupd 1.9.7, before the change that Mario highlighted rolled out. Fedora is on 1.9.9 now.

Hopefully this update makes it to LVFS soonish.

1 Like

I’m running into this too on Fedora 39 Silverblue (Universal Blue Main). Is the current solution to boot something older from a flash drive and update firmware from that?

1 Like

Well, for anyone else who stumbles across this with the same question, booting Ubuntu 22.04.3 live from USB and following the same instructions from that worked.

1 Like

Appreciate everyone working through this. I have asked for new input kits to re-test our previous (failed) LVFS attempts - hence why we ended up on the cab files.

Once I confirm, first hand, that this works as it should and can replicate those steps taken for the guide, we’ll be switching back to LVFS then. I want to be able to step by step, experience with the update for the guide’s documentation. My FP readers here at the office are from 11th and 12th gen kits. So once I get a refresh on this for testing, we’ll re-open the LVFS beta testing.


What is the recommended way to get the fingerprint scanner up and running with the new guide [Beta] LVFS Fingerprint Reader Firmware for Framework Laptop 13, 13th Gen Intel Core & AMD 7040 Series fingerprint reader on Fedora 39 and Ubuntu 22.04 - #3 by Matt_Hartley?

The dnf command is obviously not working on the immutable distro, is there an alternative with rpm-ostree?